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STEEL FRAME DESIGN

Technical Note 1
General Design Information

This Technical Note presents some basic information and concepts that you
should know before performing steel frame design using this program.

Design Codes
The design code is set using the Options menu > Preferences > Steel
Frame Design command. You can choose to design for any one design code
in any one design run. You cannot design some elements for one code and
others for a different code in the same design run. You can however perform
different design runs using different design codes without rerunning the
analysis.

Units
For steel frame design in this program, any set of consistent units can be
used for input. Typically, design codes are based on one specific set of units.
The documentation in this series of Technical Notes is typically presented in
kip-inch-seconds units.

Again, any system of units can be used to define and design a building in this
program. You can change the system of units that you are using at any time.

Overwriting the Frame Design Procedure for a Steel
Frame
The three procedures possible for steel beam design are:

 Steel frame design

 Composite beam design

 No design
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Technical Note 1 - 2 Design Load Combinations

By default, steel sections are designed using the steel frame design procedure
or the composite beam design procedure. A steel frame element qualifies for
the Composite Beam Design procedure if it meets all of the following criteria:

 The line type is Beam; that is, the line object is horizontal.

 The frame element is oriented with its positive local 2-axis in the same
direction as the positive global Z-axis (vertical upward).

 The frame element has I-section or channel section properties.

If a steel frame member meets the above criteria for composite beams, it
defaults to the composite beam design procedure. Otherwise, it defaults to
the steel frame design procedure.

A steel frame element can be switched between the Steel Frame Design,
Composite Beam Design (if it qualifies), and the "None" design procedure.
Assign a steel frame element the "None" design procedure if you do not want
it designed by the Steel Frame Design or the Composite Beam Design post-
processor.

Change the default design procedure used for steel frame elements by se-
lecting the beam(s) and clicking Design menu > Overwrite Frame Design
Procedure. This change is only successful if the design procedure assigned to
an element is valid for that element. For example, if you select a steel beam
and attempt to change the design procedure to Concrete Frame Design, the
program will not allow the change because a steel frame element cannot be
changed to a concrete frame element.

Design Load Combinations
The program creates a number of default design load combinations for steel
frame design. You can add in your own design load combinations. You can
also modify or delete the program default load combinations. An unlimited
number of design load combinations can be specified.

To define a design load combination, simply specify one or more load cases,
each with its own scale factor. See UBC97-ASD Steel Frame Design Technical
Note 8 Design Load Combinations, UBC97-LRFD Steel Frame Design Technical
Note 22 Design Load Combinations, AISC-ASD89 Steel Frame Design Techni-
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cal Note 36 Design Load Combinations and AISC-LRFD93 Steel Frame Design
Technical Note 46 Design Load Combinations for more information.

Analysis Sections and Design Sections
Analysis sections are those section properties used for a frame element to
analyze the model when you click the Analyze menu > Run Analysis com-
mand. The design section is whatever section has most currently been de-
signed and thus designated the current design section.

It is possible for the last used analysis section and the current design section
to be different. For example, you may have run your analysis using a W18X35
beam and then found in the design that a W16X31 beam worked. In this
case, the last used analysis section is the W18X35 and the current design
section is the W16X31. Before you complete the design process, verify that
the last used analysis section and the current design section are the same
using the Design menu > Steel Frame Design > Verify Analysis vs De-
sign Section command.

The program keeps track of the analysis section and the design section
separately. Note the following about analysis and design sections:

 Assigning a line object a frame section property using the Assign
menu > Frame/Line > Frame Section command assigns this sec-
tion as both the analysis section and the design section.

 Running an analysis using the Analyze menu > Run Analysis com-
mand (or its associated toolbar button) always sets the analysis sec-
tion to be the same as the current design section.

 Using the Assign menu > Frame/Line > Frame Section command
to assign an auto select list to a frame section initially sets the analysis
and design section to be the section with the median weight in the
auto select list.

 Unlocking the model deletes design results, but it does not delete or
change the design section.
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Technical Note 1 - 4 Second Order P-Delta Effects

 Using the Design menu > Steel Frame Design > Select Design
Combo command to change a design load combination deletes design
results, but it does not delete or change the design section.

 Using the Define menu > Load Combinations command to change
a design load combination deletes your design results, but it does not
delete or change the design section.

 Using the Options menu > Preferences > Steel Frame Design
command to change any of the steel frame design preferences deletes
design results, but it does not delete or change the design section.

 Deleting the static nonlinear analysis results also deletes the design
results for any load combination that includes static nonlinear forces.
Typically, static nonlinear analysis and design results are deleted when
one of the following actions is taken:

 Use the Define menu > Frame Nonlinear Hinge Properties
command to redefine existing or define new hinges.

 Use the Define menu > Static Nonlinear/Pushover Cases
command to redefine existing or define new static nonlinear load
cases.

 Use the Assign menu > Frame/Line > Frame Nonlinear
Hinges command to add or delete hinges.

Again note that this only deletes results for load combinations that include
static nonlinear forces.

Second Order P-Delta Effects
Typically design codes require that second order P-Delta effects be considered
when designing steel frames. The P-Delta effects come from two sources.
They are the global lateral translation of the frame and the local deformation
of elements within the frame.

Consider the frame element shown in Figure 1, which is extracted from a
story level of a larger structure. The overall global translation of this frame
element is indicated by ∆. The local deformation of the element is shown as δ.
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The total second order P-Delta effects on this frame element are those caused
by both ∆ and δ.

The program has an option to consider P-Delta effects in the analysis. Con-
trols for considering this effect are found using the Analyze menu > Set
Analysis Options command and then clicking the Set P-Delta Parameters
button. When you consider P-Delta effects in the analysis, the program does a
good job of capturing the effect due to the ∆ deformation shown in Figure 1,
but it does not typically capture the effect of the δ deformation (unless, in the
model, the frame element is broken into multiple pieces over its length).

In design codes, consideration of the second order P-Delta effects is generally
achieved by computing the flexural design capacity using a formula similar to
that shown in Equation. 1.

MCAP = aMnt + bMlt Eqn. 1

where,

MCAP = flexural design capacity

∆

δ

Original position of frame
element shown by vertical
line

Position of frame element
as a result of global lateral
translation, ∆, shown by
dashed line

Final deflected position of
frame element that
includes the  global lateral
translation, ∆, and the
local deformation of the
element, δ

Figure 1 The total Second Order P-Delta Effects on a Frame Element
Caused by Both ∆∆∆∆ and δδδδ
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Technical Note 1 - 6 Element Unsupported Lengths

Mnt = required flexural capacity of the member assuming there is
no translation of the frame (i.e., associated with the δ de-
formation in Figure 1)

Mlt = required flexural capacity of the member as a result of lat-
eral translation of the frame only (i.e., associated with the ∆
deformation in Figure 1)

a = unitless factor multiplying Mnt

b = unitless factor multiplying Mlt (assumed equal to 1 by the
program, see below)

When the program performs steel frame design, it assumes that the factor b
is equal to 1 and it uses code-specific formulas to calculate the factor a. That
b = 1 assumes that you have considered P-Delta effects in the analysis, as
previously described. Thus, in general, if you are performing steel frame de-
sign in this program, you should consider P-Delta effects in the analysis be-
fore running the design.

Element Unsupported Lengths
The column unsupported lengths are required to account for column slender-
ness effects. The program automatically determines these unsupported
lengths. They can also be overwritten by the user on an element-by-element
basis, if desired, using the Design menu > Steel Frame Design >
View/Revise Overwrites command.

There are two unsupported lengths to consider. They are l33 and  l22, as shown
in  Figure 2. These are the lengths between support points of the element in
the corresponding directions. The length  l33 corresponds to instability about
the 3-3 axis (major axis), and  l22 corresponds to instability about the 2-2 axis
(minor axis). The length  l22 is also used for lateral-torsional buckling caused
by major direction bending (i.e., about the 3-3 axis).

In determining the values for l22 and l33 of the elements, the program recog-
nizes various aspects of the structure that have an effect on these lengths,
such as member connectivity, diaphragm constraints and support points. The
program automatically locates the element support points and evaluates the
corresponding unsupported length.
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 for the unsupported length of a frame element to be evaluated
m as greater than the corresponding element length. For exam-
 column has a beam framing into it in one direction, but not the
or level. In this case, the column is assumed to be supported in

 only at that story level, and its unsupported length in the other
exceed the story height.

ength Factor (K)
 automatically determines K-factors for frame elements. These
 be overwritten by the user if desired using the Design menu >
e Design > View/Revise Overwrites command. See the
t the end of this section for some important tips about how the

ulates the K-factors.

 algorithm has been developed for building-type structures,
lumns are vertical and the beams are horizontal, and the behav-
y that of a moment-resisting nature for which the K-factor cal-
latively complex. For the purpose of calculating K-factors, the
 identified as columns, beams and braces. All elements parallel

or and Minor Axes of Bending
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Technical Note 1 - 8 Element Unsupported Lengths

to the Z-axis are classified as columns. All elements parallel to the X-Y plane
are classified as beams. The rest are braces.

The beams and braces are assigned K-factors of unity. In the calculation of
the K-factors for a column element, the program first makes the following
four stiffness summations for each joint in the structural model:
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where the x and y subscripts correspond to the global X and Y directions and
the c and b subscripts refer to column and beam. The local 2-2 and 3-3 terms
EI22/L22 and EI33/L33 are rotated to give components along the global X and Y
directions to form the (EI/L)x and (EI/L)y values. Then for each column, the
joint summations at END-I and the END-J of the member are transformed
back to the column local 1-2-3 coordinate system and the G-values for END-I
and the END-J of the member are calculated about the 2-2 and 3-3 directions
as follows:
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If a rotational release exists at a particular end (and direction) of an element,
the corresponding value is set to 10.0. If all degrees of freedom for a par-
ticular joint are deleted, the G-values for all members connecting to that joint
will be set to 1.0 for the end of the member connecting to that joint. Finally, if
GI and GJ are known for a particular direction, the column K-factor for the
corresponding direction is calculated by solving the following relationship for
α:
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from which K = π/α. This relationship is the mathematical formulation for the
evaluation of K-factors for moment-resisting frames assuming sidesway to be
uninhibited. For other structures, such as braced frame structures, the K-
factors for all members are usually unity and should be set so by the user.
The following are some important aspects associated with the column K-factor
algorithm:

 An element that has a pin at the joint under consideration will not en-
ter the stiffness summations calculated above. An element that has a
pin at the far end from the joint under consideration will contribute
only 50% of the calculated EI value. Also, beam elements that have no
column member at the far end from the joint under consideration,
such as cantilevers, will not enter the stiffness summation.

 If there are no beams framing into a particular direction of a column
element, the associated G-value will be infinity. If the G-value at any
one end of a column for a particular direction is infinity, the K-factor
corresponding to that direction is set equal to unity.

 If rotational releases exist at both ends of an element for a particular
direction, the corresponding K-factor is set to unity.

 The automated K-factor calculation procedure can occasionally gener-
ate artificially high K-factors, specifically under circumstances involving
skewed beams, fixed support conditions, and under other conditions
where the program may have difficulty recognizing that the members
are laterally supported and K-factors of unity are to be used.

 All K-factors produced by the program can be overwritten by the user.
These values should be reviewed and any unacceptable values should
be replaced.

 The beams and braces are assigned K-factors of unity.

Continuity Plates and Doubler Plates
When a beam frames into the flange of a column, continuity plates and dou-
bler plates may be required, as illustrated in Figure 3. The design of these
plates is based on the major moment in the beam. If the beam frames into
the column flange at an angle, the doubler and continuity plate design is
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Technical Note 1 - 10 Continuity Plates and Doubler Plates

based on a component of the beam major moment, rather than the full beam
moment.

The design equations for doubler and continuity plates are described further
in the following Technical Notes:

UBC-ASD Steel Frame Design Technical Note 16 Doubler Plates

UBC-LRFD Steel Frame Design Technical Note 30 Doubler Plates

UBC-ASD Steel Frame Design Technical Note 15 Continuity Plates

UBC-LRFD Steel Frame Design Technical Note 29 Continuity Plates
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Technical Note 2
Steel Frame Design Process

This Technical Note describes a basic steel frame design process using this
program. Although the exact steps you follow may vary, the basic design pro-
cess should be similar to that described herein. The other Technical Notes in
the Steel Frame Design series provide additional information.

Steel Frame Design Procedure
The following sequence describes a typical steel frame design process for a
new building. Note that although the sequence of steps you follow may vary,
the basic process probably will be essentially the same.

1. Use the Options menu > Preferences > Steel Frame
Design command to choose the steel frame design code and to review
other steel frame design preferences and revise them if necessary. Note
that default values are provided for all steel frame design preferences, so
it is unnecessary to define any preferences unless you want to change
some of the default values. See UBC97-ASD Steel Frame Design Technical
Note 6 Preferences, UBC97-LRFD Steel Frame Design Technical Note 20
Preferences, AISC-ASD89 Steel Frame Design Technical Note 34 Prefer-
ences, and AISC-LRFD93 Steel Frame Design Technical Note 44 Prefer-
encesfor more information.

2. Create the building model.

3. Run the building analysis using the Analyze menu > Run Analysis
command.

4. Assign steel frame overwrites, if needed, using the Design menu > Steel
Frame Design > View/Revise Overwrites command. Note that you
must select frame elements first using this command. Also note that de-
fault values are provided for all steel frame design overwrites so it is un-
necessary to define overwrites unless you want to change some of the
default values. Note that the overwrites can be assigned before or after
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the analysis is run. See UBC97-ASD Steel Frame Design Technical Note 7
Overwrites, UBC97-LRFD Steel Frame Design Technical Note 21 Over-
writes, AISC-ASD89 Steel Frame Design Technical Note 35 Overwrites,
and AISC-LRFD93 Steel Frame Design Technical Note 45 Overwrites for
more information.

5. Designate design groups, if desired, using the Design menu > Steel
Frame Design > Select Design Group command. Note that you must
have already created some groups by selecting objects and clicking the
Assign menu > Group Names command.

6. To use design load combinations other than the defaults created by the
program for your steel frame design, click the Design menu > Steel
Frame Design > Select Design Combo command. Note that you must
have already created your own design combos by clicking the Define
menu > Load Combinations command. See UBC97-ASD Steel Frame
Design Technical Note 8 Design Load Combinations, UBC97-LRFD Steel
Frame Design Technical Note 22 Design Load Combinations, AISC-ASD89
Steel Frame Design Technical Note 36 Design Load Combinations, and
AISC-LRFD93 Steel Frame Design Technical Note 46 Design Load Combi-
nations for more information.

7. Designate lateral displacement targets for various load cases using the
Design menu > Steel Frame Design > Set Lateral Displacement
Targets command.

8. Click the Design menu > Steel Frame Design > Start Design/Check
of Structure command to run the steel frame design.

9. Review the steel frame design results by doing one of the following:

a. Click the Design menu > Steel Frame Design > Display Design
Info command to display design input and output information on the
model. See Steel Frame Design Technical Note 4 Output Data Plotted
Directly on the Model.

b. Right click on a frame element while the design results are displayed
on it to enter the interactive design mode and interactively design the
frame element. Note that while you are in this mode, you can revise
overwrites and immediately see the results of the new design.
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If design results are not currently displayed (and the design has been
run), click the Design menu > Steel Frame Design > Interactive
Steel Frame Design command and right click a frame element to
enter the interactive design mode for that element. See Steel Frame
Design Technical Note 3 Interactive Steel Frame Design for more in-
formation.

c. Use the File menu > Print Tables > Steel Frame Design command
to print steel frame design data. If you select frame elements before
using this command, data is printed only for the selected elements.
See UBC97-ASD Steel Frame Design Technical Note 17 Input Data,
UBC97-LRFD Steel Frame Design Technical Note 31 Input Data, AISC-
ASD89 Steel Frame Design Technical Note 41 Input Data, and AISC-
LRFD93 Steel Frame Design Technical Note 51 Input Data, and UBC97-
ASD Steel Frame Design Technical Note 18 Output Details, UBC97-
LRFD Steel Frame Design Technical Note 32 Output Details,  AISC-
ASD89 Steel Frame Design Technical Note 42 Output Details, and
AISC-LRFD93 Steel Frame Design Technical Note 52 Output Details for
more information.

10. Use the Design menu > Steel Frame Design > Change Design
Section command to change the design section properties for selected
frame elements.

11. Click the Design menu > Steel Frame Design > Start De-
sign/Check of Structure command to rerun the steel frame design
with the new section properties. Review the results using the procedures
described above.

12. Rerun the building analysis using the Analyze menu > Run Analysis
command. Note that the section properties used for the analysis are the
last specified design section properties.

13. Compare your lateral displacements with your lateral displacement tar-
gets.

14. Click the Design menu > Steel Frame Design > Start De-
sign/Check of Structure command to rerun the steel frame design
with the new analysis results and new section properties. Review the re-
sults using the procedures described in Item 9.
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Note:

Steel frame design in  this program is an iterative process. Typically, the analysis and
design will be rerun multiple times to complete a design.

15. Again use the Design menu > Steel Frame Design > Change De-
sign Section command to change the design section properties for se-
lected frame elements, if necessary.

16. Repeat the processes in steps 12, 13, 14 and 15 as many times as nec-
essary.

17. Select all frame elements and click the Design menu > Steel Frame
Design > Make Auto Select Section Null command. This removes
any auto select section assignments from the selected frame elements
(if they have the Steel Frame design procedure).

18. Rerun the building analysis using the Analyze menu > Run Analysis
command. Note that the section properties used for the analysis are the
last specified design section properties.

19. Verify that your lateral displacements are within acceptable limits.

20. Click the Design menu > Steel Frame Design > Start De-
sign/Check of Structure command to rerun the steel frame design
with the new section properties. Review the results using the procedures
described in step 9.

21. Click the Design menu > Steel Frame Design > Verify Analysis vs
Design Section command to verify that all of the final design sections
are the same as the last used analysis sections.

22. Use the File menu > Print Tables > Steel Frame Design command
to print selected steel frame design results if desired. See UBC97-ASD
Steel Frame Design Technical Note 18 Output Details, UBC97-LRFD Steel
Frame Design Technical Note 32 Output Details, AISC-ASD89 Steel
Frame Design Technical Note 42 Output Details, and AISC-LRFD93 Steel
Frame Design Technical Note 52 Output Details for more information.

It is important to note that design is an iterative process. The sections used in
the original analysis are not typically the same as those obtained at the end
of the design process. Always run the building analysis using the final frame
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section sizes and then run a design check using the forces obtained from that
analysis. Use the Design menu > Steel Frame Design > Verify Analysis
vs Design Section command to verify that the design sections are the same
as the analysis sections.

Automating the Iterative Design Process
If frame elements have been assigned as auto select sections, the program
can automatically  perform the iterative steel frame design process. To initiate
this process, first use the Options menu > Preferences > Steel Frame
Design command and set the Maximum Auto Iterations item to the maximum
number of design iterations you want the program to run automatically. Next
run the analysis. Then, making sure that no elements are selected, use the
Design menu > Steel Frame Design > Start Design/Check of Structure
command to begin the design of the structure. The program will then start a
cycle of (1) performing the design, (2) comparing the last-used Analysis Sec-
tions with the Design Sections, (3) setting the Analysis Sections equal to the
Design Sections, and (4) rerunning the analysis. This cycle will continue until
one of the following conditions has been met:

 the Design Sections and the last-used Analysis Sections are the same

 the number of iterations performed is equal to the number of iterations you
specified for the Maximum Auto Iterations item on the Preferences form

If the maximum number of iterations is reached before the Design Sections
and Analysis Sections match, the program will report any differences on
screen.
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Interactive Steel Frame Design

General
Interactive steel frame design allows you to review the design results for any
frame element and to interactively change the design overwrites and immedi-
ately review the results.

Note that a design must have been run for the interactive design mode to be
available. To run a design, click Design menu > Steel Frame Design >
Start Design/Check of Structure command.

Right click on a frame element while the design results are displayed on it to
enter the interactive design mode and interactively design the element. If de-
sign results are not currently displayed (and the design has been run), click
the Design menu > Steel Frame Design > Interactive Steel Frame De-
sign command and then right click a frame element to enter the interactive
design mode for that element and display the Steel Stress Check Information
form.

Steel Stress Check Information Form
Table 1 identifies the features that are included in the Steel Stress Check In-
formation form.

Table 1  Steel Stress Check Information Form
FEATURE DESCRIPTION

Story ID This is the story level ID associated with the frame element.

Beam This is the label associated with a frame element that is a
beam.

Column This is the label associated with a frame element that is a col-
umn.
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Table 1  Steel Stress Check Information Form
FEATURE DESCRIPTION

Brace This is the label associated with a frame element that is a
brace.

Tip:

The section property displayed for the Design Section item is used by the
program as the section property for the next analysis run.

Analysis section This is the section property that was used for this frame ele-
ment in the last analysis. Thus, the design forces are based on
a frame element of this section property. For your final design
iteration, the Design Section and the last-used Analysis Section
should be the same.

Design section This is the current design section property. If the frame element
is assigned an auto select list, the section displayed in this form
initially defaults to the optimal section.

If no auto select list has been assigned to the frame element,
the element design is performed for the section property speci-
fied in this edit box.

It is important to note that subsequent analyses use the section
property specified in this list box for the next analysis section
for the frame element. Thus, the forces and moments obtained
in the next analysis will be based on this section.

To change the Design Section, click the Overwrites button.

Stress Details Table

The stress details table shows the stress ratios obtained for each design load combina-
tion at each output station along the frame element. Initially the worst stress ratio is high-
lighted. Following are the headings in the table:

Combo ID This is the name of the design load combination considered.

Station location This is the location of the station considered, measured from
the i-end of the frame element.
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Table 1  Steel Stress Check Information Form
FEATURE DESCRIPTION

Moment Interaction Checks

Ratio This is the total PMM stress ratio for the element. When stress
ratios are reported for this item, they are followed by either (T)
or (C). The (T) item indicates that the axial component of the
stress ratio is tension. The (C) item indicates that the axial
component of the stress ratio is compression. Note that typi-
cally the interaction formulas are different, depending on
whether the axial stress is tension or compression.

Axl This is the axial component of the PMM stress ratio.

B-Maj This is the bending component of the PMM stress ratio for
bending about the major axis.

B-Min This is the bending component of the PMM stress ratio for
bending about the minor axis.

Maj Shr Ratio This is the shear stress ratio for shear acting in the major direc-
tion of the frame element.

Min Shr Ratio This is the shear stress ratio for shear acting in the minor direc-
tion of the frame element.

Overwrites Button 
Click this button to access and make revisions to the steel frame overwrites and then
immediately see the new design results. If you modify some overwrites in this mode and
exit both the Steel Frame Design Overwrites form and the Steel Stress Check Information
form by clicking their respective OK buttons, the changes made to the overwrites are
saved permanently.

Exiting the Steel Frame Design Overwrites form by clicking the OK button temporarily
saves changes. Subsequently exiting the Steel Stress Check Information form by clicking
the Cancel button, cancels the changes made. Permanent saving of the overwrites does
not occur until you click the OK button in the Steel Stress Check Information form as well
as the Steel Frame Design Overwrites form.
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Details Button
Clicking this button displays design details for the frame elements. Print this information
by selecting Print from the File menu that appears at the top of the window displaying the
design details.
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Output Data Plotted Directly on the Model

This Technical Note describes the input and output data that can be plotted
directly on the model.

Overview
Use the Design menu > Steel Frame Design > Display Design Info
command to display on-screen output plotted directly on the program model.
If desired, the screen graphics can then be printed using the File menu >
Print Graphics command. The on-screen display data provides design input
and output data.

Design Input
Table 1 identifies the types of data that can be displayed directly on the
model by selecting the data type (shown in bold type) from the drop-down list
on the Display Design Results form. Display this form by selecting the Design
menu > Steel Frame Design > Display Design Info command.

Table 1 Data Displayed Directly on the Model
DATA TYPE DESCRIPTION

Design Sections The  current design section property.

Design Type Steel, concrete or other. In this section, steel would be
selected.

Live Load Red Fac-
tors

 These reduction factors are used by the program to
automatically reduce the live load in the design post-
processor. They are set using the Options menu >
Preferences command.

Unbraced L Ratios Ratio of unbraced length divided by total length.
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Table 1 Data Displayed Directly on the Model
DATA TYPE DESCRIPTION
Effective Length K-
Factors

As defined in AISC-ASD Table C-C2.1 or AISC-LRFD
Table C-C2.1.

Axial Allowables

Bending Allowables

Shear Allowables

Note that you cannot simultaneously display multiple listed items on the
model.

Design Output
Table 2 identifies the types of data that can be displayed directly on the
model after the model has been run by selecting the data type (shown in bold
type) from the drop-down list on the Display Design Results form. Display this
form by selecting he Design menu > Steel Frame Design > Display De-
sign Info command.

Table 2 Data Available After a Model Has Been Run
DATA TYPE DESCRIPTION

PM Ratio Colors &
Values

Colors indicating stress ranges for ratio of acting axial
and bending stresses or forces divided by the allowable
numerical values.

PM Colors/Shear
Ratio Values

Colors indicating axial and bending ratio, and numerical
values indicating shear stress ratio.

PM Ratio Color/no
Values 

Colors indicating axial and bending ratio only.

To display color-coded P-M interaction ratios with values, use the Design
menu > Steel Frame Design > Display Design Info command. Click the
Design Output check box on the Display Design Results form. Note that a de-
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sign must have been run for the output selection to be available. Select P-M
Ratios Colors & Values from the drop-down box. Click the OK button and your
selection will display on the model in the active window. Access the other two
display options in the same manner.

Note that you cannot simultaneously display multiple listed items on the
model.
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Technical Note 5
General and Notation

Introduction to the UBC97-ASD Series of Technical
Notes
The UBC97-ASD design code in this program implements the International
Conference of Building Officials' 1997 Uniform Building Code: Volume 2:
Structural Engineering Design Provisions, Chapter 22, Division III, "Design
Standard for Specification for Structural Steel BuildingsAllowable Stress De-
sign and Plastic Design" (ICBO 1997).

For referring to pertinent sections and equations of the UBC code, a unique
prefix "UBC" is assigned. For referring to pertinent sections and equations of
the AISC-ASD code, a unique prefix "ASD" is assigned. However, all refer-
ences to the "Specifications for Allowable Stress Design of Single-Angle Mem-
bers" (AISC 1989b) carry the prefix of "ASD SAM." Various notations used in
the Steel Frame Design UBC97-ASD series of Technical Notes are described
herein.

When using the UBC97-ASD option, the following Framing Systems are rec-
ognized (UBC 1627, 2213):

 Ordinary Moment Frame (OMF)

 Special Moment-Resisting Frame (SMRF)

 Concentrically Braced Frame (CBF)

 Eccentrically Braced Frame (EBF)

 Special Concentrically Braced Frame (SCBF)

By default the frame type is taken as Special-Moment Resisting (SMRF) in the
program. However, the frame type can be overwritten in the Preferences
(Options menu > Preferences > Steel Frame Design) to change the de-
fault values and in the Overwrites (Design menu > Steel Frame Design >
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View/Revise Overwrites) on a member-by-member basis. If any member
is assigned with a frame type, the change of the frame type in the Preference
will not modify the frame type of the individual member for which it is as-
signed.

When using the UBC97-LRFD option, a frame is assigned to one of the fol-
lowing five Seismic Zones (UBC 2213, 2214):

 Zone 0

 Zone 1

 Zone 2

 Zone 3

 Zone 4

By default the Seismic Zone is taken as Zone 4 in the program. However, the
frame type can be overwritten in the Preferences to change the default (Op-
tions menu > Preferences > Steel Frame Design).

The design is based on user-specified loading combinations. To facilitate use,
the program provides a set of default load combinations that should satisfy
requirements for the  design of most building type structures. See UCB-ASD
Steel Frame Design Technical Note 8 Design Load Combinations for more in-
formation.

In the evaluation of the axial force/biaxial moment capacity ratios at a station
along the length of the member, first the actual member force/moment com-
ponents and the corresponding capacities are calculated for each load combi-
nation. Then the capacity ratios are evaluated at each station under the influ-
ence of all  load combinations using the corresponding equations that are de-
fined in this series of Technical Notes. The controlling capacity ratio is then
obtained. A capacity ratio greater than 1.0 indicates overstress. Similarly, a
shear capacity ratio is also calculated separately. Algorithms for completing
these calculations are described in UBC97-ASD Steel Frame Design Technical
Notes 10 Calculation of Stresses, 11 Calculation of Allowable Stresses, and 12
Calculation of Stress Ratios.
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Further information is available from UBC97-ASD Steel Frame Design Techni-
cal Notes 9 Classification of Sections, 14 Joint Design, 15 Continuity Plates,
and 16 Doubler Plates.

Information about seismic requirements is provided in UBC97-ASD Steel
Frame Design Technical Note 13 Seismic Requirements.

The program uses preferences and overwrites, which are described in UBC97-
ASD Steel Frame Design Technical Notes 6 Preferences and 7 Overwrites. It
also provides input and output data summaries, which are described in
UBC97-ASD Steel Frame Design Technical Notes 17 Input Data and 18 Output
Details.

English as well as SI and MKS metric units can be used for input. But the code
is based on Kip-Inch-Second units. For simplicity, all equations and descrip-
tions presented in this series of Technical Notes correspond to Kip-Inch-
Second units unless otherwise noted.

Notations
A Cross-sectional area, in2

Ae Effective cross-sectional area for slender sections, in2

Af Area of flange, in2

Ag Gross cross-sectional area, in2

Av2, Av3 Major and minor shear areas, in2

Aw Web shear area, dtw, in2

Cb Bending Coefficient

Cm Moment Coefficient

Cw Warping constant, in6

D Outside diameter of pipes, in

E Modulus of elasticity, ksi
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Fa Allowable axial stress, ksi

Fb Allowable bending stress, ksi

Fb33, Fb22 Allowable major and minor bending stresses, ksi

Fcr Critical compressive stress, ksi

'
33eF

2
333333

2

) / (23

12

rlK

Eπ

'
22eF

2
222222

2

) / (23

12

rlK

Eπ

Fv Allowable shear stress, ksi

Fy Yield stress of material, ksi

K Effective length factor

K33, K22 Effective length K-factors in the major and minor directions

M33, M22 Major and minor bending moments in member, kip-in

Mob Lateral-torsional moment for angle sections, kin-in

P Axial force in member, kips

Pe Euler buckling load, kips

Q Reduction factor for slender section, = QaQs

Qa Reduction factor for stiffened slender elements

Qs Reduction factor for unstiffened slender elements

S Section modulus, in3

S33, S22 Major and minor section moduli, in3

Seff,33,Seff,22 Effective major and minor section moduli for slender sec-
tions, in3
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Sc Section modulus for compression in an angle section, in3

V2, V3 Shear forces in major and minor directions, kips

b Nominal dimension of plate in a section, in
longer leg of angle sections,
bf  — 2tw for welded and bf  — 3tw for rolled box sections,
etc.

be Effective width of flange, in

bf Flange width, in

d Overall depth of member, in

fa Axial stress, either in compression or in tension, ksi

fb Normal stress in bending, ksi

fb33, fb22 Normal stress in major and minor direction bending, ksi

fv Shear stress, ksi

fv2, fv3 Shear stress in major and minor direction bending, ksi

h Clear distance between flanges for I shaped sections
(d — 2tf), in

he Effective distance between flanges, less fillets, in

k Distance from outer face of flange to web toes of fillet, in

kc Parameter used for classification of sections,

[ ]
,70th  
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w46.0

>if
th w

1         70h ≤wtif

l33, l22 Major and minor direction unbraced member length, in

lc Critical length, in

r Radius of gyration, in
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r33, r22 Radii of gyration in the major and minor directions, in

rz Minimum radius of gyration for angles, in

t Thickness of a plate in I, box, channel, angle, and T sec-
tions, in

tf Flange thickness, in

tw Web thickness, in

βw Special section property for angles, in
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Technical Note 6
Preferences

This Technical Note describes the items in the Preferences form.

General
The steel frame design preferences in this program are basic assignments
that apply to all steel frame elements. Use the Options menu > Prefer-
ences > Steel Frame Design command to access the Preferences form
where you can view and revise the steel frame design preferences.

Default values are provided for all steel frame design preference items. Thus,
it is not required that you specify or change any of the preferences. You
should, however, at least review the default values for the preference items
to make sure they are acceptable to you.

Using the Preferences Form
To view preferences, select the Options menu > Preferences > Steel
Frame Design. The Preferences form will display.  The preference options
are displayed in a two-column spreadsheet. The left column of the spread-
sheet displays the preference item name. The right column of the spreadsheet
displays the preference item value.

To change a preference item, left click the desired preference item in either
the left or right column of the spreadsheet. This activates a drop-down box or
highlights the current preference value. If the drop-down box appears, select
a new value. If the cell is highlighted, type in the desired value. The prefer-
ence value will update accordingly. You cannot overwrite values in the drop-
down boxes.

When you have finished making changes to the composite beam preferences,
click the OK button to close the form. You must click the OK button for the
changes to be accepted by the program. If you click the Cancel button to exit
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the form, any changes made to the preferences are ignored and the form is
closed.

Preferences
For purposes of explanation in this Technical Note, the preference items are
presented in Table 1. The column headings in the table are described as fol-
lows:

 Item: The name of the preference item as it appears in the cells at the left
side of the Preferences form.

 Possible Values: The possible values that the associated preference item
can have.

 Default Value: The built-in default value that ETABS assumes for the as-
sociated preference item.

 Description: A description of the associated preference item.

Table 1: Steel Frame Preferences

Item
Possible
Values

Default
Value Description

Design Code Any code in
the program

AISC-ASD89 Design code used for design of
steel frame elements.

Time History
Design

Envelopes,
Step-by-Step

Envelopes Toggle for design load combinations
that include a time history designed for
the envelope of the time history, or de-
signed step-by-step for the entire time
history. If a single design load combi-
nation has more than one time history
case in it, that design load combination
is designed for the envelopes of the
time histories, regardless of what is
specified here.

Frame Type Ordinary MRF,
Special MRF,

Braced Frame,
Special CBF,

EBF

Ordinary MRF
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Table 1: Steel Frame Preferences

Item
Possible
Values

Default
Value Description

Zone Zone 0,
Zone 1,
Zone 2,
Zone 3,
Zone 4

Zone 4 Seismic zone

Omega 0 ≥0 2.8

Stress Ratio
Limit

>0 .95 Program will select members from the
auto select list with stress ratios less
than or equal to this value.

Maximum Auto
Iteration

≥1 1 Sets the number of iterations of the
analysis-design cycle that the program
will complete automatically assuming
that the frame elements have been as-
signed as auto select sections.
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Technical Note 7
Overwrites

General
The steel frame design overwrites are basic assignments that apply only to
those elements to which they are assigned. This Technical Note describes
steel frame design overwrites for UBC97-ASD. To access the overwrites, se-
lect an element and click the Design menu > Steel Frame Design >
View/Revise Overwrites command.

Default values are provided for all overwrite items. Thus, you do not need to
specify or change any of the overwrites. However, at least review the default
values for the overwrite items to make sure they are acceptable. When
changes are made to overwrite items, the program applies the changes only
to the elements to which they are specifically assigned; that is, to the ele-
ments that are selected when the overwrites are changed.

Overwrites
For explanation purposes in this Technical Note, the overwrites are presented
in Table 1. The column headings in the table are described as follows.

 Item: The name of the overwrite item as it appears in the program. To
save space in the forms, these names are generally short.

 Possible Values: The possible values that the associated overwrite item
can have.

 Default Value: The default value that the program assumes for the associ-
ated overwrite item. If the default value is given in the table with an asso-
ciated note "Program Calculated," the value is shown by the program before
the design is performed. After design, the values are calculated by the pro-
gram and the default is modified by the program-calculated value.

 Description: A description of the associated overwrite item.
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An explanation of how to change an overwrite is provided at the end of this
Technical Note.

Table 1 Steel Frame Design Overwrites

Item
Possible
Values

Default
Value Description

Current Design
Section

Indicates selected member size used in
current design.

Element Type Ordinary MRF,
Special MRF,

Braced Frame,
Special CBF,

EBF

From
Preferences

Live Load
Reduction

Factor

≥0 1
(Program

Calculated)

Live load is multiplied by this factor.

Horizontal
Earthquake

Factor

≥0 1 Earthquake loads are multiplied by this
factor.

Unbraced
Length Ratio

(Major)

≥0 1
(Program

Calculated)

Ratio of unbraced length divided by
total length.

Unbraced
Length Ratio
(Minor, LTB)

≥0 1
(Program

Calculated)

Ratio of unbraced length divided by
total length.

Effective
Length Factor

(K Major)

≥0 1
(Program

Calculated for
Columns)

As defined in AISC-ASD Table C-C2.1,
page 5-135.

Effective
Length Factor

(K Minor)

≥0 1
(Program

Calculated for
Columns)

As defined in AISC-ASD Table C-C2.1,
page 5-135.

Moment
Coefficient
(Cm Major)

≥0 0.85
(Program

Calculated)

As defined in AISC-ASD, page 5-55.

Moment
Coefficient
(Cm Minor)

≥0 0.85
(Program

Calculated)

As defined in AISC-ASD, page 5-55.
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Table 1 Steel Frame Design Overwrites

Item
Possible
Values

Default
Value Description

Bending
Coefficient

(Cb)

≥0 1
(Program

Calculated)

As defined in AISC-ASD, page 5-47.

Yield stress, Fy ≥0 0 If zero, yield stress defined for material
property data used.

Omega0 ≥0 From
Preferences

Seismic force amplification factor as
required by the UBC.

Compressive
stress, Fa

≥0 0 If zero, yield stress defined for material
property data used and AISC-ASD
specification Chapter E.

Tensile
stress, Ft

≥0 0 If zero, as defined for material property
data used and AISC-ASD Chapter D.

Major Bending
stress, Fb3

≥0 0 If zero, as defined for material property
data used and AISC-ASD specification
Chapter F.

Minor Bending
stress, Fb2

≥0 0 If zero, as defined for material property
data used and AISC-ASD specification
Chapter F.

Major Shear
stress, Fv2

≥0 0 If zero, as defined for material property
data used and AISC-ASD specification
Chapter F.

Minor Shear
stress, Fv3

≥0 0 If zero, as defined for material property
data used and AISC-ASD specification
Chapter F.

Making Changes in the Overwrites Form
To access the steel frame overwrites, select a frame element and click the
Design menu > Steel Frame Design > View/Revise Overwrites com-
mand.

The overwrites are displayed in the form with a column of check boxes and a
two-column spreadsheet. The left column of the spreadsheet contains the
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name of the overwrite item. The right column of the spreadsheet contains the
overwrites values.

Initially, the check boxes in the Steel Frame Design Overwrites form are all
unchecked and all of the cells in the spreadsheet have a gray background to
indicate that they are inactive and the items in the cells cannot be changed.
The names of the overwrite items are displayed in the first column of the
spreadsheet. The values of the overwrite items are visible in the second col-
umn of the spreadsheet if only one frame element was selected before the
overwrites form was accessed. If multiple elements were selected, no values
show for the overwrite items in the second column of the spreadsheet.

After selecting one or multiple elements, check the box to the left of an over-
write item to change it. Then left click in either column of the spreadsheet to
activate a drop-down box or highlight the contents in the cell in the right col-
umn of the spreadsheet. If the drop-down box appears, select a value from
the box. If the cell is highlighted, type in the desired value. The overwrite will
reflect the change. You cannot change the values of the drop-down boxes.

When changes to the overwrites have been completed, click the OK button to
close the form. The program then changes all of the overwrite items whose
associated check boxes are checked for the selected members. You must click
the OK button for the changes to be accepted by the program. If you click the
Cancel button to exit the form, any changes made to the overwrites are ig-
nored and the form is closed.

Resetting Steel Frame Overwrites to Default Values
Use the Design menu > Steel Frame Design > Reset All Overwrites
command to reset all of the steel frame overwrites. All current design results
will be deleted when this command is executed.

Important note about resetting overwrites: The program defaults for the
overwrite items are built into the program. The steel frame overwrite values
that were in a .edb file that you used to initialize your model may be different
from the built-in program default values. When you reset overwrites, the pro-
gram resets the overwrite values to its built-in values, not to the values that
were in the .edb file used to initialize the model.



Design Load Combinations Technical Note 8 - 1

©COMPUTERS AND STRUCTURES, INC., BERKELEY, CALIFORNIA DECEMBER 2001

STEEL FRAME DESIGN UBC97-ASD

Technical Note 8
Design Load Combinations

The design load combinations are the various combinations of the load cases
for which the structural members and joints need to be designed or checked.
For the UBC97-ASD code, if a structure is subjected to dead load (DL), live
load (LL), wind load (WL), and earthquake induced load (EL) and considering
that wind and earthquake forces are reversible, the following load combina-
tions may need to be defined (UBC 1612.3):

DL (UBC 1612.3.1 12-7)
DL + LL (UBC 1612.3.1 12-8)

DL ± WL (UBC 1612.3.1 12-9)
DL + 0.75LL ± 0.75 WL (UBC 1612.3.1 12-11)

DL ± EL/1.4 (UBC 1612.3.1 12-9)
0.9 DL ± EL/1.4 (UBC 1612.3.1 12-10)
DL + 0.75 LL ± 0.75 EL/1.4 (UBC 1612.3.1 12-11)

These are also the default design load combinations in the program whenever
the UBC97-ASD code is used. The user should use other appropriate load
combinations if roof live load is separately treated, if other types of loads are
present, or if pattern live loads are to be considered.

When designing for combinations involving earthquake and wind loads, allow-
able stresses are NOT increased by a factor of 4/3 of the regular allowable
value (UBC 1612.3.1, 2209.3).

Live load reduction factors can be applied to the member forces of the live
load case on an element-by-element basis to reduce the contribution of the
live load to the factored loading. See UBC97-ASD Steel Frame Design Techni-
cal Note 7 Overwrites for more information.

It is noted here that whenever special seismic loading combinations are
required by the code for special circumstances, the program automatically
generates those load combinations internally. The following additional seismic
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load combinations are frequently checked for specific types of members and
special circumstances.

1.0 DL + 0.7 LL ± Ωo EL (UBC 2213.5.1.1.)
0.85 DL ± Ωo EL (UBC 2213.5.1.2)

where Ωo is the seismic force amplification factor, which is required to account
for structural overstrength. The default value of Ωo is taken as 2.8 in the pro-
gram. However, Ωo can be overwritten in the Preferences to change the de-
fault and in the Overwrites on a member-by-member basis. If any member is
assigned a value for Ωo, the change of Ωo in the Preferences will not modify
the Ωo of the individual member for which Ωo is assigned, unless the member
had been selected. The guidelines for selecting a reasonable value can be
found in UBC 1630.3.1 and UCB Table 16-N. Other similar special design load
combinations described in UBC97-ASD Steel Frame Design Technical Notes 13
Seismic Requirements and 14 Joint Design.

Those special seismic load combinations are internal to program. The user
does NOT need to create additional load combinations for those load combi-
nations. The special circumstances for which the load combinations are addi-
tionally checked are described as appropriate in the other Technical Notes. It
is assumed that any required scaling (such as may be required to scale re-
sponse spectra results) has already been applied to the program load cases.



Classification of Sections Technical Note 9 - 1

©COMPUTERS AND STRUCTURES, INC., BERKELEY, CALIFORNIA DECEMBER 2001

STEEL FRAME DESIGN UBC97-ASD

Technical Note 9
Classification of Sections

This Technical Note explains the classification of sections when the user se-
lects the UBC97-ASD design code.

Overview
The allowable stresses for axial compression and flexure depend on the clas-
sification of sections. The sections are classified in UBC97-ASD as either
Compact, Noncompact, Slender or Too Slender in the same way as described
in AISC-ASD89 Steel Frame Design Technical Note 37 Classification of Sec-
tions. The program classifies the individual members according to the limiting
width/thickness ratios given in Table 1 of AISC-ASD89 Steel Frame Design
Technical Note 37 Classification of Sections (UBC 2208, 2212, 2213, ASD
B5.1, F3.1, F5, G1, A-B5-2). The definition of the section properties required
in this table is given in Figure 1 of AISC-ASD89 Steel Frame Design Technical
Note 37 Classification of Sections and AISC-ASD89 Steel Frame Design Tech-
nical Note 33 General and Notation.

In general the design sections need not necessarily be Compact to satisfy
UBC97-ASD codes (UBC 2213.4.2). However, for certain special seismic cases
they must be Compact and must satisfy special slenderness requirements.
See UBC97-ASD Steel Frame Design Technical Note 13 Seismic Require-
ments. The sections that do satisfy these additional requirements are classi-
fied and reported as "SEISMIC" in the program. These special requirements
for classifying the sections as "SEISMIC" in the program ("Compact" in UBC)
are given in Table 1 (UBC 2213.7.3, 2213.8.2.5, 2213.9.24, 2213.9.5,
2212.10.2). If these criteria are not satisfied when the code requires them to
be satisfied, the user must modify the section property. In that case, the pro-
gram gives a warning message in the output file.
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Table 1 Limiting Width-Thickness Ratios for Classification of Sections
When Special Seismic Conditions Apply in accordance with
UBC97-ASD

Description
of Section

Width-
Thickness

Ratio λλλλ

SEISMIC
(Special requirements in

seismic design)
(λλλλp) Section References

bf / 2tf
(beam)

≤  52 / yF
UBC 2213.7.3 (SMRF)
UBC 2213.10.2 (EBF)

I-SHAPE
bf / 2tf

(column)

8.5 for Fy ≤ 36
8.0 for 36 ≤ Fy ≤ 42
7.4 for 42 ≤ Fy ≤ 45
7.0 for 45 ≤ Fy ≤ 50
6.6 for 50 ≤ Fy ≤ 55
6.3 for 55 ≤ Fy ≤ 60
6.0 for Fy > 60

UBC2213.7.3 (SMRF)
UBC 2213.9.5 (SCBF)

ASD N7

b  / tf
and

hc / tw
(column)

≤  110 / yF
UBC 2213.7.3 (SMRF)
UBC 2213.9.5 (SCBF)

BOX
b  / tf
and

hc / tw
(brace)

≤  110 / yF
UBC 2213.8.2.5 (BF)

UBC 2213.9.2.4 (SCBF)

ANGLE  b / t
(brace)

≤  52 / yF
UBC 2213.8.2.5 (BF)

UBC 2213.9.2.4 (SCBF)

DOUBLE-ANGLE  b / t
(brace)

≤  52 / yF
UBC 2213.8.2.5 (BF)

UBC 2213.9.2.4 (SCBF)

PIPE D / t
(brace)

≤ 1,300 / yF
UBC 2213.8.2.5 (BF)

UBC 2213.9.2.4 (SCBF)

CHANNEL bf  / tf
hc / tw

No special requirement
No special requirement

T-SHAPE bf / 2tf
d / tw

No special requirement
No special requirement

ROUND BAR  No special requirement

RECTANGULAR  No special requirement

GENERAL  No special requirement
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Calculation of Stresses

The axial, flexural, and shear stresses at each of the previously defined sta-
tions for each load combination in UBC97-ASD are calculated in the same way
as described in AISC-ASD89 Steel Frame Design Technical Note 38 Calcula-
tion of Stresses without any exception (UBC 2208, ASD A-B5.2d). For non-
slender sections, the stresses are based on the gross cross-sectional areas
(ASD A-B5.2c); for slender sections, the stresses are based on effective sec-
tion properties (ASD A-B5.2c); and for Single-Angle sections, the stresses are
based on the principal properties of the sections (ASD SAM 6.1.5).

The flexural stresses are calculated based on the properties about the princi-
pal axes. For I, Box, Channel, T, Double-angle, Pipe, Circular and Rectangular
sections, the principal axes coincide with the geometric axes. For Single-angle
sections, the design considers the principal properties. For general sections, it
is assumed that all section properties are given in terms of the principal di-
rections.

For Single-angle sections, the shear stresses are calculated for directions
along the geometric axes. For all other sections, the program calculates the
shear stresses along the geometric and principle axes.
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Technical Note 11
Calculation of Allowable Stresses

The allowable stress in compression, tension, bending, and shear for Com-
pact, Noncompact, and Slender sections in accordance with UBC97-ASD are
calculated in the same way as described in the AISC-ASD89 Steel Frame De-
sign Technical Note 39 Calculation of Allowable Stresses without any excep-
tions (UBC 2208, ASD A-B5.2d). The allowable stresses for Seismic sections
are calculated in the same way as for Compact sections.

The allowable flexural stresses for all shapes of sections are calculated based
on their principal axes of bending. For the I, Box, Channel, Circular, Pipe, T,
Double-angle and Rectangular sections, the principal axes coincide with their
geometric axes. For the Angle sections, the principal axes are determined and
all computations related to flexural stresses are based on that.

The allowable shear stress is calculated along geometric axes for all sections.
For I, Box, Channel, T, Double-Angle, Pipe, Circular and Rectangular sections,
the principal axes coincide with their geometric axes. For Single-Angle sec-
tions, principal axes do not coincide with the geometric axis.

All limitations and warnings related to allowable stress calculations in AISC-
ASD89 Steel Frame Design Technical Note 39 Calculation of Allowable
Stresses also apply when the user selects this code in the program.

If the user specifies  nonzero allowable stresses for one or more elements in
the Steel Frame Overwrites dialog box (display using the Design menu >
Steel Frame Design > Review/Revise Overwrites command), the
nonzero values will be used rather than the calculated values for those
elements. The specified allowable stresses should be based on the principal
axes of bending.
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Technical Note 12
Calculation of Stress Ratios

This Technical Note explains that the stress ratios in UBC97-ASD are calcu-
lated in the same way as described in AISC-ASD89 Steel Frame Design Tech-
nical Note 40 Calculation of Stress Ratios, with some modifications as de-
scribed herein.

In the calculation of the axial and bending stress ratios, first, for each station
along the length of the member, the actual stresses are calculated for each
load combination. Then the corresponding allowable stresses are calculated.
Then, the stress ratios are calculated at each station for each member under
the influence of each of the design load combinations. The controlling stress
ratio is then obtained, along with the associated station and load combination.
A stress ratio greater than 1.0 indicates an overstress. Similarly, a shear ca-
pacity ratio is also calculated separately.

During the design, the effect of the presence of bolts or welds is not
considered.

Axial and Bending Stresses
With the computed allowable axial and bending stress values and the factored
axial and bending member stresses at each station, an interaction stress ratio
is produced  for each of the load combinations as follows (ASD H1, H2, SAM
6):

 If fa is compressive and  fa /  Fa, > 0.15, the combined stress ratio is given
by the larger of
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fa = axial stress

fb33  = bending stress about the local 3-axis

fb22 = bending stress about the local 2-axis

Fa = allowable axial stress

Fb33 = allowable bending stress about the local 3-axis

Fb22 =  allowable bending stress about the local 2-axis
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2

2

)/(23

12

rKl

Eπ
. (ASD H1)

A factor of 4/3 is NOT applied on Fe and 0.6Fy if the load combination in-
cludes any wind load or seismic load (UBC 1612.3.1).

Cm33 and Cm22 are coefficients representing distribution of moment along the
member length. They are calculated as described in AISC-ASD89 Steel
Frame Design Technical Note 40 Calculation of Stress Ratios.

When the stress ratio is calculated for Special Seismic Load Combinations,
the column axial allowable stress in compression is taken to be 1.7Fa in-
stead of Fa (UBC 2213.4.2).

 If fa is compressive and fa / Fa ≤ 0.15, a relatively simplified formula is used
for the combined stress ratio.
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 If fa is tensile or zero, the combined stress ratio is given by the larger of
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fa, fb33, fb22, Fa, Fb33, and Fb22 are as defined earlier in this Technical Note.
However, either Fb33 or Fb22 need not be less than 0.6Fy in the first equation
(ASD H2-1).  The second equation considers flexural buckling without any
beneficial effect from axial compression.

When the stress ratio is calculated for Special Seismic Load Combinations,
the column axial allowable stress in tension is taken to be Fy instead of Fa

(UBC 2213.4.2).

For circular and pipe sections, an SRSS combination is first made of the two
bending components before adding the axial load component, instead of the
simple addition implied by the above formula.

For Single-angle sections, the combined stress ratio is calculated based on the
properties about the principal axis (ASD SAM 5.3, 6.1.5). For I, Box, Channel,
T, Double-angle, Pipe, Circular and Rectangular sections, the principal axes
coincide with their geometric axes. For Single-angle sections, principal axes
are determined in the program. For general sections, it is assumed that all
section properties are given in terms of the principal directions, and conse-
quently, no effort is made to determine the principal directions.

In contrast to the AISC-ASD code, when designing for combinations involving
earthquake and wind loads, allowable stresses are NOT increased by a factor
of 4/3 of the regular allowable value (UBC 1612.3.1, 2209.3).

Shear Stresses
From the allowable shear stress values and the factored shear stress values
at each station, shear stress ratios for major and minor directions are com-
puted for each of the load combinations as follows:

v
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F
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F
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For Single-angle sections, the shear stress ratio is calculated for directions
along the geometric axis. For all other sections, the shear stress is calculated
along the principle axes that coincide with the  geometric axes.

In contrast to AISC-ASD code, when designing for combinations involving
earthquake and wind loads, allowable shear stresses are NOT increased by a
factor of 4/3 of the regular allowable value (UBC 1612.3.1, 2209.3).
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Technical Note 13
Seismic Requirements

This Technical Note explains the special seismic requirements checked by the
program for member design. Those requirements are dependent on the type
of framing used and are described below for each type of framing. The re-
quirements checked are based on UBC Section 2213 for frames in Seismic
Zones 3 and 4 and on UBC Section 2214 for frames in Seismic Zones 1 and 2
(UBC 2204.2, 2205.2, 2205.3, 2208, 2212, 2213, 2214). No special require-
ment is checked for frames in Seismic Zone 0.

Ordinary Moment Frames
For this framing system, the following additional requirements are checked
and reported:

 In Seismic Zones 3 and 4, whenever the axial stress, ƒa, in columns
caused by the prescribed loading combinations exceeds 0.3 Fy, the Special
Seismic Load Combinations as described below are checked with respect
to the column axial load capacity only (UBC 2213.5.1).

1.0DL + 0.7 LL ± Ωo EL (UBC 2213.5.1.1)
0.85 DL ± Ωo EL (UBC 2213.5.1.2)

In this case, column forces are replaced by the column forces for the Spe-
cial Seismic Load Combinations, whereas the other forces are taken as
zeros. For this case, the column axial allowable stress in compression is
taken to be 1.7 Fa instead of Fa, and the column axial allowable stress in
tension is taken to be Fy instead of Fa (UBC 2213.5.1, 2213.4.2).

Special Moment Resisting Frames
For this framing system, the following additional requirements are checked or
reported:

 In Seismic Zones 3 and 4, when the axial stress, ƒa, in columns caused by
the prescribed loading combinations exceeds 0.3 Fy, the Special Seismic
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Load Combinations as described below are checked with respect to the
column axial load capacity only (UBC 2213.5.1).

1.0DL + 0.7 LL ± Ωo EL (UBC 2213.5.1.1)
0.85 DL ± Ωo EL (UBC 2213.5.1.2)

In this case, column forces are replaced by the column forces for the Spe-
cial Seismic Load Combinations, whereas the other forces are taken as
zeros. For this case, the column axial allowable stress in compression is
taken to be 1.7 Fa instead of Fa, and the column axial allowable stress in
tension is taken to be Fy instead of Fa (UBC 2213.5.1, 2213.4.2).

 In Seismic Zones 3 and 4, the I-shaped beams, I-shaped columns, and
Box-shaped columns are additionally checked for compactness criteria as
described in Table 1 of UBC97-ASD Steel Frame Design Technical Note 9
Classification of Sections (UBC 2213.7.3). Compact I-shaped beam sec-

tions are also checked for bf/2tf to be less than 52/ yF . Compact I-

shaped column sections are additionally checked for bf/2tf to be less than
the numbers given for plastic sections in Table 1 of UBC97-ASD Steel
Frame Design Technical Note 9 Classification of Sections. Compact box

shaped column sections are also checked for b/tf to be less than 110/ yF .

If this criterion is satisfied, the section is reported as SEISMIC as de-
scribed in UBC97-ASD Steel Frame Design Technical Note 9 Classification
of Sections. If this criterion is not satisfied, the user must modify the sec-
tion property

 In Seismic Zones 3 and 4, the program checks the laterally unsupported
length of beams to be less than 96ry. If the check is not satisfied, it is
noted in the output (UBC 2213.7.8).

Braced Frames
For this framing system, the following additional requirements are checked or
reported:

 In Seismic Zones 3 and 4, when the axial stress, ƒa, in columns resulting
from the prescribed loading combinations exceeds 0.3 Fy, the Special
Seismic Load Combinations as described below are checked with respect
to the column axial load capacity only (UBC 2213.5.1).
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1.0DL + 0.7 LL ± Ωo EL (UBC 2213.5.1.1)
0.85 DL ± Ωo EL (UBC 2213.5.1.2)

In this case, column forces are replaced by the column forces for the Spe-
cial Seismic Load Combinations, whereas the other forces are taken as
zeros. For this case, the column axial allowable stress in compression is
taken to be 1.7Fa instead of Fa, and the column axial allowable stress in
tension is taken to be Fy instead of Fa (UBC 2213.5.1, 2213.4.2).

 In Seismic Zones 3 and 4, the program checks the laterally unsupported
length of beams to be less than 96ry. If the check is not satisfied, it is
noted in the output (UBC 2213.8.1, 2213.7.8).

 In Seismic Zones 3 and 4, the maximum l/r ratio of the braces is checked

not to exceed 720/ yF . If this check is not met, it is noted in the output

(UBC 2213.8.2.1).

 In Seismic Zones 3 and 4, the Angle, Double-angle, Box, and Pipe shaped
braces are additionally checked for compactness criteria, as described in
Table 1 of UBC97-ASD Steel Frame Design Technical Note 9 Classification
of Sections (UBC223.8.2.5). For angles and double-angles, b/t is limited

to 52/ yF ; for box sections, b/tf and d/tw is limited to 110/ yF ; for pipe

sections, D/t is limited to 1,300/Fy. If this criterion is satisfied, the section
is reported as SEISMIC as described in UBC97-ASD Steel Frame Design
Technical Note 9 Classification of Sections. If this criterion is not satisfied,
the user must modify the section property.

 In Seismic Zones 3 and 4, the allowable compressive stress for braces is
reduced by a factor of B where

B=

cC
rKl

2
/

1

1

+
(UBC 2213.8.2.2)

In Seismic Zones 1 and 2, the allowable compressive stress for braces is
reduced by the same factor B where

B ≥ 0.8 (UBC 2214.6.2.1)
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 In Seismic Zones 3 and 4, Chevron braces are designed for 1.5 times the
specified load combination (UBC 2213.8.4.1).

Eccentrically Braced Frames
For this framing system, the program looks for and recognizes the eccentri-
cally braced frame configuration shown in Figure 1. The following additional
requirements are checked or reported for the beams, columns and braces as-
sociated with these configurations. Special seismic design of eccentrically
braced frames in Seismic Zones 1 and 2 is the same as that in Seismic Zones
3 and 4 (UBC 2214.8).

 In all Seismic zones except Zone 0, the I-shaped beam sections are also
checked for compactness criteria as described in Table 1 of UBC97-ASD
Steel Frame Design Technical Note 9 Classification of Sections. Compact I-

shaped beam sections are also checked for bf/2tf to be less than 52/ yF .

If this criterion is satisfied, the section is reported as SEISMIC as de-
scribed in UBC97-ASD Steel Frame Design Technical Note 9 Classification
of Sections. If this criterion is not satisfied, the user must modify the sec-
tion property (UBC 2213.10.2). Other sections meeting this criterion are
also reported as SEISMIC.

 In all Seismic Zones except Zone 0, the link beam strength in shear
Vs=0.55Fydtw and moment Ms=ZFy are calculated. If Vs ≤ 2.0Ms/e, the link
beam strength is assumed to be governed by shear and is so reported. If
the above condition is not satisfied, the link beam strength is assumed to
be governed by flexure and is so reported. When link beam strength is
governed by shear, the axial and flexural properties (area, A and section
modulus, S) for use in the interaction equations are calculated based on
the beam flanges only (UBC 2213.10.3).

 In all Seismic Zones except Zone 0, if the link beam is connected to the
column, the link beam length e is checked not to exceed the following
(UBC 2213.10.12):

e ≤1.6
p

p

V

M
(UBC 2213.10.12)

If the check is not satisfied, it is noted in the output.
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bay divided by height of the story. The link beam rotation θ is checked to
be less than the following values (UBC 2213.10.4).

θ ≤ 0.090, where link beam clear length, e ≤ 1.6 Ms/Vs

θ ≤ 0.030, where link beam clear length, e ≥ 3.0 Ms/Vs, and

θ ≤ value interpolated between 0.090 and 0.030 as the link beam clear
length varies from 1.6 Ms/Vs to 3.0 Ms/Vs.

 In all Seismic zones except Zone 0, the link beam shear under the speci-
fied loading combinations is checked not to exceed 0.8Vs (UBC
2213.10.5).

 In all Seismic Zones except Zone 0, the brace strength is checked to be at
least 1.5 times the axial force corresponding to the controlling link beam
strength (UBC 2213.10.13). The controlling link beam strength is either
the shear strength, Vs, as Vs=0.55Fydtw, or the reduced flexural strength
Mrs, whichever produces the lower brace force. The value of Mrs is taken as
Mrs = Z(Fy-ƒa)(UBC 2213.10.3), where ƒa is the lower of the axial stress in
the link beam corresponding to yielding of the link beam web in shear or
the link beam flanges in flexure. The correspondence between brace force
and link beam force is obtained from the associated load cases, whichever
has the highest link beam force of interest.

 In all Seismic Zones except Zone 0, the column is checked to not become
inelastic for gravity loads plus 1.25 times the column forces corresponding
to the controlling link beam strength (UBC 2213.10.14). The controlling
link beam strength and the corresponding forces are as obtained by the
process described above. If this condition governs, the column axial al-
lowable stress in compression is taken to be 1.7Fa instead of Fa, and the
column axial allowable stress in tension is taken to be Fy instead of Fa.

 In all Seismic Zones except Zone 0, axial forces in the beams are included
in checking of beams (UBC 2211.10.17). The user is reminded that using
a rigid diaphragm model will result in zero axial forces in the beams. The
user must disconnect some of the column lines from the diaphragm to al-
low beams to carry axial loads. It is recommended that only one column
line per eccentrically braced frame be connected to the rigid diaphragm or
a flexible diaphragm model be used.
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 In all Seismic Zones except Zone 0, the beam laterally unsupported length

is checked to be less than 76 bf/ yF . If not satisfied, it is so noted as a

warning in the output file (UBC 2213.10.18).

Note: The beam strength in flexure, of the beam outside the link, is NOT
currently checked to be at least 1.5 times the moment corresponding to the
controlling link beam strength (UBC 2213.10.13). Users need to check for this
requirement.

Special Concentrically Braced Frames
Special seismic design of special concentrically braced frames in Seismic
Zones 1 and 2 is the same as those in Seismic zones 3 and 4 (UBC 2214.7).
For this framing system, the following additional requirements are checked or
reported:

 In all Seismic Zones except Zone 0, when the axial stress fa in columns
resulting from the prescribed loading combinations exceeds 0.3Fy, the
Special Seismic Load Combinations as described below are checked with
respect to the column axial load capacity only (UBC 2213.9.5, 2213.5.1).

1.0 DL + 0.7 LL ± ΩoEL (UBC 2213.5.1.1)
0.85 DL ± ΩoEL (UBC 2213.5.1.2)

In this case, column forces are replaced by the column forces for the Spe-
cial Seismic Load Combinations, whereas the other forces are taken as
zeros. For this case, the column axial allowable stress in compression is
taken to be 1.7 Fa instead of Fa, and the column axial allowable stress in
tension is taken to be Fy instead of Fa (UBC 2213.5.1, 2213.4.2).

 In all Seismic Zones except Zone 0, the I-shaped and Box-shaped col-
umns are also checked for compactness criteria as described in Table 1 of
UBC97-ASD Steel Frame Design Technical Note 9 Classification of Sec-
tions. Compact I-shaped column sections are also checked for bf/2tf to be
less than the numbers given for plastic sections in Table 1 of UBC97-ASD
Steel Frame Design Technical Note 9 Classification of Sections. Compact
Box-shaped column sections also are checked for b/tf and d/tw to be less

than 110/ yF . If this criterion is satisfied, the section is reported as

SEISMIC as described in UBC97-ASD Steel Frame Design Technical Note 9
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Classification of Sections. If this criterion is not satisfied, the user must
modify the section property (UBC 2213.9.5, 2213.7.3).

 In all Seismic Zones except Zone 0, bracing members are checked to be
compact and are so reported. The Angle, Box, and Pipe sections used as
braces are also checked for compactness criteria as described in Table 1 of
UBC97-ASD Steel Frame Design Technical Note 9 Classification of Sec-

tions. For angles, b/t is limited to 52/ yF ; for pipe sections, D/t is limited

to 1,300/Fy. If this criterion is satisfied, the section is reported as SEIS-
MIC. If this criterion is not satisfied, the user must modify the section
property (UBC 2213.9.2.4).

 In all Seismic Zones except Zone 0, the maximum Kl/r ratio of the braces

is checked not to exceed 1,000/ yF . If this check is not met, it is noted in

the output (UBC 2213.9.2.1).

Note: Beams intersected by Chevron braces are NOT currently checked to
have a strength to support loads represented by the following loading
combination (UBC 2213.9.14):

1.2 DL + 0.5LL ± Pb (UBC 2213.9.4.1)

0.9 DL ± Pb (UBC 2213.9.4.1)

where Pb is given by the difference of FyA for the tension brace and 0.3
times 1.7FaA for the compression brace. Users need to check for this re-
quirement (UBC 2213.9.4.1, 2213.4.2).
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Joint Design

This Technical Note describes how the program checks or designs joints.
When using UBC97-ASD design code, the structural joints are checked or de-
signed for the following:

 Check for the requirement of continuity plate and determination of its area
(see UBC97-ASD Steel Frame Design Technical Note 15 Continuity Plates )

 Check for the requirement of doubler plate and determination of its thick-
ness (see Steel Frame Design UBC97-ASD Technical Note 16 Doubler
Plates)

 Check for ratio of beam flexural strength to column flexural strength

 Reporting the beam connection shear

 Reporting the brace connection force

Beam/Column Plastic Moment Capacity Ratio
In Seismic Zones 3 and 4, for Special Moment-Resisting Frames, the code re-
quires that the sum of beam flexure strengths at a joint should be less than
the sum of column flexure strengths (UBC 2213.7.5). The column flexure
strength should reflect the presence of axial force present in the column. To
facilitate the review of the strong-column/weak-beam criterion, the program
reports a beam/column plastic moment capacity ratio for every joint in the
structure.

For the major direction of any column (top end) the beam-to-column strength
ratio is obtained as:

Rmaj = 
pcbxpcax

n

n
npbn

MM

M
b

+

θ∑
=1

cos

(UBC 2213.7.5)
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For the minor direction of any column the beam-to-column strength ratio is
obtained as:

Rmin = 
pcbypcay

n

n
npbn

MM

M
b

+

θ∑
=1

sin

(UBC 2213.7.5)

where,

Rmaj, min = Plastic moment capacity ratios, in the major and minor di-
rections of the column, respectively

Mpbn = Plastic moment capacity of n-th beam connecting to col-
umn,

θn = Angle between the n-th beam and the column major direc-
tion,

Mpcax,y = Major and minor plastic moment capacities, reduced for ax-
ial force effects, of column above story level. Currently, it is
taken equal to Mpcbx,y if there is a column above the joint. If
there is no column above the joint, Mpcax,y is taken as zero.

Mpcbx,y = Major and minor plastic moment capacities, reduced for ax-
ial force effects, of column below story level, and

nb = Number of beams connecting to the column.

The plastic moment capacities of the columns are reduced for axial force ef-
fects and are taken as

Mpc = Zc(Fyc - fa), (UBC 2213.7.5)

where,

Zc = Plastic modulus of column,

Fyc = Yield stress of column material, and

fa = Maximum axial stress in the column.
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For the above calculations, the section of the column above is taken to be the
same as the section of the column below assuming that the column splice will
be located some distance above the story level.

Evaluation of Beam Connection Shears
For each steel beam in the structure, the program will report the maximum
major shears at each end of the beam for the design of the beam shear con-
nections. The beam connection shears reported are the maxima of the fac-
tored shears obtained from the loading combinations.

For special seismic design, the beam connection shears are not taken less
than the following special values for different types of framing. The require-
ments checked are based on UBC Section 2213 for frames in Seismic Zones 3
and 4 and on UBC Section 2214 for frames in Seismic Zones 1 and 2 (UBC
2204.2, 2205.2, 2213, 2214). No special requirement is checked for frames in
Seismic Zone 0.

 In all Seismic Zones except Zone 0, for Ordinary Moment Frames, the
beam connection shears reported are the maximum of the specified load-
ing combinations and the following additional loading combinations (UBC
2213.6.2, 2214.4.2):

1.0 DL + 1.0LL ± Ω0 EL (UBC 2213.6.2, 2214.4.2)

 In all Seismic Zones except Zone 0, for Special Moment-Resisting Frames,
the beam connection shears that are reported allow for the development
of the full plastic moment capacity of the beam (UBC 2213.7.1,
22145.5.1.1). Thus:

V = LLDL
pb V

L

CM
++ (UBC 2213.7.1.1, 2214.5.1.1)

where,

V = Shear force corresponding to END I and END J of beam

C = 0 if beam ends are pinned or for cantilever beam,

= 1 if one end of the beam is pinned,
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= 2 if no ends of the beam are pinned,

Mpb = Plastic moment capacity of the beam, ZFy,

L = Clear length of the beam, and

VDL+LL = Absolute maximum of the calculated factored beam shears
at the corresponding beam ends from the dead load and live
load combinations only.

 In all Seismic Zones except Zone 0, for Eccentrically Braced Frames, the
beam connection shears reported are the maximum of the specified load-
ing combinations and the following additional loading combination:

1.0 DL + 1.0LL ± Ω0 EL

Evaluation of Brace Connection Forces
For each steel brace in the structure, the program reports the maximum axial
force at each end of the brace for the design of the brace-to-beam connec-
tions. The brace connection forces reported are the maxima of the factored
brace axial forces obtained from the loading combinations.

For special seismic design, the brace connection forces are not taken less
than the following special values for different types of framing. The require-
ments checked are based on UBC Section 2213 for frames in Seismic Zones 3
and 4 and on UBC 2214 for frames in Seismic Zones 1 and 2 (UBC 2204.2,
2205.2, 2213, 2214). No special requirement is checked for frames in Seismic
Zone 0.

 In all Seismic zones except Zone 0, for Ordinary Braced Frames, the
bracing connection force is reported at least as the smaller of the tensile
strength of the brace (FyA) and the following special loading combination
(UBC 2213.8.3.1, 2214.6.3.1).

1.0 DL + 1.0LL ± Ω0 EL (UBC 2213.8.3.1, 2214.6.3.1)

 In all Seismic Zones except Zone 0, for Special Concentrically Braced
Frames, the bracing connection force is reported at least as the smaller of
the tensile strength of the brace (FyA) and the following special loading
combination (UBC 2213.9.3.1, 2214.7):
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1.0 DL + 1.0LL ± Ω0 EL (UBC 2213.9.3, 2214.7)

 In all Seismic Zones except Zone 0, for Eccentrically Braced Frames, the
bracing connection force is reported as at least the brace strength in com-
pression that is computed as 1.7Fa A (UBC 2213.10.6, 2214.8). 1.7Fa A is
limited not to exceed Fy A.
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Continuity Plates

This Technical Note describes how this program can be used in the design of
continuity plates.

In a plan view of a beam/column connection, a steel beam can frame into a
column in the following ways:

1. The steel beam frames in a direction parallel to the column major direc-
tion, i.e., the beam frames into the column flange.

2. The steel beam frames in a direction parallel to the column minor direc-
tion, i.e., the beam frames into the column web.

3. The steel beam frames in a direction that is at an angle to both of the
principal axes of the column, i.e., the beam frames partially into the col-
umn web and partially into the column flange.

To achieve a beam/column moment connection, continuity plates such as
shown in Figure 1 are usually placed on the column, in line with the top and
bottom flanges of the beam, to transfer the compression and tension flange
forces of the beam into the column.

For the connection described in conditions 2 and 3 above, the thickness of
such plates is usually set equal to the flange thickness of the corresponding
beam. However, for the connection described by condition 1, where the beam
frames into the flange of the column, such continuity plates are not always
needed. The requirement depends on the magnitude of the beam-flange force
and the properties of the column. This is the condition that the program in-
vestigates. Columns of I-sections only are investigated. The program evalu-
ates the continuity plate requirements for each of the beams that frame into
the column flange (i.e., parallel to the column major direction) and reports
the maximum continuity plate area that is needed for each beam flange. The
continuity plate requirements are evaluated for moment frames only. No
check is made for braced frames.
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Figure 1 Elevation and Plan of Doubler Plates for a Column of I-Section
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The continuity plate area required for a particular beam framing into a column
is given by:

Acp = 
yc

bf

F
P

 - twc (tfb + 5kc) (ASD K1-9)

If Acp ≤ 0, no continuity plates are required, provided the following two condi-
tions are also satisfied:

 The depth of the column clear of the fillets, i.e., dc - 2kc, is less than or
equal to:

bf

ycwc

P

Ft 3100,4
(ASD K1-8)

 The thickness of the column flange, tfc, is greater than or equal to:

0.4
yc

bf

F
P

, where (ASD K1-1)

Pbf = fbAbf.

fb is the bending stress calculated from the larger of 5/3 of loading combina-
tions with gravity loads only (5/3)M/[(d-tf)Afb] and 4/3 of the loading combi-
nation with lateral loads (4/3)M/[(d-tf)Afb] (ASD K1.2). For special seismic de-
sign, fa is specified to be beam flange strength.

If continuity plates are required, they must satisfy a minimum area specifica-
tion defined as follows:

 The thickness of the stiffeners is at least .05 tfb, or

min
cpt  = 0.5 tfb (ASD K1.8.2)

 The width of the continuity plate on each side plus 1/2 the thickness of
the column web shall not be less than 1/3 of the beam flange width, or

min
cpb  = 





−

23
wcfb tb

(ASD K1.8.1)
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 So that the minimum area is given by:

min
cpA  = min

cpt min
cpb

Therefore, the continuity plate area provided by the program is either zero or

the greater of Acp and min
cpA .

Where

Abf = Area of beam flange

Acp = Required continuity plate area

Fyb = Yield stress of beam material

Fyc = Yield stress of the column and continuity plate material

tfb = Beam flange thickness

twc = Column web thickness

kc = Distance between outer face of the column flange and web
toe of its fillet

dc = Column depth

db = Beam depth

fb = Beam flange depth

tcp = Continuity plate thickness

bcp = Continuity plate width

fb = Bending stress calculated from the larger of 5/3 of loading
combinations with gravity loads only (5/3)M/[(d-tf)Afb] and
4/3 of the loading combinations with lateral loads (4/3)M/[(d-
tf)Afb] (ASD K1.2).

The special seismic requirements additionally checked by the program are de-
pendent on the type of framing used and are described below for each type of
framing. The requirements checked are based on UBC Section 2213 for
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frames in Seismic Zones 3 and 4 and UBC Section 2214 for frames in Seismic
Zones 1 and 2 (UBC 2204.2, 2205.2, 2212, 2214). No special requirement is
checked for frames in Seismic Zone 0.

 In all Seismic Zones except Zone 0, for Ordinary Moment Frames the con-
tinuity plates are checked and designed for a beam flange force, Pbf.

Pbf = fybAbf (UBC 2213.6.1, 2213.7.1.1, 2214.4.1, 2214.5.1.1)

 In Seismic Zones 3 and 4, for Special Moment-Resisting Frames, for de-
termining the need for continuity plates at joints resulting from tension
transfer from the beam flanges, the force Pbf is taken as 1.8 fybAbf (UBC
2213.7.4). For design of the continuity plate, the beam flange force is
taken as fybAbf (UBC 2213.7.1.1).

In Seismic Zones 1 and 2, for Special Moment-Resisting Frames, for de-
termining the need for continuity plates at joints resulting from tension
transfer from the beam flanges, the force Pbf is taken as fybAbf. For design
of the continuity plate, the beam flange force is taken as fybAbf (UBC
2214.5.1.1).

 In all Seismic zones except Zone 0, for Eccentrically Braced Frames, the
continuity plates are checked and designed for a beam flange force, Pbf.

Pbf = fybAbf (UBC 2213.10.12, 2213.10.19)
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This Technical Note explains how the program can be used in the design of
doubler plates.

One aspect of the design of a steel frame system is an evaluation of the shear
forces that exist in the region of the beam column intersection known as the
panel zone.

Shear stresses seldom control the design of a beam or column member. How-
ever, in a Moment-Resisting frame, the shear stress in the beam-column joint
can be critical, especially in framing systems when the column is subjected to
major direction bending and the joint shear forces are resisted by the web of
the column. In minor direction bending, the joint shear is carried by the col-
umn flanges, in which case the shear stresses are seldom critical, and this
condition is therefore not investigated by the program.

Shear stresses in the panel zone, resulting from major direction bending in
the column, may require additional plates to be welded onto the column web,
depending on the loading and geometry of the steel beams that frame into
the column, either along the column major direction, or at an angle so that
the beams have components along the column major direction. See Figure 1.
The program investigates such situations and reports the thickness of any re-
quired doubler plates. Only columns with I-shapes are investigated for dou-
bler plate requirements. Also doubler plate requirements are evaluated for
moment frames only. No check is made for braced frames.

The shear fore in the panel zone is given by:

Vp = P - Vc, or

Vp = ∑
= −

θb

n

n

n fn

nbn

td
M

1

cos
 - Vc
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Figure 1 Elevation and Plan of Doubler Plates for a Column of I-Section
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The required web thickness to resist the shear force, Vp, is given by

tr = 
yccv

p

F

h
dF

V

/380
≥ (ASD F4)

The extra thickness, or thickness of the doubler plate is given by

tdp = tr -twc, where

Fv = 0.40Fyc (ASD F4)

Fyc = Yield stress of the column and doubler plate material

tr = Required column web thickness

tdp = Required doubler plate thickness

tfn = Thickness of flange of the n-th beam connecting to column

twc = Column web thickness

Vp = Panel zone shear

Vc = Column shear in column above

P = Beam flange forces

nb = Number of beams connecting to column

dn = Depth of n-th beam connecting to column

h = dc - 2tfc if welded, dc - 2kc if rolled

θn = Angle between n-th beam and column major direction

dc = Depth of column

Mbn = Calculated factored beam moment from the corresponding
loading combination

The largest calculated value of Vp calculated for any of the load combinations
based on the factored beam moments is used to calculate doubler plate ar-
eas.
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The special seismic requirements checked by the program for calculating dou-
bler plate areas are dependent on the type of framing used and are described
below for each type of framing. The requirements checked are based on UBC
Section 2213 for frames in Seismic Zones 3 and 4 and on UBC Section 2214
for frames in Seismic Zones 1 and 2 (UBC 2204.2, 2205.2, 2213, 2214). No
special requirement is checked for frames in Seismic Zones 0, 1 and 2.

 In Seismic Zones 3 and 4, for Special Moment-Resisting Frames, the
panel zone doubler plate requirements that are reported will develop the
lesser of beam moments equal to 0.8 of the plastic moment capacity of
the beam (0.8∑Mpb), or beam moments caused by gravity loads plus 1.85
times the seismic load (UBC 2213.7.2.1).

The capacity of the panel zone in resisting this shear is taken as (UBC
2213.7.2.1):

VP = 0.55Fycdctr 









+

rcb

cfc

tdd
tb 23

1 (UBC 2213.7.2.1)

giving the required panel zone thickness as

tr = 
yccb

cfc

cyc

p

F

h
dd
tb

dF

V

/380

3
55.0

2

≥− (UBC 2213.7.2.1, ASD F4)

and the required doubler plate thickness as

tdp = tr - twc

where

bc = width of column flange

h = dc-2tfc if welded, dc-2kc if rolled,

tcf = thickness of column flange, and

db = depth of deepest beam framing into the major direction of
the column

 In Seismic Zones 3 and 4 for Special Moment-Resisting Frames, the pro-
gram checks the following panel zone column web thickness requirement:
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twc ≥ 
90

)2()2( fbbfcc tdtd −+−
(UBC 2213.7.2.2)

If the check is not satisfied, it is noted in the output.

 In Seismic Zones 3 and 4, for Eccentrically Braced Frames, the doubler
plate requirements are checked similar to the doubler plate checks for
special Moment-Resisting frames as described previously (UBC
2213.10.19).
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Technical Note 17
Input Data

This Technical Note describes the steel frame design input data for UBC97-
ASD. The input can be printed to a printer or to a text file when you click the
File menu > Print Tables > Steel Frame Design command. A printout of
the input data provides the user with the opportunity to carefully review the
parameters that have been input into the program and upon which program
design is based.  Further information about using the Print Design Tables
Form is provided at the end of this Technical Note.

Input Data
The program provides the printout of the input data in a series of tables. The
column headings for input data and a description of what is included in the
columns of the tables are provided in Table 1 of this Technical Note.

Table 1  Steel Frame Design Input Data
COLUMN HEADING DESCRIPTION
Material Property Data
Material Name Steel, concrete or other.

Material Type Isotropic or orthotropic.

Design Type Concrete, steel or none. Postprocessor available if steel is
specified.

Material Dir/Plane "All" for isotropic materials; specify axis properties define for
orthotropic.

Modulus of Elasticity

Poisson's Ratio

Thermal Coeff

Shear Modulus

Material Property Mass and Weight
Material Name Steel, concrete or other.
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Table 1  Steel Frame Design Input Data
COLUMN HEADING DESCRIPTION

Mass Per Unit Vol Used to calculate self mass of the structure.

Weight Per Unit Vol Used to calculate the self weight of the structure.

Material Design Data for Steel Materials
Material Name Steel.

Steel FY Minimum yield stress of steel.

Steel FU Maximum tensile stress of steel.

Steel Cost ($) Cost per unit weight used in composite beam design if optimum
beam size specified to be determined by cost.

Material Design Data for Concrete Materials
Material Name Concrete.

Lightweight Concrete Check this box if this is a lightweight concrete material.

Concrete FC Concrete compressive strength.

Rebar FY Bending reinforcing yield stress.

Rebar FYS Shear reinforcing yield stress.

Lightwt Reduc Fact Define reduction factor if lightweight concrete box checked.
Usually between 0.75 ad 0.85.

Frame Section Property Data
Frame Section Name User specified or auto selected member name.

Material Name Steel, concrete or none.

Section Shape Name
or Name in Section
Database File

Name of section as defined in database files.

Section Depth Depth of the section.

Flange Width Top Width of top flange per AISC database.

Flange Thick Top Thickness of top flange per AISC database.

Web Thick Web thickness per AISC database.

Flange Width Bot Width of bottom flange per AISC database.

Flange Thick Bot Thickness of bottom flange per AISC database.

Section Area
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Table 1  Steel Frame Design Input Data
COLUMN HEADING DESCRIPTION

Torsional Constant

Moments of Inertia I33, I22

Shear Areas A2, A3

Section Moduli S33, S22

Plastic Moduli Z33, Z22

Radius of Gyration R33, R22

Load Combination Multipliers
Combo Load combination name.

Type Additive, envelope, absolute, or SRSS as defined in Define >
Load Combination.

Case Name(s) of case(s) to be included in this load combination.

Case Type Static, response spectrum, time history, static nonlinear, se-
quential construction.

Factor Scale factor to be applied to each load case.

Beam Steel Stress Check Element Information
Story Level Name of the story level.

Beam Bay Beam bay identifier.

Section ID Name of member section assigned.

Framing Type Ordinary MRF, Special MRF, Braced Frame, Special CBF, ERF

RLLF Factor Live load reduction factor.

L_Ratio Major Ratio of unbraced length divided by the total member length.

L_Ratio Minor Ratio of unbraced length divided by the total member length.

K Major Effective length factor.

K Minor Effective length factor.

Beam Steel Moment Magnification Overwrites

Story Level Name of the story level.

Beam Bay Beam bay identifier.

CM Major As defined in AISC-ASD, page 5-55.
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Table 1  Steel Frame Design Input Data
COLUMN HEADING DESCRIPTION

CM Minor As defined in AISC-ASD, page 5-55.

Cb Factor As defined in AISC-ASD, page 5-47.

Beam Steel Allowables & Capacities Overwrites

Story Level Name of the story level.

Beam Bay Beam bay identifier.

Fa If zero, yield stress defined for material property data used and
AISC-ASD specification Chapter E.

Ft If zero, as defined for material property data used and AISC-
ASD Chapter D.

Fb Major If zero, as defined for material property data used and AISC-
ASD specification Chapter F.

Fb Minor If zero, as defined for material property data used and AISC-
ASD specification Chapter F.

Fv Major If zero, as defined for material property data used and AISC-
ASD specification Chapter F.

Fv Minor If zero, as defined for material property data used and AISC-
ASD specification Chapter F.

Column Steel Stress Check Element Information

Story Level Name of the story level.

Column Line Column line identifier.

Section ID Name of member sections assigned.

Framing Type Ordinary MRF, Special MRF, Braced Frame, Special CBF, ERF

RLLF Factor Live load reduction factor.

L_Ratio Major Ratio of unbraced length divided by the total member length.

L_Ratio Minor Ratio of unbraced length divided by the total member length.

K Major Effective length factor.

K Minor Effective length factor.

Column Steel Moment Magnification Overwrites

Story Level Name of the story level.
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Table 1  Steel Frame Design Input Data
COLUMN HEADING DESCRIPTION

Column Line Column line identifier.

CM Major As defined in AISC-ASD, page 5-55.

CM Minor As defined in AISC-ASD, page 5-55.

Cb Factor As defined in AISC-ASD, page 5-47.

Column Steel Allowables & Capacities Overwrites

Story Level Name of the story level.

Column Line Column line identifier.

Fa If zero, yield stress defined for material property data used and
AISC-ASD specification Chapter E.

Ft If zero, as defined for material property data used and AISC-
ASD Chapter D.

Fb Major If zero, as defined for material property data used and AISC-
ASD specification Chapter F.

Fb Minor If zero, as defined for material property data used and AISC-
ASD specification Chapter F.

Fv Major If zero, as defined for material property data used and AISC-
ASD specification Chapter F.

Fv Minor If zero, as defined for material property data used and AISC-
ASD specification Chapter F.

Using the Print Design Tables Form
To print steel frame design input data directly to a printer, use the File menu
> Print Tables > Steel Frame Design command and click the Input Sum-
mary check box on the Print Design Tables form. Click the OK button to send
the print to your printer. Click the Cancel button rather than the OK button
to cancel the print. Use the File menu > Print Setup command and the
Setup>> button to change printers, if necessary.

To print steel frame design input data to a file, click the Print to File check box
on the Print Design Tables form. Click the Filename button to change the
path or filename. Use the appropriate file extension for the desired format
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(e.g., .txt, .xls, .doc). Click the Save buttons on the Open File for Printing
Tables form and the Print Design Tables form to complete the request.

Note:

The File menu > Display Input/Output Text Files command is useful for displaying out-
put that is printed to a text file.

The Append check box allows you to add data to an existing file. The path and
filename of the current file is displayed in the box near the bottom of the Print
Design Tables form. Data will be added to this file. Or use the Filename
button to locate another file, and when the Open File for Printing Tables cau-
tion box appears, click Yes to replace the existing file.

If you select a specific frame element(s) before using the File menu > Print
Tables > Steel Frame Design command, the Selection Only check box will
be checked. The print will be for the selected beam(s) only.
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Technical Note 18
Output Details

This Technical Note describes the steel frame design output for UBC97-ASD
that can be printed to a printer or to a text file. The design output is printed
when you click the File menu > Print Tables > Steel Frame Design com-
mand and select Output Summary on the Print Design Tables form. Further
information about using the Print Design Tables form is provided at the end of
this Technical Note.

The program provides the output data in tables. The column headings for
output data and a description of what is included in the columns of the tables
are provided in Table 1 of this Technical Note.

Table 1 Steel Frame Design Output
COLUMN HEADING DESCRIPTION

Beam Steel Stress Check Output

Story Level Name of the story level.

Beam Bay Beam bay identifier.

Section ID Name of member sections assigned.

Moment Interaction Check

Combo Name of load combination that produces maximum stress ratio.

Ratio Ratio of acting stress to allowable stress.

Axl Ratio of acting axial stress to allowable axial stress.

B33 Ratio of acting bending stress to allowable bending stress
about the 33 axis.

B22 Ratio of acting bending stress to allowable bending stress
about the 22 axis.
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Table 1 Steel Frame Design Output
COLUMN HEADING DESCRIPTION

Shear22

Combo Load combination that produces the maximum shear parallel to
the 22 axis.

Ratio Ratio of acting shear stress divided by allowable shear stress.

Shear33

Combo Load combination that produces the maximum shear parallel to
the 33 axis.

Ratio Ratio of acting shear stress divided by allowable shear stress.

Beam Special Seismic Requirements

Story Level Name of the story level.

Beam Bay Beam bay identifier.

Section ID Name of member sections assigned.

Section Class Classification of section for the enveloping combo.

Connection Shear

Combo Name of the load combination that provides maximum End-I
connection shear.

END-I Maximum End-I connection shear.

Combo Name of the load combination that provides maximum End-J
connection shear.

END-J Maximum End-J connection shear.

Column Steel Stress Check Output

Story Level Name of the story level.



Steel Frame Design UBC97-ASD  Output Details

Table 1 Steel Frame Design Output Technical Note 18 - 3

Table 1 Steel Frame Design Output
COLUMN HEADING DESCRIPTION

Column Line Column line identifier.

Section ID Name of member sections assigned.

Moment Interaction Check

Combo Name of load combination that produces maximum stress ratio.

Ratio Ratio of acting stress to allowable stress.

AXL Ratio of acting axial stress to allowable axial stress.

B33 Ratio of acting bending stress to allowable bending stress
about the 33 axis.

B22 Ratio of acting bending stress to allowable bending stress
about the 22 axis.

Shear22

Combo Load combination that produces the maximum shear parallel to
the 22 axis.

Ratio Ratio of acting shear stress divided by allowable shear stress.

Shear33

Combo Load combination that produces the maximum shear parallel to
the 33 axis.

Ratio Ratio of acting shear stress divided by allowable shear stress.

Column Special Seismic Requirements

Story Level Story level name.

Column Line Column line identifier.

Section ID Name of member section assigned.
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Table 1 Steel Frame Design Output
COLUMN HEADING DESCRIPTION

Section Class Classification of section for the enveloping combo.

Continuity Plate

Combo Name of load combination that produces maximum continuity
plate area.

Area Cross-section area of the continuity plate.

Doubler Plate

Combo Name of load combination that produces maximum doubler
plate thickness.

Thick Thickness of the doubler plate.

B/C Ratios

Major Beam/column capacity ratio for major direction.

Minor Beam/column capacity ratio for minor direction.

Using the Print Design Tables Form
To print steel frame design output data directly to a printer, use the File
menu > Print Tables > Steel Frame Design command and click the Out-
put Summary check box on the Print Design Tables form. Click the OK button
to send the print to your printer. Click the Cancel button rather than the OK
button to cancel the print. Use the File menu > Print Setup command and
the Setup>> button to change printers, if necessary.

To print steel frame design output data to a file, click the Print to File check
box on the Print Design Tables form. Click the Filename button to change the
path or filename. Use the appropriate file extension for the desired format
(e.g., .txt, .xls, .doc). Click the Save buttons on the Open File for Printing
Tables form and the Print Design Tables form to complete the request.
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Note:

The File menu > Display Input/Output Text Files command is useful for displaying out-
put that is printed to a text file.

The Append check box allows you to add data to an existing file. The path and
filename of the current file is displayed in the box near the bottom of the Print
Design Tables form. Data will be added to this file. Or use the Filename
button to locate another file, and when the Open File for Printing Tables cau-
tion box appears, click Yes to replace the existing file.

If you select a specific frame element(s) before using the File menu > Print
Tables > Steel Frame Design command, the Selection Only check box will
be checked. The print will be for the selected beam(s) only.
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Technical Note 19
General and Notation

Introduction to the UBC97-LRFD Series of Technical
Notes
The UBC97-LRFD design code in this program implements the International
Conference of Building Officials 1997 Uniform Building Code: Volume 2:
Structural Engineering Design Provisions, Chapter 22, Division II, "Design
Standard for Load and Resistance Factor Design Specification for Structural
Steel Buildings (ICBO 1997).

Chapter 22, Division III of UBC adopted the American Institute of Steel Con-
struction's Load and Resistance Factor Design Specification for Structural
Steel Buildings (AISC 1993), which has been implemented in the AISC-
LRFD93 code in ETABS.

For referring to pertinent sections and equations of the UBC code, a unique
prefix "UBC" is assigned. For referring to pertinent sections and equations of
the AISC-LRFD code, a unique prefix "LRFD" is assigned. However, all refer-
ences to the "Specifications for Load and Resistance Factored Design of Sin-
gle-Angle Members" (AISC 1994) carry the prefix of "LRFD SAM." Moreover,
all sections of the "Seismic Provisions for Structural Steel Buildings June 15,
1992" (AISC 1994) are referred to as Section 2211.4 of the UBC code. In the
UBC97-LRFD Technical Notes, all sections and subsections referenced by "UBC
2211.4" or "UBC 2211.4.x" refer to the LRFD Seismic Provisions after UBC
amendments through UBC Section 2210. Various notations used in the Steel
Frame Design UBC97-LRFD series of Technical Notes are described herein.

When using the UBC97-LRFD option, the following Framing Systems are rec-
ognized (UBC 1627, 2210):

 Ordinary Moment Frame (OMF)

 Special Moment-Resisting Frame (SMRF)
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 Concentrically Braced Frame (CBF)

 Eccentrically Braced Frame (EBF)

 Special Concentrically Braced Frame (SCBF)

By default the frame type is taken as Special-Moment Resisting (SMRF) in the
program. However, the frame type can be overwritten in the Preferences
(Options menu > Preferences > Steel Frame Design) to change the de-
fault values and in the Overwrites (Design menu > Steel Frame Design >
View/Revise Overwrites) on a member-by-member basis. If any member
is assigned with a frame type, the change of the frame type in the Preference
will not modify the frame type of the individual member for which it is as-
signed.

When using the UBC97-LRFD option, a frame is assigned to one of the fol-
lowing five Seismic Zones (UBC 2210):

 Zone 0

 Zone 1

 Zone 2

 Zone 3

 Zone 4

By default the Seismic Zone is taken as Zone 4 in the program. However, the
frame type can be overwritten in the Preferences to change the default (Op-
tions menu > Preferences > Steel Frame Design).

The design is based on user-specified loading combinations. To facilitate use,
the program provides a set of default load combinations that should satisfy
requirements for the design of most building type structures. See UBC97-
LRFD Steel Frame Design Technical Note 22 Design Load Combinations for
more information.

In the evaluation of the axial force/biaxial moment capacity ratios at a station
along the length of the member, first the actual member force/moment com-
ponents and the corresponding capacities are calculated for each load combi-
nation. Then, the capacity ratios are evaluated at each station under the in-
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fluence of all load combinations using the corresponding equations that are
defined in this series of Technical Notes. The controlling capacity ration is
then obtained. A capacity ratio greater than 1.0 indicates exceeding a limit
state. Similarly, a shear capacity ration is also calculated separately. Algo-
rithms for completing these calculations are described in UBC97-LRFD Steel
Frame Design Technical Note 24 Calculation of Factored Forces and Moments,
Technical Note 25 Calculation of Nominal Strengths, and Technical Note 26
Calculation of Capacity Ratios.

Further information is available from UBC97-LRFD Steel Frame Design Techni-
cal Notes 23 Classification of Sections, Technical Notes 28 Joint Design, Tech-
nical Notes 29 Continuity Plates, and Technical Notes 30 Doubler Plates.

Information about seismic requirements is provided in UBC97-LRFD Steel
Frame Design Technical Note 27 Seismic Requirements.

The program uses preferences and overwrites, which are described in UBC97-
LRFD Steel Frame Design Technical Note 20 Preferences and Technical Note
21 Overwrites. It also provides input and output data summaries, which are
described in UBC97-LRFD Steel Frame Design Technical Note 31 Input Data
and Technical Note 32 Output Details.

English as well as SI and MKS metric units can be used for input. The code is
based on Kip-Inch-Second units. For simplicity, all equations and descriptions
presented in the UBC97-LRFD series of Technical Notes correspond to Kip-
Inch-Second units unless otherwise noted.

Notation
A Cross-sectional area, in2

Ae Effective cross-sectional area for slender sections, in2

Ag Gross cross-sectional area, in2

Av2,Av3 Major and minor shear areas, in2

Aw Shear area, equal dtw per web, in2

B1 Moment magnification factor for moments not causing side-
sway
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B2 Moment magnification factor for moments causing sidesway

Cb Bending coefficient

Cm Moment coefficient

Cw Warping constant, in6

D Outside diameter of pipes, in

E Modulus of elasticity, ksi

Fcr Critical compressive stress, ksi

Fr Compressive residual stress in flange assumed 10.0 for rolled
sections and 16.5 for welded sections, ksi

Fy Yield stress of material, ksi

G Shear modulus, ksi

I22 Minor moment of inertia, in4

I33 Major moment of inertia, in4

J Torsional constant for the section, in4

K Effective length factor

K33,K22 Effective length K-factors in the major and minor directions

Lb Laterally unbraced length of member, in

Lp Limiting laterally unbraced length for full plastic capacity, in

Lr Limiting laterally unbraced length for inelastic lateral-torsional
buckling, in

Mcr Elastic buckling moment, kip-in

Mlt Factored moments causing sidesway, kip-in

Mnt Factored moments not causing sidesway, kip-in
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Mn33,Mn22 Nominal bending strength in major and minor directions, kip-
in

Mob Elastic lateral-torsional buckling moment for angle sections,
kip-in

Mr33, Mr22 Major and minor limiting buckling moments, kip-in

Mu Factored moment in member, kip-in

Mu33, Mu22 Factored major and minor moments in member, kip-in

Pe Euler buckling load, kips

Pn Nominal axial load strength, kip

Pu Factored axial force in member, kips

Py AgFy, kips

Q Reduction factor for slender section, = QaQs   

Qa Reduction factor for stiffened slender elements

Qs Reduction factor for unstiffened slender elements

S Section modulus, in3

S33,S22 Major and minor section moduli, in3

Seff,33,Seff,22 Effective major and minor section moduli for slender sections,
in3

Sc Section modulus for compression in an angle section, in3

Vn2,Vn3 Nominal major and minor shear strengths, kips

Vu2,Vv3 Factored major and minor shear loads, kips

Z Plastic modulus, in3

Z33,Z22 Major and minor plastic moduli, in3

b Nominal dimension of plate in a section, in
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longer leg of angle sections,
bf  ― 2tw for welded and bf  ― 3tw for rolled box sections, etc.

be Effective width of flange, in

bf Flange width, in

d Overall depth of member, in

de Effective depth of web, in

hc Clear distance between flanges less fillets, in
assumed d ― 2k for rolled sections, and d ― 2tf for welded
sections

k Distance from outer face of flange to web toe of fillet, in

kc Parameter used for section classification,
 wth4 , 0.35 ≤ kc ≤ 0.763

l33,l22 Major and minor directions unbraced member lengths, in

r Radius of gyration, in

r33,r22 Radii of gyration in the major and minor directions, in

t Thickness, in

tf Flange thickness, in

tw Thickness of web, in

βw Special section property for angles, in

λ Slenderness parameter

λc,λe Column slenderness parameters

λp Limiting slenderness parameter for compact element

λr Limiting slenderness parameter for non-compact element

λs Limiting slenderness parameter for seismic element
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λslender Limiting slenderness parameter for slender element

ϕb Resistance factor for bending, 0.9

ϕc Resistance factor for compression, 0.85

ϕt Resistance factor for tension, 0.9

ϕv Resistance factor for shear, 0.9

References
American Institute of Steel Construction (AISC). 1993. Load and Resistance

Factor Design Specification for Structural Steel Building. Chicago, Illi-
nois.

American Institute of Steel Construction (AISC). 1994. Manual of Steel Con-
struction, Load & Resistance Factor Design, 2nd Edition. Chicago, Illi-
nois.

International Conference of Building Officials (ICBO). 1997. 1997 Uniform
Building Code Volume 2, Structural Engineering Design Provisions.
Whittier, California.
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Preferences

This Technical Note describes the items in the Preferences form.

General
The steel frame design preferences in this program are basic assignments
that apply to all steel frame elements. Use the Options menu > Prefer-
ences > Steel Frame Design command to access the Preferences form
where you can view and revise the steel frame design preferences.

Default values are provided for all steel frame design preference items. Thus,
it is not required that you specify or change any of the preferences. You
should, however, at least review the default values for the preference items
to make sure they are acceptable to you.

Using the Preferences Form
To view preferences, select the Options menu > Preferences > Steel
Frame Design. The Preferences form will display.  The preference options
are displayed in a two-column spreadsheet. The left column of the spread-
sheet displays the preference item name. The right column of the spreadsheet
displays the preference item value.

To change a preference item, left click the desired preference item in either
the left or right column of the spreadsheet. This activates a drop-down box or
highlights the current preference value. If the drop-down box appears, select
a new value. If the cell is highlighted, type in the desired value. The prefer-
ence value will update accordingly. You cannot overwrite values in the drop-
down boxes.

When you have finished making changes to the composite beam preferences,
click the OK button to close the form. You must click the OK button for the
changes to be accepted by the program. If you click the Cancel button to exit
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the form, any changes made to the preferences are ignored and the form is
closed.

Preferences
For purposes of explanation in this Technical Note, the preference items are
presented in Table 1. The column headings in the table are described as fol-
lows:

 Item: The name of the preference item as it appears in the cells at the
left side of the Preferences form.

 Possible Values: The possible values that the associated preference item
can have.

 Default Value: The built-in default value that the program assumes for
the associated preference item.

 Description: A description of the associated preference item.

Table 1: Steel Frame Preferences

Item
Possible
Values

Default
Value Description

Design Code Any code in the
program

AISC-ASD89 Design code used for design of
steel frame elements.

Time History
Design

Envelopes,
Step-by-Step

Envelopes Toggle for design load combina-
tions that include a time history
designed for the envelope of the
time history, or designed step-by-
step for the entire time history. If a
single design load combination
has more than one time history
case in it, that design load combi-
nation is designed for the enve-
lopes of the time histories, re-
gardless of what is specified here.
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Table 1: Steel Frame Preferences

Item
Possible
Values

Default
Value Description

Frame Type Ordinary MRF;
Special MRF;

Braced Frame;
Special CBF;

EBF

Ordinary MRF

Zone Zone 0,
Zone 1,
Zone 2,
Zone 3,
Zone 4

Zone 4 Seismic zone.

Omega0 ≥0 2.8

Stress Ratio
Limit

>0 .95 Program will select members from
the auto select list with stress ra-
tios less than or equal to this
value.

Maximum Auto
Iteration

≥1 1 Sets the number of iterations of the
analysis-design cycle that the pro-
gram will complete automatically
assuming that the frame elements
have been assigned as auto select
sections.
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Overwrites

General
The steel frame design overwrites are basic assignments that apply only to
those elements to which they are assigned. This Technical Note describes
steel frame design overwrites for UBC97-LRFD. To access the overwrites, se-
lect an element and click the Design menu > Steel Frame Design >
View/Revise Overwrites command.

Default values are provided for all overwrite items. Thus, you do not need to
specify or change any of the overwrites. However, at least review the default
values for the overwrite items to make sure they are acceptable. When
changes are made to overwrite items, the program applies the changes only
to the elements to which they are specifically assigned; that is, to the ele-
ments that are selected when the overwrites are changed.

Overwrites
For explanation purposes in this Technical Note, the overwrites are presented
in Table 1. The column headings in the table are described as follows.

 Item: The name of the overwrite item as it appears in the program. To
save space in the forms, these names are generally short.

 Possible Values: The possible values that the associated overwrite item
can have.

 Default Value: The default value that the program assumes for the associ-
ated overwrite item. If the default value is given in the table with an asso-
ciated note "Program Palculated," the value is shown by the program before
the design is performed. After design, the values are calculated by the pro-
gram and the default is modified by the program-calculated value.

 Description: A description of the associated overwrite item.
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An explanation of how to change an overwrite is provided at the end of this
Technical Note.

Table 1 Steel Frame Design Overwrites

Item
Possible
Values

Default
Value Description

Current Design
Section

Indicates selected member size used in
current design.

Element Type Ordinary MRF;
Special MRF;

Braced Frame;
Special CBF;

EBF

From
Preferences

Live Load
Reduction

Factor

≥0 1 Live load is multiplied by this factor.

Horizontal
Earthquake

Factor

≥0 1 Earthquake loads are multiplied by this
factor.

Unbraced
Length Ratio

(Major)

≥0 1 Ratio of unbraced length divided by
total length.

Unbraced
Length Ratio
(Minor, LTB)

≥0 1 Ratio of unbraced length divided by
total length.

Effective
Length Factor

(K Major)

≥0 1 As defined in AISC-LRFD Table C-
C2.1, page 6-184.

Effective
Length Factor

(K Minor)

≥0 1 As defined in AISC-LRFD Table C-
C2.1, page 6-184.

Moment
Coefficient
(Cm Major)

≥0 0.85 As defined in AISC-LRFD specification
Chapter C.

Moment
Coefficient
(Cm Minor)

≥0 0.85 As defined in AISC-LRFD specification
Chapter C.



Steel Frame Design UBC97-LRFD  Overwrites

Overwrites Technical Note 21 - 3

Table 1 Steel Frame Design Overwrites

Item
Possible
Values

Default
Value Description

Bending
Coefficient

(Cb)

≥0 1 As defined in AISC-LRFD specification
Chapter F.

NonSway
Moment
Factor

(B1 Major)

≥0 1 As defined in AISC-LRFD specification
Chapter C.

NonSway
Moment
Factor

(B1 Minor)

≥0 1 As defined in AISC-LRFD specification
Chapter C.

Sway Moment
Factor

(B2 Major)

≥0 1 As defined in AISC-LRFD specification
Chapter C.

Sway Moment
Factor

(B2 Minor)

≥0 1 As defined in AISC-LRFD specification
Chapter C.

Yield stress, Fy ≥0 0 If zero, yield stress defined for material
property data used.

Omega0 ≥0 From
Preferences

Seismic force amplification factor as
required by the UBC.

Compressive
Capacity,
phi*Pnc

≥0 0 If zero, as defined for Material Property
Data used and per AISC-LRFD specifi-
cation Chapter E.

Tensile
Capacity,
phi*Pnt

≥0 0 If zero, as defined for Material Property
Data used and per AISC-LRFD specifi-
cation Chapter D.

Major Bending
Capacity,
phi*Mn3

≥0 0 If zero, as defined for Material Property
Data used and per AISC-LRFD specifi-
cation Chapter F and G.

Minor Bending
Capacity,
phi*Mn2

≥0 0 If zero, as defined for Material Property
Data used and per AISC-LRFD specifi-
cation Chapter F and G.
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Table 1 Steel Frame Design Overwrites

Item
Possible
Values

Default
Value Description

Major Shear
Capacity,
phi*Vn2

≥0 0 If zero, as defined for Material Property
Data used and per AISC-LRFD specifi-
cation Chapter F.

Minor Shear
Capacity,
phi*Vn3

≥0 0 If zero, as defined for Material Property
Data used and per AISC-LRFD specifi-
cation Chapter F.

Making Changes in the Overwrites Form
To access the steel frame overwrites, select a frame element and click the
Design menu > Steel Frame Design > View/Revise Overwrites com-
mand.

The overwrites are displayed in the form with a column of check boxes and a
two-column spreadsheet. The left column of the spreadsheet contains the
name of the overwrite item. The right column of the spreadsheet contains the
overwrites values.

Initially, the check boxes in the Steel Frame Design Overwrites form are all
unchecked and all of the cells in the spreadsheet have a gray background to
indicate that they are inactive and the items in the cells cannot be changed.
The names of the overwrite items are displayed in the first column of the
spreadsheet. The values of the overwrite items are visible in the second col-
umn of the spreadsheet if only one frame element was selected before the
overwrites form was accessed. If multiple elements were selected, no values
show for the overwrite items in the second column of the spreadsheet.

After selecting one or multiple elements, check the box to the left of an over-
write item to change it. Then left click in either column of the spreadsheet to
activate a drop-down box or highlight the contents in the cell in the right col-
umn of the spreadsheet. If the drop-down box appears, select a value from
the box. If the cell contents is highlighted, type in the desired value. The
overwrite will reflect the change. You cannot change the values of the drop-
down boxes.
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When changes to the overwrites have been completed, click the OK button to
close the form. The program then changes all of the overwrite items whose
associated check boxes are checked for the selected members. You must click
the OK button for the changes to be accepted by the program. If you click the
Cancel button to exit the form, any changes made to the overwrites are ig-
nored and the form is closed.

Resetting Steel Frame Overwrites to Default Values
Use the Design menu > Steel Frame Design > Reset All Overwrites
command to reset all of the steel frame overwrites. All current design results
will be deleted when this command is executed.

Important note about resetting overwrites: The program defaults for the
overwrite items are built into the program. The steel frame overwrite values
that were in a .edb file that you used to initialize your model may be different
from the built-in program default values. When you reset overwrites, the pro-
gram resets the overwrite values to its built-in values, not to the values that
were in the .edb file used to initialize the model.
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Design Load Combinations

The design load combinations are the various combinations of the load cases
for which the structural members and joints need to be designed or checked.
For the UBC97-LRFD code, if a structure is subjected to dead load (DL), live
load (LL), wind load (WL), and earthquake induced load (EL), and considering
that wind and earthquake forces are reversible, the following load combina-
tions may need to be defined (UBC 2204.1, 2206, 2207.3, 2210.3, 1612.2.1):

1.4 DL (UBC 1612.2.1 12-1)
1.2 DL + 1.4 LL (UBC 1612.2.1 12-2)

1.2 DL ± 0.8 WL (UBC 1612.2.1 12-3)
0.9 DL ± 1.3 WL (UBC 1612.2.1 12-6)
1.2 DL + 0.5 LL ± 1.3 WL (UBC 12.12.2.1 12-4)

1.2 DL ± 1.0 EL (UBC 1612.2.1 12-5)
0.9 DL ± 1.0 EL (UBC 1612.2.1 12-6)
1.2 DL + 0.5 LL ± EL (UBC 1612.2.1 12-5)

These are also the default design load combinations in the program whenever
the UBC97-LRFD code is used. The user should include other appropriate
loading combinations if roof live load is separately treated, if other types of
loads are present, or if pattern live loads are to be considered.

Live load reduction factors can be applied to the member forces of the live
load case on an element-by-element basis to reduce the contribution of the
live load to the factored loading. See UBC97-LRFD Steel Frame Design Tech-
nical Note 21 Overwrites for more information.

When using the UBC97-LRFD code, the program design assumes that a P-
delta analysis has been performed so that moment magnification factors for
moments causing sidesway can be taken as unity. It is recommended that the
P-delta analysis be completed at the factored load level of 1.2 DL plus 0.5 LL
(White and Hajjar 1991).
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It is noted here that whenever special seismic loading combinations are
required by the code for special circumstances, the program automatically
generates those load combinations internally. The following additional seismic
load combinations are frequently checked for specific types of members and
special circumstances.

0.9 DL ± Ωo EL (UBC 2210.3, 2211.4.3.1)
1.2 DL + 0.5 LL ± Ωo EL (UBC 2210.3, 2211.4.3.1)

where Ωo is the seismic force amplification factor that is required to account
for structural overstrength. The default value of Ωo is taken as 2.8 in the pro-
gram. However, Ωo can be overwritten in the Preferences (Options menu >
Preferences > Steel Frame Design command) to change the default and in
the Overwrites (Design menu > Steel Frame Design > View/Revise
Overwrites command) on a member-by-member basis. If any member is
assigned a value for Ωo, the change of Ωo in the Preferences will not modify Ωo

of the individual member for which Ωo has been assigned. The guidelines for
selecting a reasonable value can be found in UBC 1630.3.1 and UBC Table 16-
N. Other similar special loading combinations are described in UBC97-LRFD
Steel Frame Design Technical Note 27 Seismic Requirements and Technical
Note 28 Joint Design.

The combinations described herein are internal to the program. The user does
NOT need to create additional load combinations for these load combinations.
The special circumstances for which these load combinations are additionally
checked are described in UBC97-LRFD Steel Frame Design Technical Note 27
Seismic Requirements and Technical Note 28 Joint Design. The special loading
combination factors are applied directly to the program load cases. It is as-
sumed that any required scaling (such as may be required to scale response
spectra results) has already been applied to the progam load cases.

Reference
White, D.W. and J.F. Hajjar. 1991. Application of Second-Order Elastic Analy-

sis in LRFD:  Research to Practice. Engineering Journal. American In-
stitute of Steel Construction, Inc. Vol. 28. No. 4.
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Technical Note 23
Classification of Sections

This Technical Note explains the classification of sections when the user se-
lects the UBC97-LRFD design code.

The nominal strengths for axial compression and flexure depend on the clas-
sification of the section as Compact, Noncompact, Slender or Too Slender.
The section classification in UBC97-LRFD is the same as described in the
AISC-LRFD93 Steel Frame Design Technical Note 47 Classification of Sections,
with the exceptions described in the next paragraph. The program classifies
individual members according to the limiting width/thickness ratios given in
Table 1 and Table 2 of AISC-LRFD93 Technical Note 47 Classification of Sec-
tions (UBC 2204.1, 2205, 2206, and 2210; LRFD B5.1, A-G1, and Table A-
F1.1). The definition of the section properties required in these tables is given
in Figure 1 of AISC-LRFD93 Technical Note 47 Classification of Sections and
Technical Note 43 General and Notations. The same limitations apply.

In general, the design sections need not necessarily be Compact to satisfy
UBC97-LRFD codes (UBC 2213.2). However, for certain special seismic cases,
they must be Compact and must satisfy special slenderness requirements.
See the UBC97-LRFD Steel Frame Design Technical Note 27 Seismic Require-
ments. The sections that satisfy the additional requirements are classified and
reported by the program as "SEISMIC." Those special requirements for clas-
sifying the sections as SEISMIC (i.e., "Compact" in UBC) are summarized
herein in Table 1 (UBC 2210.8, 2210.10c, 2211.4.8.4.b, 2211.9.2.d,
2210.10g, 2211.4.10.6.e). If these criteria are not satisfied when the code
requires it, the user must modify the section property. In that case, the pro-
gram gives a warning message in the output file.
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Table 1 Limiting Width-Thickness Ratios for Classification of Sections
When Special Seismic Conditions Apply in Accordance with
UBC97-LRFD

Description of
Section

Width-
Thickness

Ratio λλλλ

SEISMIC
(Speical requirements

in seismic design)
(λλλλp) Section References

bf / 2tf ≤ 52 / yF
UBC 2211.4.8.4.b (SMRF)

UBC 2211.4 Table 8-1 (SMRF)

I-SHAPE
hc / tw

For Pu / ϕbPy ≤ 0.125,

≤ 











ϕ
−

yb

u

y
P
P

F
54.11

520

For Pu / ϕbPy > 0.125,

≤ 












≥










ϕ
−

yyb

u

y FP
P

F

253
33.2

191

UBC 2211.4.8.4.b (SMRF)
UBC 2211.4 Table 8-1 (SMRF)

b / tf
or

hc / tw

≤ 110 / yF  (Beam and

column in SMRF, column in
SCBF, Braces in BF)

UBC 2210.8 (SMRF)
UBC 2210.10.g (SCBF)
UBC 2211.4.9.2.d (BF)BOX

b / tf
or

hc / tw

≤ 100 / yF

(Braces in SCBF)
UBC 2210.10.c (SCBF)

CHANNEL bf / tf
hc / tw

Same as I-Shapes
Same as I-Shapes

UBC 2211.4.8.4.b (SMRF)
UBC 2211.4 Table 8-1 (SMRF)

ANGLE b / t
≤ 52 / yF

(Braces in SCBF)
UBC 2210.10.c (SCBF)

UBC 2211.4.9.2.d (SCBF)

DOUBLE-ANGLE b / t
≤ 52 / yF

(Braces in SCBF)
UBC 2210.10.c (SCBF)

UBC 2211.4.9.2.d (SCBF)

PIPE D/t ≤ 1,300 / Fy
UBC 2210.10.c (Braces in SCBF)
UBC 2211.4.9.2.d (Braces in BF)

T-SHAPE bf / 2tf
d / tw

No special requirement
No special requirement

ROUND BAR  No special requirement
RECTANGULAR  No special requirement

GENERAL  No special requirement
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Technical Note 24
Calculation of Factored Forces and Moments

This Technical Note explains how the program calculates factored forces and
moments when the user selects the UBC97-LRFD code.

The factored member loads that are calculated for each load combination are
Pu, Mu33, Mu22, Vu2 and Vu3 corresponding to factored values of the axial load,
the major moment, the minor moment, the major direction shear force and
the minor direction shear force, respectively. These factored loads are calcu-
lated at each of the previously defined stations for each load combination.
They are calculated in the same way as described in the AISC-LRFD93 Steel
Frame Design Technical Note 48 Calculation of Factored Forces and Moments
without any exception (UBC 2204.1, 2205.2, 2205.3, 2206, 2210).

The bending moments are obtained along the principal directions. For I, Box,
Channel, T, Double-Angle, Pipe, Circular, and Rectangular sections, the prin-
cipal axes coincide with the geometric axes. For the Angle sections, the prin-
cipal axes are determined and all computations related to bending moment
are based on that. For general sections, it is assumed that all section proper-
ties are given in terms of the principal directions and consequently no effort is
made to determine the principal directions.

The shear forces for Single-Angle sections are obtained for directions along
the geometric axes. For all other sections, the shear stresses are calculated
along the geometric/principal axes.

For loading combinations that cause compression in the member, the factored
moment Mu (Mu33 and Mu22 in the corresponding directions) is magified to con-
sider second order effects. The magnified moment in a particular direction is
given by:

Mu = B1Mnt + B2Mlt (LRFD C1-1, SAM 6)

where

B1 = Moment magnification factor for non-sidesway moments,
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B2 = Moment magnification factor for sidesway moments,
Mnt = Factored moments not causing sidesway, and
Mlt = Factored moments causing sidesway.

B1 is calculated as shown in AISC-LRFD93 Steel Frame Design Technical Note
48 Calculation of Factored Forces and Moments.

Similar to AISC-LRFD93, the program design assumes the analysis includes P-
delta effects; therefore, B2 is taken as unity for bending in both directions. If
the program assumptions are not satisfactory for a particular structural model
or member, the user has a choice of explicitly specifying the values of B1 and
B2 for any member.

When using UBC97-LRFD code, the program design assumes that a P-delta
analysis has been performed so that moment magnification factors for mo-
ments causing sidesway can be taken as unity. It is recommended that the P-
delta analysis be performed at the factored load level of 1.2 DL plus 0.5 LL
(White and Hajjar 1991).

The same conditions and limitations as AISC-LRFD93 apply.

Reference
White, D.W. and J. F. Hajjar. 1991. Application of Second-Order Elastic Analy-

sis in LRFD:  Research to Practice. Engineering Journal. American In-
stitute of Steel Construction, Inc. Vol. 28, No. 4.
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Technical Note 25
Calculation of Nominal Strengths

The program calculates the nominal strengths in compression, tension, bend-
ing and shear for Seismic, Compact, Noncompact, and Slender sections in ac-
cordance with UBC97-LRFD the same way as described in the AISC-LRFD93
Steel Frame Design Technical Note 49 Calculation of Nominal Strengths  with-
out any exceptions (UBC 2204.1, 2205.2, 2205.3, 2206, 2210.2, 2210.3).
The nominal strengths for Seismic sections are calculated in the same way as
for Compact sections.

The nominal flexural strengths for all shapes of sections, including Single-
Angle sections are calculated based on their principal axes of bending. For the
I, Box, Channel, Circular, Pipe, T, Double-Angle, and Rectangular sections,
the principal axes coincide with their geometric axes. For the Angle sections,
the principal axes are determined and all computations related to flexural
strengths are based on that.

The nominal shear strengths are calculated along the geometric axes for all
sections. For I, Box, Channel, T, Double-Angle, Pipe, Circular, and Rectangu-
lar sections, the principal axes coincide with their geometric axes. For Single-
Angle sections, principal axes do not coincide with the geometric axes.

If the user specifies nonzero factored strengths for one or more elements in
the Capacity Overwrites (accessed using the Design menu > Steel Frame
Design > Review/Revise Overwrites command), the user-specified values
will override the calculated values described herein for those elements. The
specified factored strengths should be based on the principal axes of bending.

The strength reduction factor, ϕ, is taken as follows (LRFD A5.3):

ϕt = Resistance factor for tension, 0.9 (LRFD D1, H1, SAM 2, 6)

ϕc = Resistance factor for compression, 0.85 (LRFD E2, E3, H1)

ϕc = Resistance factor for compression in angles, 0.90 (LRFD SAM 4,6)
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ϕb = Resistance factor for bending, 0.9 (LRFD F1, H1, A-F1, A-G2, SAM 5)

ϕv = Resistance factor for shear, 0.9 (LRFD F2, A-F2, A-G3, SAM 3)

All limitations and warnings related to nominal strengths calculations in AISC-
LRFD93 Steel Frame Design Technical Note 49 Calculation of Nominal
Strengths also apply to this code.
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Technical Note 26
Calculation of Capacity Ratios

This Technical Note describes the calculation of capacity ratios when the user
selects the UBC97-LRFD code, including axial and bending stresses and shear
stresses.

Overview
The capacity ratios in UBC97-LRFD are calculated in the same way as de-
scribed in AISC-LRFD93 Steel Frame Design Technical Note 50 Calculation of
Capacity Ratios, with some modifications as described herein.

In the calculation of the axial force/biaxial moment capacity ratios, first, for
each station along the length of the member, the actual member
force/moment components are calculated for each load combination. Then the
corresponding capacities are calculated. Then the capacity ratios are calcu-
lated at each station for each member under the influence of each of the de-
sign load combinations. The controlling capacity ratio is then obtained, along
with the associated station and load combination. A capacity ratio greater
than 1.0 indicates exceeding a limit state.

During the design, the effect of the presence of bolts or welds is not
considered.

Axial and Bending Stresses

The interaction ratio is determined based on the ratio 
n

u

P
P

ϕ
. If Pu is tensile, Pn

is the nominal axial tensile strength and ϕ = ϕt = 0.9; and if Pu is compres-
sive, Pn is the nominal axial compressive strength and ϕ = ϕc = 0.85, except
for angle sections ϕ = ϕc = 0.9 (LRFD SAM 6). In addition, the resistance
factor for bending, ϕb = 0.9.

For 
n

u

P
P

ϕ
 ≥ 0.2, the capacity ratio is given as
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





ϕ

+
ϕ

+
ϕ 22
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33

33

9
8

nb

u

nb
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M
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M
M

P
P

. (LRFD H1-1a, SAM 6-1a)

For 
n

u

P
P

ϕ
 < 0.2, the capacity ratio is given as







ϕ

+
ϕ

+
ϕ 22

22

33

33

2 nb

u

nb

u

n

u

M
M

M
M

P
P

. (LRFD H1-1b, SAM 6-1a)

For circular sections, an SRSS (Square Root of Sum of Squares) combination
is first made of the two bending components before adding the axial load
component instead of the simple algebraic addition implied by the above for-
mulas.

For Single-Angle sections, the combined stress ratio is calculated based on
the properties about the principal axes (LRFD SAM 5.3.6). For I, Box, Chan-
nel, T, Double-Angle, Pipe, Circular, and Rectangular sections, the principal
axes coincides with their geometric axes. For Single-Angles sections, principal
axes are determined in the program. For general sections, it is assumed that
all section properties are given in terms of the principal directions; conse-
quently, no effort is made to determine the principal directions.

Shear Stresses
Similar to the normal stresses, from the factored shear force values and the
nominal shear strength values at each station for each of the load combina-
tions, shear capacity ratios for major and minor directions are calculated as
follows:

,
2

2

nv

u

V
V

ϕ
 and

,
3

3

nv

u

V
V

ϕ

where ϕv = 0.9.

For Single-angle sections, the shear stress ratio is calculated for directions
along the geometric axis. For all other sections, the shear stress is calculated
along the principal axes that coincides with the geometric axes.
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Technical Note 27
Seismic Requirements

This Technical Note explains the special seismic requirements checked by this
program for member design, which are dependent on the type of framing
used. Those requirements are described herein for each type of framing (UBC
2204.1, 2205.2, 2205.3).

The requirements checked are based on UBC Section 2211.4.2.1 for frames in
Seismic Zones 0 and 1 and Zone 2 with Importance factor equal to 1 (UBC
2210.2, UBC 2211.4.2.1), on UBC Section 2211.4.2.2 for frames in Seismic
Zone 2 with Importance factor greater than 1 (UBC 2210.2, UBC 2211.4.2.2),
and on UBC Section 2211.4.2.3 for frames in Seismic Zones 3 and 4 (UBC
2210.2, UBC 2211.4.2.3). No special requirement is checked for frames in
Seismic Zones 0 and 1 and in Seismic Zone 2 with Importance factor equal to
1 (UBC 2210.2, UBC 2211.4.2.1).

Ordinary Moment Frames
For this framing system, the following additional requirements are checked
and reported (UBC 2210.2, 2211.4.2.2.c, 211.4.2.3.c):

 In Seismic Zones 3 and 4 and in Seismic Zone 2 with Importance factor
greater than 1, whenever Pu/ϕPn > 0.5 in columns resulting from the pre-
scribed load combinations, the Special Seismic Load Combinations as de-
scribed below are checked (UBC 2210.2, 2211.4.2.2.b, 2211.4.2.3.b,
2210.5, 2211.4.6.1).

0.9DL ± Ωo EL (UBC 2210.3, 2211.4.3.1)
1.2DL + 0.5 LL ± Ωo EL (UBC 2210.3, 2211.4.3.1)

Special Moment Resisting Frames
For this framing system, the following additional requirements are checked or
reported (UBC 2210.2, 2211.4.2.2.d, 2211.4.2.3.d):
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 In Seismic Zones 3 and 4 and in Seismic Zone 2 with Importance factor
greater than 1, whenever Pu/ϕPn > 0.5 in columns resulting from the pre-
scribed load combinations, the Special Seismic Load Combinations as de-
scribed below are checked (UBC 2210.2, 2211.4.2.2.d, 2211.4.2.3.d,
2210.5, 2211.4.6.1).

0.9DL ± Ωo EL (UBC 2210.3, 2211.4.3.1)
1.2DL + 0.5LL ± Ωo EL (UBC 2210.3, 2211.4.3.1)

 In Seismic zones 3 and 4, the I-shaped beams or columns, Channel-
shaped beams or columns, and Box-shaped columns are also checked for
compactness criteria as described in Table 1 of UBC97-LFRD Steel Frame
Design Technical Note 23 Classification of Sections (UBC 2210.8,
2211.4.8.4.b, Table 2211.4.8-1). Compact I-shaped beam sections are

also checked for bf/2tf to be less than 52/ yF . Compact Channel-shaped

beam and column sections are also checked for bf/tf to be less than

52/ yF . Compact I-shaped and Channel-shaped column sections are also

checked for web slenderness h/tw to be less than the numbers given in
Table 1 of UBC97-LFRD Steel Frame Design Technical Note 23 Classifica-
tion of Sections. Compact box-shaped column sections are also checked

for b/tf and d/tw to be less than 110/ yF . If this criterion is satisfied, the

section is reported as SEISMIC as described in Technical Note UBC97-
LFRD Steel Frame Design Technical Note 23 Classification of Sections. If
this criterion is not satisfied, the user must modify the section property

 In Seismic Zones 3 and 4 and in Seismic Zone 2 with Importance factor
greater than 1, the program checks the laterally unsupported length of
beams to be less than (2,500/Fy)ry. If the check is not satisfied, it is noted
in the output (UBC 2211.4.8.8).

Braced Frames
For this framing system, the following additional requirements are checked or
reported (UBC 2210.2, 2211.4.2.2.e, 2211.4.2.3.e):

 In Seismic Zones 3 and 4 and in Seismic Zone 2 with Importance factor
greater than 1, whenever Pu/ϕPn > 0.5 in columns as a result of the pre-
scribed load combinations, the Special Seismic Load Combinations as de-
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scribed below are checked (UBC 2210.2, 2211.4.2.2.e, 2211.4.2.3.e,
2210.5, 2211.4.6.1).

0.9DL ± Ωo EL (UBC 2210.3, 2211.4.3.1)
1.2DL +0.5LL ± Ωo EL (UBC 2210.3, 2211.4.3.1)

 In Seismic Zones 3 and 4 and in Seismic Zone 2 with Importance factor
greater than 1, the maximum l/r ration of the braces is checked not to ex-

ceed 720/ yF . If this check is not met, it is noted in the output (UBC

2211.4.9.2.a).

 In Seismic Zones 3 and 4 and in Seismic Zone 2 with Importance factor
greater than 1, the compressive strength for braces is reduced as 0.8ϕcPn

(UBC 2211.4.9.2.b).

Pu ≤ 0.8ϕcPn (UBC 2211.4.9.2.b)

 In Seismic Zones 3 and 4 and in Seismic Zone 2 with Importance factor
greater than 1, all braces are checked to be either Compact or Noncom-
pact according to Table 2 of AISC-LRFD93 Steel Frame Design Technical
Note 47 Classification of Sections (UBC 2211.4.9.2.d). The Box and Pipe-
shaped braces are also checked for compactness criteria as described in
Table 1 of UBC97-LFRD Steel Frame Design Technical Note 23 Classifica-
tion of Sections (UBC 2211.4.9.2.d). For box sections, b/tf and d/tw are

limited to 110/ yF ; for pipe sections D/t is limited to 1,300/ yF . If these

criteria are satisfied, the section is reported as SEISMIC as described in
Technical Note UBC97-LFRD Steel Frame Design Technical Note 23 Classi-
fication of Sections. If these criteria are not satisfied, the user must mod-
ify the section property.

 In Seismic Zones 3 and 4 and in Seismic Zone 2 with Importance factor
greater than 1, Chevron braces are designed for 1.5 times the specified
load combinations (UBC 2211.4.9.4.a.1).

Eccentrically Braced Frames
For this framing system, the program looks for and recognizes the eccentri-
cally braced frame configuration shown in Figure 1. The following additional



Seismic Requirements Steel Frame Design UBC97-LRFD

Technical Note 27 - 4

requirements are checked or reported for the beams, columns and braces as-
sociated with these configurations (UBC 2210.2, 2211.4.2.2.e, 2211.4.2.3.e).

 In Seismic Zone 3 and 
greater than 1, wheneve

e

Figure 1 Eccentrically Bra
Seismic Requirements

4 and in Seismic Zone 2 with Importance factor
r Pu/ϕPn > 0.5 in columns as a result of the pre-

a)

L

e

L

b)

L

c)
e
2

e
2

ced Frame Configurations
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scribed load combinations, the Special Seismic Load Combinations as de-
scribed below are checked (UBC 2210.2, 2211.4.2.2.b, 2211.4.2.3.b,
2210.5, 2211.4.6.1).

0.9DL ± Ωo EL (UBC 2210.3, 2211.4.3.1)
1.2DL +0.5LL ± Ωo EL (UBC 2210.3, 2211.4.3.1)

 In Seismic Zones 3 and 4 and in Seismic Zone 2 with Importance factor
greater than 1, the I-shaped and Channel-shaped beams are also checked
for compactness criteria as described in Table 1 of UBC97-LFRD Steel
Frame Design Technical Note 23 Classification of Sections (UBC
2211.4.10.2.a, 2210.8, 2211.4.8.4.b, Table 2211.4.8-1). Compact I-
shaped and Channel-shaped beam sections are also checked for bf/2tf to

be less than 52 / yF . If this criterion is satisfied, the section is reported

as SEISMIC as described in UBC97-LFRD Steel Frame Design Technical
Note 23 Classification of Sections. If this criterion is not satisfied, the user
must modify the section property.

 In Seismic Zones 3 and 4 and in Seismic Zone 2 with Importance factor
greater than 1, the link beam yield strength, Fy, is checked not to exceed
the following (UBC 2211.4.10.2.b):

Fy ≤ 50 ksi (UBC 2211.4.10.2.b)

If the check is not satisfied, it is noted in the output.

 In Seismic Zones 3 and 4 and in Seismic Zone 2 with Importance factor
greater than 1, the shear strength for link beams is taken as follows (UBC
2210.10.b, 2211.4.12.2.d):

Vu ≤ ϕvVn, (UBC 2211.4.10.2.d)

where

ϕVn = min (ϕVpa, ϕ 2Mpa/e) (UBC 2211.4.10.2.d)

Vpa = Vp

2

1 
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P , (UBC 2211.4.10.2.f)
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Mpa = 1.18 Mp 
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1 , (UBC 2211.4.10.2.f)

Vp = 0.6Fy(d - 2tf)tw (UBC 2211.4.10.2.d)

Mp = ZFy (UBC 2211.4.10.2.d)

ϕ = ϕv (default is 0.9) (UBC 2211.4.10.2.d, 2211.4.10.2.f)

Py = AgFy (UBC 2211.4.10.2.e)

 In Seismic Zones 3 and 4 and in Seismic Zone 2 with Importance factor
greater than 1, if Pu > 0.15 AgFy, the link beam length, e, is checked not
to exceed the following (UBC 2211.4.10.2.f):
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(UBC 2211.4.10.2.f)

where,

Aw = (d ― 2tf)tw, and (UBC 2211.4.10.2.f)

ρ = Pu/Vu (UBC 2211.4.10.2.f)

If the check is not satisfied, it is noted in the output.

 The link beam rotation, θ, of the individual bay relative to the rest of the
beam is calculated as the story drift deltam times bay length divided by
the total lengths of link beams in the bay. In Seismic Zones 3 and 4 and in
Seismic Zone 2 with Importance factor greater than 1, the link beam ro-
tation, θ, is checked as follows (UBC 2211.4.10.2.g):

θ ≤ 0.090, where link beam clear length, e ≤ 1.6 Ms/Vs

θ ≤ 0.030, where link beam clear length, e ≥ 2.6 Ms/Vs and

θ ≤ value interpolated between 0.090 and 0.030 as the link beam clear
length varies from 1.6 Ms/Vs to 2.6 Ms/Vs.
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 In Seismic Zones 3 and 4 and in Seismic Zone 2 with Importance factor
greater than 1, the brace strength is checked to be at least 1.25 times the
axial force corresponding to the controlling link beam strength (UBC
2211.4.10.6.a). The controlling link beam nominal strength is taken as
follows:

min (Vpa, 2Mpa/e) (UBC 2211.4.10.2.d)

The values of Vpa and Mpa are calculated following the procedures de-
scribed above. The correspondence between brace force and link beam
force is obtained from the associated load cases, whichever has the high-
est link beam force of interest.

 In Seismic Zones 3 and 4 and in Seismic Zone 2 with Importance factor
greater than 1, the column strength is checked for 1.25 times the column
forces corresponding to the controlling link beam nominal strength (UBC
2211.4.10.8). The controlling link beam strength and the corresponding
forces are as obtained by the process described above.

 Axial forces in the beams are included in checking the beams. The user is
reminded that using a rigid diaphragm model will result in zero axial
forces in the beams. The user must disconnect some of the column lines
from the diaphragm to allow beams to carry axial loads. It is recom-
mended that only one column line per eccentrically braced frame be con-
nected to the rigid diaphragm or that a flexible diaphragm model be used.

 In Seismic Zones 3 and 4 and in Seismic Zone 2 with Importance factor
greater than 1, the beam laterally unsupported length is checked to be

less than 76 bf/ yF . If not satisfied, it is so noted as a warning in the

output file (UBC 2210.11, 2211.4.10.5).

Note: The program does NOT check that the strength in flexure of the beam
outside the link is at least 1.25 times the moment corresponding to the con-
trolling link beam strength (UBC 2211.4.10.6.b). Users need to check for this
requirement.

Special Concentrically Braced Frames
For this framing system, the following additional requirements are checked or
reported (UBC 2210.2, 2211.4.2.2.e, 2211.4.2.3.e):
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 In Seismic Zones 3 and 4 and in Seismic Zone 2 with Importance factor
greater than 1, whenever Pu/ϕPn > 0.5 in columns as a result of the pre-
scribed load combinations, the Special Seismic Load Combinations as de-
scribed below are checked (UBC 2210.2, 2211.4.2.2.e, 2211.4.2.3.e,
2210.5, 2211.4.6.1):

0.9 DL ± Ω0EL (UBC 2210.2, 2211.4.3.1)
1.2 DL + 0.5 LL ± Ω0EL (UBC 2210.3, 2211.4.3.1)

 In Seismic Zones 3 and 4 and in Seismic Zone 2 with Importance factor
greater than 1, all columns are checked to be Compact in accordance with
Table 2 in AISC-LRFD93 Steel Frame Design Technical Note 47 Classifica-
tion of Section. Compact box-shaped column sections are also checked for

b/tf and d/tw to be less than 100/ yF  as described in Table 1 in UBC97-

LFRD Steel Frame Design Technical Note 23 Classification of Sections
(UBC 2211.4.12.5.a). If this criterion is satisfied, the section is reported
as SEISMIC as described in UBC97-LFRD Steel Frame Design Technical
Note 23 Classification of Sections. If this criterion is not satisfied, the user
must modify the section property (UBC 2210.10.g, 2211.4.12.5.a).

 In Seismic Zones 3 and 4 and in Seismic Zone 2 with Importance factor
greater than 1, all braces are checked to be Compact in accordance with
Table 2 in AISC-LRFD93 Steel Frame Design Technical Note 47 Classifica-
tion of Section (UBC 2210.10.c, 2211.4.12.2.d). The Angle-, Double-
Angle,  Box- and Pipe-shaped braces are also checked for compactness
criteria as described in Table 1 in UBC97-LFRD Steel Frame Design Tech-
nical Note 23 Classification of Sections (UBC 2210.10.c, 2211.4.12.2.d).

For box sections b/tf and d/tw are limited to 100/ yF ; for pipe sections,

D/t is limited to 1,300/Fy. If these criteria are satisfied, the section is re-
ported as SEISMIC as described in UBC97-LFRD Steel Frame Design Tech-
nical Note 23 Classification of Sections. If these criteria are not satisfied,
the user must modify the section property.

 In Seismic Zones 3 and 4 and in Seismic Zone 2 with Importance factor
greater than 1, the compressive strength for braces is taken as ϕcPn (UBC
2210.10.b, 1122.4.12.2.b). Unlike Braced Frames, no reduction is re-
quired.

Pu ≤ ϕcPn (UBC 2211.4.12.2.b)
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 In Seismic Zones 3 and 4 and in Seismic Zone 2 with Importance factor
greater than 1, the maximum l/r ratio of the braces is checked not to ex-

ceed 1,000/ yF . If this check is not met, it is noted in the output (UBC

2210.10.a, 2211.4.12.2.a).

Note: Beams intersected by Chevron braces are NOT currently checked to
have a strength to support loads represented by the following combina-
tions (UBC 2213.9.4.1):

1.0DL + 0.7LL ± Pb (UBC 2210.10.e, 2211.4.12.4.a.3)
0.9DL ± Pb (UBC 2210.10.e, 2211.4.12.4.a.3)

where Pb is given by the difference of FyA for the tension brace and 0.3ϕcPn

for the compression brace. Users need to check for this requirement.
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When using UBC97-LRFD design code, the structural joints are checked or de-
signed for the following:

 Check for the requirement of continuity plate and determination of its area
(see UBC97-LRFD Steel Frame Design Technical Note 29 Continuity Plates)

 Check for the requirement of doubler plate and determination of its thick-
ness (see UBC97-LRFD Steel Frame Design Technical Note 30 Doubler
Plates)

 Check for the ratio of beam flexural strength to column flexural strength

 Reporting the beam connection shear

 Reporting the brace connection force

Weak-Beam / Strong-Column Measure
In Seismic Zones 3 and 4, for Special Moment-Resisting Frames, the code re-
quires that the sum of beam flexure strengths at a joint should be less than
the sum of column flexure strengths (UBC 2211.4.8.6). The column flexure
strength should reflect the presence of the axial force present in the column.
To facilitate the review of the strong-column/weak-beam criterion, the pro-
gram reports a beam/column plastic moment capacity ratio for every joint in
the structure.

For the major direction of any column (top end), the beam-to-column
strength ratio is obtained as:

Rmaj =
pcbxpcax

n

n
npbn

MM

M
b

+

θ∑
=1

cos

(UBC 2211.4.8.6 8-3)
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For the minor direction of any column, the beam-to-column-strength ratio is
obtained as:

Rmin =
pcbypcay

n

n
npbn

MM

M
b

+

θ∑
=1

cos

(UBC 2211.4.8.6 8-3)

where,

Rmaj,min = Plastic moment capacity ratios, in the major and minor
directions of the column, respectively

Mpbn = Plastic moment capacity of n-th beam connecting to col-
umn

θn = Angle between the n-th beam and the column major di-
rection

Mpcax,y = Major and minor plastic moment capacities, reduced for
axial force effects, of column above story level

Mpcbx,y = Major and minor plastic moment capacities, reduced for
axial force effects, of column below story level

nb = Number of beams connecting to the column

The plastic moment capacities of the columns are reduced for axial force ef-
fects and are taken as:

Mpc = Zc (Fyc - gcuc AP / ), (UBC 2211.4.8.6 8-3)

where,

Zc = Plastic modulus of column

Fyc = Yield stress of column material

Puc = Maximum axial strength in column in compression, Puc ≥
0, and

Agc = Gross area of column
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For the above calculations, the section of the column above is taken to be the
same as the section of the column below, assuming that the column splice will
be located some distance above the story level.

Evaluation of Beam Connection Shears
For each steel beam in the structure, the program will report the maximum
major shears at each end of the beam for the design of the beam shear con-
nections. The beam connection shears reported are the maxima of the fac-
tored shears obtained from the load combinations.

For special seismic design, the beam connection shears are not taken less
than the following special values for different types of framing. The require-
ments checked are based on UBC Section 2211.4.2.1 for frames in Seismic
Zones 0 and 1 and Zone 2 with Importance factor equal to 1 (UBC 2210.2,
UBC 2211.4.2.1), on UBC Section 2211.4.2.2 for frames in Seismic Zone 2
with Importance factor greater than 1 (UBC 2210.2, UBC 2211.4.2.2), and on
UBC Section 2211.4.2.3 for frames in Seismic Zones 3 and 4 (UBC 2210.2,
UBC 2211.4.2.3). No special requirement is checked for frames in Seismic
Zones 0 and 1 and in Seismic Zone 2 with Importance factor equal to 1 (UBC
2210.2, UBC 2211.4.2.1).

 In Seismic Zones 3 and 4 and in Seismic Zone 2 with Importance factor
greater than 1, for Ordinary Moment Frames, the beam connection shears
reported are the maximum of the specified load combinations and the fol-
lowing additional load combinations (UBC 2211.4.7.2.a, 2211.4.8.2.b):

0.9DL ± Ω0 EL (UBC 2210.3, 2211.4.3.1)
1.2DL + 0.5LL ± Ω0 EL (UBC 2210.3, 2211.4.3.1)

 In Seismic Zones 3 and 4 and in Seismic Zone 2 with Importance factor
greater than 1, for Special Moment-Resisting Frames, the beam connec-
tion shears that are reported allow for the development of the full plastic
moment capacity of the beam. Thus:

Vu = 
L

CMpb  +1.2VDL + 0.5VLL (UBC 2211.4.8.2.b)

where
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V = Shear force corresponding to END I and END J of beam,

C = 0 if beam ends are pinned, or for cantilever beam,

= 1 if one end of the beam is pinned

= 2 if no ends of the beam are pinned,

Mpb = Plastic moment capacity of the beam, ZFy

L = Clear length of the beam,

VDL = Absolute maximum of the calculated factored beam
shears at the corresponding beam ends from the dead
load only, and

VLL = Absolute maximum of the calculated factored beam
shears at the corresponding beam ends from the live
load only.

 In Seismic Zones 3 and 4 and in Seismic Zone 2 with Importance factor
greater than 1, for Eccentrically Braced Frames, the link beam connection
shear is reported as equal to the link beam web shear capacity (UBC
2211.4.10.7).

Evaluation of Brace Connection Forces
For each steel brace in the structure, the program reports the maximum axial
force at each end of the brace for the design of the brace-to-beam connec-
tions. The brace connection forces reported are the maxima of the factored
brace axial forces obtained from the load combinations.

For special seismic design, the brace connection forces are not taken less
than the following special values for different types of framing. The require-
ments checked are based on UBC Section 2211.4.2.1 for frames in Seismic
Zones 0 and 1 and Zone 2 with Importance factor equal to 1 (UBC 2210.2,
UBC 2211.4.2.1), on UBC Section 2211.4.2.2 for frames in Seismic Zone 2
with Importance factor greater than 1 (UBC 2210.2, UBC 2211.4.2.2), and on
UBC 2211.4.2.3 for frames in Seismic Zones 3 and 4 (UBC 2210.2, UBC
2211.4.2.3). No special requirement is checked for frames in Seismic Zones 0
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and 1 and in Seismic Zone 2 with Importance factor equal to 1 (UBC 2210.2,
UBC 2211.4.2.1).

 In Seismic Zones 3 and 4 and in Seismic Zone 2 with Importance factor
greater than 1, for ordinary Braced Frames, the bracing connection force
is reported at least as the smaller of the tensile strength of the brace (FyA)
(UBC 2211.4.9.3.a.1) and the following special load combinations (UBC
2211.4.9.3.a.2):

0.9 DL ± Ω0 EL (UBC 2210.3, 2211.4.3.1)
1.2 DL + 0.5 LL ± Ω0 EL (UBC 2210.3, 2211.4.3.1)

 In Seismic Zones 3 and 4 and in Seismic Zone 2 with Importance factor
greater than 1, for Eccentrically Braced Frames, the bracing connection
force is reported as at least the nominal strength of the brace (UBC
221.4.10.6.d).

 In Seismic Zones 3 and 4 and in Seismic Zone 2 with Importance factor
greater than 1, for Special Concentrically Braced Frames, the bracing con-
nection force is reported at least as the smaller of the tensile strength of
the brace (FyA) (UBC 2210.10, 2211.4.12.3.a.1) and the following special
load combinations (UBC 2211.10, 2211.4.12.3.a.2):

0.9 DL ± Ω0 EL (UBC 2210.3, 2211.4.3.1)
1.2 DL + 0.5 LL ± Ω0 EL (UBC 2210.3, 2211.4.3.1)
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In a plan view of a beam/column connection, a steel beam can frame into a
column in the following ways:

1. The steel beam frames in a direction parallel to the column major direc-
tion, i.e., the beam frames into the column flange.

2. The steel beam frames in a direction parallel to the column minor direc-
tion, i.e., the beam frames into the column web.

3. The steel beam frames in a direction that is at an angle to both the princi-
pal axes of the column, i.e., the beam frames partially into the column
web and partially into the column flange.

To achieve a beam/column moment connection, continuity plates such as
shown in Figure 1 are usually placed on the column in line with the top and
bottom flanges of the beam to transfer the compression and tension flange
forces from the beam into the column.

For connection conditions described in items 2 and 3 above, the thickness of
such plates is usually set equal to the flange thickness of the corresponding
beam. However, for the connection condition described by item 1 above,
where the beam frames into the flange of the column, such continuity plates
are not always needed. The requirement depends on the magnitude of the
beam-flange force and the properties of the column. This is the condition that
the program investigates. Columns of I-sections only are investigated. The
program evaluates the continuity plate requirements for each of the beams
that frame into the column flange (i.e., parallel to the column major direction)
and reports the maximum continuity plate area that is needed for each beam
flange. The continuity plate requirements are evaluated for moment frames
only. No check is made for braced frames.
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Figure 1 Elevation and Plan of Doubler Plates for a Column of I-Section
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The program first evaluates the need for continuity plates. Continuity plates
will be required if any of the following four conditions are not satisfied:

 The column flange design strength in bending must be larger than the
beam flange force, i.e.,

ϕRn = (0.9)6.25 2
fct  Fyc ≥ Pbf (LRFD K1-1)

 The design strength of the column web against local yielding at the toe of
the fillet must be larger than the beam flange force, i.e.,

ϕRn = (1.0)(5.0 kc + tfb) Fyctwc ≥ Pbf (LRFD K1-2)

 The design strength of the column web against crippling must be larger
than the beam flange force, i.e.,

ϕRn = (0.75) 68 2
wct  bf

wc

fc
yc
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c
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31 (LRFD K1-5a)

 The design compressive strength of the column web against buckling must
be larger than the beam flange force, i.e.,

ϕRn = (0.9) ≥
c

ycwc

d

Ft 3100,4
 Pbf (LRFD K1-8)

If any of the conditions above are not met, the program calculates the re-
quired continuity plate area as:

Acp = 
)9.0)(85.0( yc

bf

F
P

 - 12 2
wct (LRFD K1.9,E2)

If Acp ≤ 0, no continuity plates are required.

The formula above assumes the continuity plate plus a width of web equal to
12twc act as a compression member to resist the applied load (LRFD K1.9).
The formula also assumes ϕ = 0.85 and Fcr = 0.9Fyc. This corresponds to an
assumption of λ = 0.5 in the column formulas (LRFD E2-2). The user should
choose the continuity plate cross-section such that this is satisfied. As an ex-
ample, when using Fyc = 50 ksi and assuming the effective length of the stiff-
ener as a column to be 0.75h (LRFD K1.9), the required minimum radius gy-
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ration of the stiffener cross-section would be r = 0.02h to obtain λ = 0.5
(LRFD E2-4).

If continuity plates are required, they must satisfy a minimum area specifica-
tion defined as follows:

 The minimum thickness of the stiffeners is taken in the program as fol-
lows:

min
cpt  = max 













fb
y

fb b
F

t
95

,5.0 (LRFD K1.9.2)

 The minimum width of the continuity plate on each side plus 1/2 the
thickness of the column web shall not be less than 1/3 of the beam flange
width, or:

min
cpb  = 2 










−

23
wcfp tb

(LRFD K1.9.1)

 So that the minimum area is given by:

min
cpA  = 2

cpt min
cpb (LRFD K1.9.1)

Therefore, the continuity plate area provided by the program is either zero or
the greater of Acp and min

cpA .

In the equations above,

Acp = Required continuity plate area

Fyc = Yield stress of the column and continuity plate material

db = Beam depth

dc = Column depth

h = Clear distance between flanges of column less fillets for rolled
shapes
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kc = Distance between outer face of the column flange and web toe of
its fillet

Mu = Factored beam moment

Pbf = Beam flange force, assumed as Mu / (db - tfb)

Rn = Nominal strength

tfb = Beam flange thickness

tfc = column flange thickness

twc = Column web thickness

ϕ = Resistance factor

The program also checks special seismic requirements depending on the type
of frame as described below. The requirements checked are based on UBC
Section 2211.4.2.1 for frames in Seismic Zones 0 and 1 and Zone 2 with Im-
portance factor equal to 1 (UBC 2210.2, UBC 2211.4.2.1), on UBC Section
2211.4.2.2 for frames in Seismic Zone 2 with Importance factor greater than
1 (UBC 2210.2, UBC 2211.4.2.2), and on UBC Section 2211.4.2.3 for frames
in Seismic Zones 3 and 4 (UBC 2210.2, UBC 2211.4.2.3). No special require-
ment is checked for frames in Seismic Zones 0 and 1 and in Seismic Zone 2
with Importance factor equal to 1 (UBC 2210.2, UBC 2211.4.2.1).

 In Seismic Zones 3 and 4 and Seismic Zone 2 with Importance factor
greater than 1 for Ordinary Moment Frames the continuity plates are
checked and designed for a beam flange force, Pbf = Mpb/(db-tfb) (UBC
2211.4.7.2.a, 2211.4.8.2.a.1).

 In Seismic Zones 3 and 4 for Special Moment-Resisting Frames, for de-
termining the need for continuity plates at joints as a result of tension
transfer from the beam flanges, the force Pbf is taken as fybAbf for all four
checks described above (LRFD K1-1, K1-2, K1-5a, K1-8), except for
checking column flange design strength in bending Pbf is taken as 1.8 fybAbf

(UBC 2211.4.8.5, LRFD K1-1). In Seismic Zone 2 with Importance factor
greater than 1, for Special Moment-Resisting Frames, for determining the
need for continuity plates at joints as a result of tension transfer from the
beam flanges, the force Pbf is taken as fybAbf (UBC 2211.4.8.2.a.1)
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Pbf = 1.8fybAbf  (Zones 3 and 4) (UBC 2211.4.8.5)

Pbf = fybAbf  (Zone 2 with I>1) (UBC 2211.4.8.2.a.1)

For design of the continuity plate, the beam flange force is taken as Pbf =
Mpb/(db-tfb) (UBC 211.4.8.2.a.1).

 In Seismic Zones 3 and 4 and in Seismic Zone 2 with Importance factor
greater than 1, for Eccentrically Braced Frames, the continuity plate re-
quirements are checked and designed for beam flange force of Pbf = fybAbg.
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One aspect of the design of a steel framing system is an evaluation of the
shear forces that exist in the region of the beam column intersection known
as the panel zone.

Shear stresses seldom control the design of a beam or column member. How-
ever, in a Moment-Resisting frame, the shear stress in the beam-column joint
can be critical, especially in framing systems when the column is subjected to
major direction bending and the joint shear forces are resisted by the web of
the column. In minor direction bending, the joint shear is carried by the col-
umn flanges, in which case the shear stresses are seldom critical, and this
condition is therefore not investigated by the program.

Shear stresses in the panel zone caused by major direction bending in the
column may require additional plates to be welded onto the column web, de-
pending on the loading and the geometry of the steel beams that frame into
the column, either along the column major direction or at an angle so that the
beams have components along the column major direction. See Figure 1. The
program investigates such situations and reports the thickness of any re-
quired doubler plates. Only columns with I-shapes are investigated for dou-
bler plate requirements. Also, doubler plate requirements are evaluated for
moment frames only. No check is made for braced frames.

The program calculates the required thickness of doubler plates using the
following algorithms. The shear force in the panel zone is given by:

Vp =  ∑
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Figure 1 Elevation and Plan of Doubler Plates for a Column of I-Section
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The nominal panel shear strength is given by

Rv = 0.6Fydctr, for Pu ≤ 0.4Py or if Pu is tensile, and (LRFD K1-9)

Rv = 0.6Fydctr, 











−

y

u

P
P

4.1 for Pu > 0.4Py  (LRFD K1-10)

By using Vp = ϕRv, with ϕ = 0.9, the required column web thickness, tr, can
be found.

The extra thickness, or thickness of the doubler plate is given by

tdp = tr - tw ≥ 
yF

h

/418
(LFRD F2-1)

where,

Fy = Column and doubler plate yield stress

tr = Required column web thickness

tdp = Required doubler plate thickness

tw = Column web thickness

h = dc-2tfc if welded, dc - 2kc if rolled

Vp = Panel zone shear

Vc =  Column shear in column above

Fy = Beam flange forces

nb = Number of beams connecting to column

dn = Depth of n-th beam connecting to column

θn = Angle between n-th beam and column major direction

dc = Depth of column clear of fillets, equals d - 2k

Mbn = Calculated factored beam moment from the corresponding
load combination
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Rv = Nominal shear strength of panel

Pu = Column factored axial load

Py = Column axial yield strength, FyA

The program reports the largest calculated value of tdb for any of the load
combinations based on the factored beam moments and factored column axial
loads.

The special seismic requirements checked by the program for calculating dou-
bler plate areas depend on the type of framing used; the requirements
checked are described herein for each type of framing. The requirements
checked are based on UBC Section 2211.4.2.1 for frames in Seismic Zones 0
and 1 and Zone 2 with Importance factor equal to 1 (UBC 2210.2, UBC
2211.4.2.1), on UBC Section 2211.4.2.2 for frames in Seismic Zone 2 with
Importance factor greater than 1 (UBC 2210.2, UBC 2211.4.2.2) and on UBC
Section 2211.4.2.3 for frames in Seismic Zones 3 and 4 (UBC 2210.2, UBC
2211.4.2.3). No special requirement is checked for frames in Seismic Zones 0
and 1 and in Seismic Zone 2 with Importance factor equal to 1 (UBC 2210.2,
UBC 2211.4.2.1).

 In Seismic Zones 3 and 4, for Special Moment-Resisting Frames, the panel
zone doubler plate requirements that are reported will develop the lesser
of beam moments equal to 0.9 of the plastic moment capacity of the
beam (0.9∑ϕbMpb), or beam moments resulting from specified load combi-
nations involving seismic load (UBC 2211.4.8.3.a).

The capacity of the panel zone in resisting this shear is taken as (UBC
2211.8.3.a):

ϕvVn = 0.6ϕvFydctp 
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giving the required panel zone thickness as
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(UBC 2211.4.8.3, LRFD F2-1)

and the required doubler plate thickness as
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tdp = tp - twc

where,

ϕv = 0.75,

bcf = width of column flange

tcf = thickness of column flange

tp = required column web thickness

h = dc - 2tfc if welded, dc - 2kc if rolled, and

db = depth of deepest beam framing into the major direction of
the column.

 In Seismic Zones 3 and 4, for Special Moment-Resisting Frames, the pro-
gram checks the following panel zone column web thickness requirement:

twc ≥ 
90

)2()2( fbbfcc tdtd −+−
(UBC 2211.4.8.3.b)

If the check is not satisfied, it is noted in the output.

 In Seismic Zones 3 and 4, for Eccentrically Braced Frames, the doubler
plate requirements are checked similar to doubler plate checks for  Special
Moment-Resisting Frames, as described above (UBC 2211.4.10.7).
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This Technical Note describes the steel frame design input data for UBC97-
LRFD. The input can be printed to a printer or to a text file when you click the
File menu > Print Tables > Steel Frame Design command. A printout of
the input data provides the user with the opportunity to carefully review the
parameters that have been input into the program and upon which program
design is based. Further information about using the Print Design Tables Form
is provided at the end of this Technical Note.

Input Data
The program provides the printout of the input data in a series of tables. The
column headings for input data and a description of what is included in the
columns of the tables are provided in Table 1 of this Technical Note.

Table 1  Steel Frame Design Input Data
COLUMN HEADING DESCRIPTION
Material Property Data
Material Name Steel, concrete or other.

Material Type Isotropic or orthotropic.

Design Type Concrete, steel or none. Postprocessor available if steel is
specified.

Material Dir/Plane "All" for isotropic materials; specify axis properties define for
orthotropic.

Modulus of Elasticity

Poisson's Ratio

Thermal Coeff

Shear Modulus

Material Property Mass and Weight
Material Name Steel, concrete or other.
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Table 1  Steel Frame Design Input Data
COLUMN HEADING DESCRIPTION

Mass Per Unit Vol Used to calculate self mass of the structure.

Weight Per Unit Vol Used to calculate the self weight of the structure.

Material Design Data for Steel Materials
Material Name Steel.

Steel FY Minimum yield stress of steel.

Steel FU Maximum tensile stress of steel.

Steel Cost ($) Cost per unit weight used in composite beam design if optimum
beam size specified to be determined by cost.

Material Design Data for Concrete Materials
Material Name Concrete.

Lightweight Concrete Check this box if this is a lightweight concrete material.

Concrete FC Concrete compressive strength.

Rebar FY Bending reinforcing yield stress.

Rebar FYS Shear reinforcing yield stress.

Lightwt Reduc Fact Define reduction factor if lightweight concrete box checked.
Usually between 0.75 ad 0.85.

Frame Section Property Data
Frame Section Name User specified or auto selected member name.

Material Name Steel, concrete or none.

Section Shape Name
or Name in Section
Database File

Name of section as defined in database files.

Section Depth Depth of the section.

Flange Width Top Width of top flange per AISC database.

Flange Thick Top Thickness of top flange per AISC database.

Web Thick Web thickness per AISC database.

Flange Width Bot Width of bottom flange per AISC database.

Flange Thick Bot Thickness of bottom flange per AISC database.

Section Area
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Table 1  Steel Frame Design Input Data
COLUMN HEADING DESCRIPTION

Torsional Constant

Moments of Inertia I33, I22

Shear Areas A2, A3

Section Moduli S33, S22

Plastic Moduli Z33, Z22

Radius of Gyration R33, R22

Load Combination Multipliers
Combo Load combination name.

Type Additive, envelope, absolute, or SRSS as defined in Define >
Load Combination.

Case Name(s) of case(s) to be included in this load combination.

Case Type Static, response spectrum, time history, static nonlinear, se-
quential construction.

Factor Scale factor to be applied to each load case.

Beam Steel Stress Check Element Information
Story Level Name of the story level.

Beam Bay Beam bay identifier.

Section ID Name of member section assigned.

Framing Type Ordinary MRF, Special MRF, Braced Frame, Special CBF, ERF

RLLF Factor Live load reduction factor.

L_Ratio Major Ratio of unbraced length divided by the total member length.

L_Ratio Minor Ratio of unbraced length divided by the total member length.

K Major Effective length factor.

K Minor Effective length factor.

Beam Steel Moment Magnification Overwrites

Story Level Name of the story level.

Beam Bay Beam bay identifier.

CM Major As defined in AISC-LRFD specification Chapter C.
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Table 1  Steel Frame Design Input Data
COLUMN HEADING DESCRIPTION

CM Minor As defined in AISC-LRFD specification Chapter C.

Cb Factor As defined in AISC-LRFD specification Chapter F.

B1 Major As defined in AISC-LRFD specification Chapter C.

B1 Minor As defined in AISC-LRFD specification Chapter C.

B2 Major As defined in AISC-LRFD specification Chapter C.

B2 Minor As defined in AISC-LRFD specification Chapter C.

Beam Steel Allowables & Capacities Overwrites

Story Level Name of the story level.

Beam Bay Beam bay identifier

phi*Pnc If zero, as defined for Material Property Data used and per
AISC-LRFD specification Chapter E.

phi*Pnt If zero, as defined for Material Property Data used and per
AISC-LRFD specification Chapter D.

phi*Mn Major If zero, as defined for Material Property Data used and per
AISC-LRFD specification Chapter F and G.

phi*Mn Minor If zero, as defined for Material Property Data used and per
AISC-LRFD specification Chapter F and G.

phi*Vn Major If zero, as defined for Material Property Data used and per
AISC-LRFD specification Chapter F.

phi*Vn Minor If zero, as defined for Material Property Data used and per
AISC-LRFD specification Chapter F.

Column Steel Stress Check Element Information

Story Level Name of the story level.

Column Line Column line identifier.

Section ID Name of member section assigned.

Framing Type Ordinary MRF, Special MRF, Braced Frame, Special CBF, ERF

RLLF Factor Live load reduction factor.

L_Ratio Major Ratio of unbraced length divided by the total member length.

L_Ration Minor Ratio of unbraced length divided by the total member length.
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Table 1  Steel Frame Design Input Data
COLUMN HEADING DESCRIPTION

K Major Effective length factor.

K Minor Effective length factor.

Column Steel Moment Magnification Overwrites

Story Level Name of the story level.

Column Line Column line identifier.

CM Major As defined in AISC-LRFD specification Chapter C.

CM Minor As defined in AISC-LRFD specification Chapter C.

Cb Factor As defined in AISC-LRFD specification Chapter F.

B1 Major As defined in AISC-LRFD specification Chapter C.

B1 Minor As defined in AISC-LRFD specification Chapter C.

B2 Major As defined in AISC-LRFD specification Chapter C.

B2 Minor As defined in AISC-LRFD specification Chapter C.

Column Steel Allowables & Capacities Overwrites

Story Level Name of the story level.

Column Line Column line identifier.

phi*Pnc If zero, as defined for Material Property Data used and per
AISC-LRFD specification Chapter E.

phi*Pnt If zero, as defined for Material Property Data used and per
AISC-LRFD specification Chapter D.

phi*Mn Major If zero, as defined for Material Property Data used and per
AISC-LRFD specification Chapter F and G.

phi*Mn Minor If zero, as defined for Material Property Data used and per
AISC-LRFD specification Chapter F and G.

phi*Vn Major If zero, as defined for Material Property Data used and per
AISC-LRFD specification Chapter F.

phi*Vn Minor If zero, as defined for Material Property Data used and per
AISC-LRFD specification Chapter F.
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Using the Print Design Tables Form
To print steel frame design input data directly to a printer, use the File menu
> Print Tables > Steel Frame Design command and click the Input Sum-
mary check box on the Print Design Tables form. Click the OK button to send
the print to your printer. Click the Cancel button rather than the OK button
to cancel the print. Use the File menu > Print Setup command and the
Setup>> button to change printers, if necessary.

To print steel frame design input data to a file, click the Print to File check box
on the Print Design Tables form. Click the Filename button to change the
path or filename. Use the appropriate file extension for the desired format
(e.g., .txt, .xls, .doc). Click the Save buttons on the Open File for Printing
Tables form and the Print Design Tables form to complete the request.

Note:

The File menu > Display Input/Output Text Files command is useful for displaying out-
put that is printed to a text file.

The Append check box allows you to add data to an existing file. The path and
filename of the current file is displayed in the box near the bottom of the Print
Design Tables form. Data will be added to this file. Or use the Filename
button to locate another file, and when the Open File for Printing Tables cau-
tion box appears, click Yes to replace the existing file.

If you select a specific frame element(s) before using the File menu > Print
Tables > Steel Frame Design command, the Selection Only check box will
be checked. The print will be for the selected beam(s) only.
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Technical Note 32
Output Details

This Technical Note describes the steel frame design output for UBC97-LRFD
that can be printed to a printer or to a text file. The design output is printed
when you click the File menu > Print Tables > Steel Frame Design com-
mand and select Output Summary on the Print Design Tables form. Further
information about using the Print Design Tables form is provided at the end of
this Technical Note.

The program provides the output data in a series of tables. The column
headings for output data and a description of what is included in the columns
of the tables are provided in Table 1 of this Technical Note.

Table 1 Steel Frame Output Data
COLUMN HEADING DESCRIPTION

Beam Steel Stress Check

Story Level Name of the story level.

Beam Bay Beam bay identifier.

Section ID Name of member sections assigned.

Moment Interaction Check

Combo Name of load combination that produces the maximum
load/resistance ratio.

Ratio Ratio of acting load to available resistance.

Axl Ratio of acting axial load to available axial resistance.

B33 Ratio of acting bending moment to available bending resistance
about the 33 axis.
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Table 1 Steel Frame Output Data
COLUMN HEADING DESCRIPTION

B22 Ratio of acting bending moment to available bending resistance
about the 22 axis.

Shear22

Combo Name of load combination that produces maximum stress ratio.

Ratio Ratio of acting shear divided by available shear resistance.

Shear33

Combo Load combination that produces the maximum shear parallel to
the 33 axis.

Ratio Ratio of acting shear divided by available shear resistance.

Beam Special Seismic Requirements

Story Level Name of the story level.

Beam Bay Beam bay identifier.

Section ID Name of member sections assigned.

Section Class Classification of section for the enveloping combo.

Connection Shear

Combo Name of the load combination that provides maximum End-I
connection shear.

End-I Maximum End-I connection shear.

Combo Name of the load combination that provides maximum End-J
connection shear.

End-J Maximum End-J connection shear.
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Table 1 Steel Frame Output Data
COLUMN HEADING DESCRIPTION

Column Steel Stress Check Output

Story Level Name of the story level.

Column Line Column line identifier.

Section ID Name of member sections assigned.

Moment Interaction Check

Combo Name of load combination that produces maximum stress ratio.

Ratio Ratio of acting stress to allowable stress.

AXL Ratio of acting axial stress to allowable axial stress.

B33 Ratio of acting bending stress to allowable bending stress
about the 33 axis.

B22 Ratio of acting bending stress to allowable bending stress
about the 22 axis.

Shear22

Combo Load combination that produces the maximum shear parallel to
the 22 axis.

Ratio Ratio of acting shear stress divided by allowable shear stress.

Shear33

Combo Load combination that produces the maximum shear parallel to
the 33 axis.

Ratio Ratio of acting shear stress divided by allowable shear stress.

Column Special Seismic Requirements

Story Level Story level name.
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Table 1 Steel Frame Output Data
COLUMN HEADING DESCRIPTION

Column Line Column line identifier.

Section ID Name of member section assigned.

Section Class Classification of section for the enveloping combo.

Continuity Plate

Combo Name of load combination that produces maximum continuity
plate area.

Area Cross-section area of the continuity plate.

Doubler Plate

Combo Name of load combination that produces maximum doubler
plate thickness.

Thick Thickness of the doubler plate.

B/C Ratios

Major Beam/column capacity ratio for major direction.

Minor Beam/column capacity ratio for minor direction.

Using the Print Design Tables Form
To print steel frame design ouput data directly to a printer, use the File
menu > Print Tables > Steel Frame Design command and click the Out-
put Summary check box on the Print Design Tables form. Click the OK button
to send the print to your printer. Click the Cancel button rather than the OK
button to cancel the print. Use the File menu > Print Setup command and
the Setup>> button to change printers, if necessary.

To print steel frame design output data to a file, click the Print to File check
box on the Print Design Tables form. Click the Filename button to change the
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path or filename. Use the appropriate file extension for the desired format
(e.g., .txt, .xls, .doc). Click the Save buttons on the Open File for Printing
Tables form and the Print Design Tables form to complete the request.

Note:

The File menu > Display Input/Output Text Files command is useful for displaying out-
put that is printed to a text file.

The Append check box allows you to add data to an existing file. The path and
filename of the current file is displayed in the box near the bottom of the Print
Design Tables form. Data will be added to this file. Or use the Filename
button to locate another file, and when the Open File for Printing Tables cau-
tion box appears, click Yes to replace the existing file.

If you select a specific frame element(s) before using the File menu > Print
Tables > Steel Frame Design command, the Selection Only check box will
be checked. The print will be for the selected beam(s) only.
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Technical Note 33
General and Notation

Introduction to the AISC-ASD89 Series of Technical
Notes
The AISC-ASD89 for Steel Frame Design series of Technical Notes describes
the details of the structural steel design and stress check algorithms used by
the program when the user selects the AISC-ASD89 design code (AISC
1989a). The various notations used in this series are described herein.

For referring to pertinent sections and equations of the original ASD code, a
unique prefix “ASD” is assigned. However, all references to the “Specifications
for Allowable Stress Design of Single-Angle Members” (AISC 1989b) carry the
prefix of “ASD SAM.”

The design is based on user-specified loading combinations. To facilitate use,
the program provides a set of default load combinations that should satisfy
requirements for the  design of most building type structures. See Steel
Frame Design AISC-ASD89 Technical Note 36 Design Load Combinations for
more information.

In the evaluation of the axial force/biaxial moment capacity ratios at a station
along the length of the member, first the actual member force/moment com-
ponents and the corresponding capacities are calculated for each load combi-
nation. Then the capacity ratios are evaluated at each station under the influ-
ence of all  load combinations using the corresponding equations that are de-
fined in this series of Technical Notes. The controlling capacity ratio is then
obtained. A capacity ratio greater than 1.0 indicates overstress. Similarly, a
shear capacity ratio is also calculated separately. Algorithms for completing
these calculations are described in AISC-ASD89 Steel Frame Design Technical
Notes 38 Calculation of Stresses, 39 Calculation of Allowable Stresses, and 40
Calculation of Stress Ratios.

Further information is available from AISC-ASD89 Steel Frame Design Techni-
cal Note 37 Classification of Sections.
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The program uses preferences and overwrites, which are described in AISC-
ASD89 Steel Frame Design Technical Notes 34 Preferences and 35 Over-
writes. It also provides input and output data summaries, which are described
in AISC-ASD89 Steel Frame Design Technical Notes 41 Input Data and 42
Output Details.

English as well as SI and MKS metric units can be used for input. But the code
is based on Kip-Inch-Second units. For simplicity, all equations and descrip-
tions presented in this chapter correspond to Kip-Inch-Second units unless
otherwise noted.

Notation
A Cross-sectional area, in2

Ae Effective cross-sectional area for slender sections, in2

Af Area of flange, in2

Ag Gross cross-sectional area, in2

Av2, Av3 Major and minor shear areas, in2

Aw Web shear area, dtw, in2

Cb Bending Coefficient

Cm Moment Coefficient

Cw Warping constant, in6

D Outside diameter of pipes, in

E Modulus of elasticity, ksi

Fa Allowable axial stress, ksi

Fb Allowable bending stress, ksi

Fb33, Fb22 Allowable major and minor bending stresses, ksi

Fcr Critical compressive stress, ksi
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Fv Allowable shear stress, ksi

Fy Yield stress of material, ksi

K Effective length factor

K33, K22 Effective length K-factors in the major and minor directions

M33, M22 Major and minor bending moments in member, kip-in

Mob Lateral-torsional moment for angle sections, kin-in

P Axial force in member, kips

Pe Euler buckling load, kips

Q Reduction factor for slender section, = QaQs

Qa Reduction factor for stiffened slender elements

Qs Reduction factor for unstiffened slender elements

S Section modulus, in3

S33, S22 Major and minor section moduli, in3

Seff,33,Seff,22 Effective major and minor section moduli for slender sec-
tions, in3

Sc Section modulus for compression in an angle section, in3

V2, V3 Shear forces in major and minor directions, kips

b Nominal dimension of plate in a section, in
longer leg of angle sections,
bf — 2tw for welded and bf — 3tw for rolled box sections, etc.
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be Effective width of flange, in

bf Flange width, in

d Overall depth of member, in

fa Axial stress, either in compression or in tension, ksi

fb Normal stress in bending, ksi

fb33, fb22 Normal stress in major and minor direction bending, ksi

fv Shear stress, ksi

fv2, fv3 Shear stress in major and minor direction bending, ksi

h Clear distance between flanges for I shaped sections
(d — 2tf), in

he Effective distance between flanges, less fillets, in

k Distance from outer face of flange to web toes of fillet, in

kc Parameter used for classification of sections,

[ ]
,70th  

05.4
w46.0

>if
th w

1         70h ≤wtif

l33, l22 Major and minor direction unbraced member length, in

lc Critical length, in

r Radius of gyration, in

r33, r22 Radii of gyration in the major and minor directions, in

rz Minimum radius of gyration for angles, in

t Thickness of a plate in I, box, channel, angle, and T sec-
tions, in

tf Flange thickness, in
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tw Web thickness, in

βw Special section property for angles, in
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Technical Note 34
Preferences

This Technical Note describes the items in the Preferences form.

General
The steel frame design preferences in this program are basic assignments
that apply to all steel frame elements. Use the Options menu > Prefer-
ences > Steel Frame Design command to access the Preferences form
where you can view and revise the steel frame design preferences.

Default values are provided for all steel frame design preference items. Thus,
it is not required that you specify or change any of the preferences. You
should, however, at least review the default values for the preference items
to make sure they are acceptable to you.

Using the Preferences Form
To view preferences, select the Options menu > Preferences > Steel
Frame Design. The Preferences form will display.  The preference options
are displayed in a two-column spreadsheet. The left column of the spread-
sheet displays the preference item name. The right column of the spreadsheet
displays the preference item value.

To change a preference item, left click the desired preference item in either
the left or right column of the spreadsheet. This activates a drop-down box or
highlights the current preference value. If the drop-down box appears, select
a new value. If the cell is highlighted, type in the desired value. The prefer-
ence value will update accordingly. You cannot overwrite values in the drop-
down boxes.

When you have finished making changes to the composite beam preferences,
click the OK button to close the form. You must click the OK button for the
changes to be accepted by the program. If you click the Cancel button to exit
the form, any changes made to the preferences are ignored and the form is
closed.
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Preferences
For purposes of explanation, the preference items are presented in Table 1.
The column headings in the table are described as follows:

 Item: The name of the preference item as it appears in the cells at the
left side of the Preferences form.

 Possible Values: The possible values that the associated preference item
can have.

 Default Value: The built-in default value that the program assumes for
the associated preference item.

 Description: A description of the associated preference item.

Table 1: Steel Frame Preferences

Item
Possible
Values

Default
Value Description

Design Code Any code in the
program

AISC-
ASD89

Design code used for design of
steel frame elements.

Time History
Design

Envelopes,
Step-by-Step

Envelopes Toggle for design load combinations
that include a time history designed for
the envelope of the time history, or de-
signed step-by-step for the entire time
history. If a single design load combi-
nation has more than one time history
case in it, that design load combination
is designed for the envelopes of the
time histories, regardless of what is
specified here.

Frame Type Moment Frame,
Braced Frame

Moment
Frame

Stress Ratio
Limit

>0 0.95 Program will select members from the
auto select list with stress ratios less
than or equal to this value.

Maximum Auto
Iteration

≥1 1 Sets the number of iterations of the
analysis-design cycle that the program
will complete automatically assuming
that the frame elements have been as-
signed as auto select sections.
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Technical Note 35
Overwrites

General
The steel frame design overwrites are basic assignments that apply only to
those elements to which they are assigned. This Technical Note describes
steel frame design overwrites for AISC-ASD89. To access the overwrites, se-
lect an element and click the Design menu > Steel Frame Design >
View/Revise Overwrites command.

Default values are provided for all overwrite items. Thus, you do not need to
specify or change any of the overwrites. However, at least review the default
values for the overwrite items to make sure they are acceptable. When
changes are made to overwrite items, the program applies the changes only
to the elements to which they are specifically assigned; that is, to the ele-
ments that are selected when the overwrites are changed.

Overwrites
For explanation purposes in this Technical Note, the overwrites are presented
in Table 1. The column headings in the table are described as follows.

 Item: The name of the overwrite item as it appears in the program. To
save space in the forms, these names are generally short.

 Possible Values: The possible values that the associated overwrite item
can have.

 Default Value: The default value that the program assumes for the associ-
ated overwrite item. If the default value is given in the table with an asso-
ciated note "Program Calculated," the value is shown by the program before
the design is performed. After design, the values are calculated by the pro-
gram and the default is modified by the program-calculated value.

 Description: A description of the associated overwrite item.
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An explanation of how to change an overwrite is provided at the end of this
Technical Note.

Table 1 Steel Frame Design Overwrites

Item
Possible
Values

Default
Value Description

Current Design
Section

Indicates selected member size used in
current design.

Element Type Moment
Frame,

Braced Frame

From
Preferences

Live Load
Reduction

Factor
≥0 1

Live load is multiplied by this factor.

Horizontal
Earthquake

Factor
≥0 1

Earthquake loads are multiplied by this
factor.

Unbraced
Length Ratio

(Major)
≥0 1

Ratio of unbraced length divided by
total length.

Unbraced
Length Ratio
(Minor, LTB)

≥0 1
Ratio of unbraced length divided by
total length.

Effective
Length Factor

(K Major)
≥0 1

As defined in AISC-ASD Table C-C2.1,
page 5-135.

Effective
Length Factor

(K Minor)
≥0 1

As defined in AISC-ASD Table C-C2.1,
page 5-135.

Moment
Coefficient
(Cm Major)

≥0 0.85
As defined in AISC-ASD, page 5-55.

Moment
Coefficient
(Cm Minor)

≥0 0.85
As defined in AISC-ASD, page 5-55.

Bending
Coefficient

(Cb)
≥0 1

As defined in AISC-ASD, page 5-47.
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Table 1 Steel Frame Design Overwrites

Item
Possible
Values

Default
Value Description

Yield stress, Fy ≥0 0 If zero, yield stress defined for material
property data used.

Compressive
stress, Fa ≥0 0

If zero, yield stress defined for material
property data used and AISC-ASD
specification Chapter E.

Tensile
stress, Ft ≥0 0

If zero, as defined for material property
data used and AISC-ASD Chapter D.

Major Bending
stress, Fb3 ≥0 0

If zero, as defined for material property
data used and AISC-ASD specification
Chapter F.

Minor Bending
stress, Fb2 ≥0 0

If zero, as defined for material property
data used and AISC-ASD specification
Chapter F.

Major Shear
stress, Fv2 ≥0 0

If zero, as defined for material property
data used and AISC-ASD specification
Chapter F.

Minor Shear
stress, Fv3

≥0 0 If zero, as defined for material property
data used and AISC-ASD specification
Chapter F.

Making Changes in the Overwrites Form
To access the steel frame overwrites, select a frame element and click the
Design menu > Steel Frame Design > View/Revise Overwrites com-
mand.

The overwrites are displayed in the form with a column of check boxes and a
two-column spreadsheet. The left column of the spreadsheet contains the
name of the overwrite item. The right column of the spreadsheet contains the
overwrites values.

Initially, the check boxes in the Steel Frame Design Overwrites form are all
unchecked and all of the cells in the spreadsheet have a gray background to
indicate that they are inactive and the items in the cells cannot be changed.
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The names of the overwrite items are displayed in the first column of the
spreadsheet. The values of the overwrite items are visible in the second col-
umn of the spreadsheet if only one frame element was selected before the
overwrites form was accessed. If multiple elements were selected, no values
show for the overwrite items in the second column of the spreadsheet.

After selecting one or multiple elements, check the box to the left of an over-
write item to change it. Then left click in either column of the spreadsheet to
activate a drop-down box or highlight the contents in the cell in the right col-
umn of the spreadsheet. If the drop-down box appears, select a value from
the box. If the cell contents is highlighted, type in the desired value. The
overwrite will reflect the change. You cannot change the values of the drop-
down boxes.

When changes to the overwrites have been completed, click the OK button to
close the form. The program then changes all of the overwrite items whose
associated check boxes are checked for the selected members. You must click
the OK button for the changes to be accepted by the program. If you click the
Cancel button to exit the form, any changes made to the overwrites are ig-
nored and the form is closed.

Resetting Steel Frame Overwrites to Default Values
Use the Design menu > Steel Frame Design > Reset All Overwrites
command to reset all of the steel frame overwrites. All current design results
will be deleted when this command is executed.

Important note about resetting overwrites: The program defaults for the
overwrite items are built into the program. The steel frame overwrite values
that were in a .edb file that you used to initialize your model may be different
from the built-in program default values. When you reset overwrites, the pro-
gram resets the overwrite values to its built-in values, not to the values that
were in the .edb file used to initialize the model.
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Technical Note 36
Design Load Combinations

This Technical Note describes the default design load combinations in the pro-
gram when the AISC-ASD89 code is selected.

The design load combinations are the various combinations of the load cases
for which the structure needs to be checked. For the AISC-ASD89 code, if a
structure is subjected to dead load (DL), live load (LL), wind load (WL), and
earthquake induced load (EL), and considering that wind and earthquake
forces are reversible, the following load combinations may need to be defined
(ASD A4):

DL (ASD A4.1)
DL + LL (ASD A4.1)

DL ± WL (ASD A4.1)
DL + LL ± WL (ASD A4.1)

DL ± EL (ASD A4.1)
DL + LL ± EL (ASD A4.1)

These are also the default design load combinations in the program when the
AISC-ASD89 code is used. The user should use other appropriate loading
combinations if roof live load is separately treated, if other types of  loads are
present, or if pattern live loads are to be considered.

When designing for combinations involving earthquake and wind loads, allow-
able stresses are increased by a factor of 4/3 of the regular allowable value
(ASD A5.2).

Live load reduction factors can be applied to the member forces of the live
load case on an element-by-element basis to reduce the contribution of the
live load to the factored loading. See AISC-ASD89 Steel Frame Design Tech-
nical Note 35 Overwrites for more information.
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Technical Note 37
Classification of Sections

This Technical Note explains the classification of sections when the user se-
lects the AISC-ASD89 design code.

The allowable stresses for axial compression and flexure are dependent upon
the classification of sections as either Compact, Noncompact, Slender, or Too
Slender. The program classifies the individual members according to the lim-
iting width/thickness ratios given in Table 1 (ASD B5.1, F3.1, F5, G1, A-B5-
2). The definition of the section properties required in this table is given in
Figure 1 and AISC-ASD89 Steel Frame Design Technical Note 33 General and
Notation.

If the section dimensions satisfy the limits shown in the table, the section is
classified as either Compact, Noncompact, or Slender. If the section satisfies
the criteria for Compact sections, the section is classified as a Compact sec-
tion. If the section does not satisfy the criteria for Compact sections but sat-
isfies the criteria for Noncompact sections, the section is classified as a Non-
compact section. If the section does not satisfy the criteria for Compact and
Noncompact sections but satisfies the criteria for Slender sections, the section
is classified as a Slender section. If the limits for Slender sections are not
met, the section is classified as Too Slender. Stress check of "Too Slender"
sections is beyond the scope of this program.

In classifying web slenderness of I-shapes, Box, and Channel sections, it is
assumed that there are no intermediate stiffeners (ASD F5, G1). Double an-
gles are conservatively assumed to be separated.
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Table 1 Limiting Width-Thickness Ratios for Classification of Sections Based
on AISC-ASD

Section
Description

Ratio
Check

Compact
Section

Noncompact
Section

Slender
Section

bf / 2tf
(rolled)

≤  65 / yF ≤  95 / yF No limit

bf / 2tf
(welded)

≤  65 / yF ≤  95 / 
cy kF / No limit

d / tw

For fa / Fy ≤  0.16

),74.31(
640

y

a

y
F

f

F
−≤

For fa / Fy > 0.16

≤  257 / yF

No limit No limit
I-SHAPE

h / tw No limit

If compression only,

≤  253 / yF

otherwise

≤  760 / bF

If compression only,

)5.16(

000,14

+
≤

yy FF

260≤

b / tf ≤  190 / yF ≤  238 / yF No limit

d / tw As for I-shapes No limit No limit

h / tw No limit As for I-shapes As for I-shapes
BOX

Other tw ≥ tf /2, dw ≤  6bf None None

b / tf As for I-shapes As for I-shapes No limit

d / tw As for I-shapes No limit No limit

h / tw No limit As for I-shapes As for I-shapes

CHANNEL

Other No limit No limit

If welded
bf / dw ≤  0.25,
tf / tw   ≤  3.0

If rolled
bf / dw ≤  0.5,
tf / tw   ≤  2.0
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Table 1 Limiting Width-Thickness Ratios for Classification of Sections Based
on AISC-ASD (continued)

Section
Description

Ratio
Check

Compact
Section

Noncompact
Section

Slender
Section

bf / 2tf ≤  65 / yF ≤  95 / yF No limit

d / tw Not applicable ≤  127 / yF No limit

T-SHAPE

Other No limit No limit

If welded
bf / dw ≥  0.5,
tf / tw   ≥  1.25

If rolled
bf / dw ≥  0.5,
tf / tw   ≥  1.10

DOUBLE
ANGLES b / t Not applicable ≤  76 / yF No limit

ANGLE b / t Not applicable ≤  76 / yF No limit

PIPE D / t ≤  3,300 / Fy ≤  3,300 / Fy

≤  3,300 / Fy

(Compression only)
No limit for flexure

ROUND BAR  Assumed Compact

RECTANGLE  Assumed Noncompact

GENERAL  Assumed Noncompact
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STEEL FRAME DESIGN AISC-ASD89

Technical Note 38
Calculation of Stresses

This Technical Note explains how the program calculates the stresses at each
defined station. The member stresses for non-slender sections that are cal-
culated for each load combination area, in general, based on the gross cross-
sectional properties, as follows:

fa = P/A
fb33 = M33/S33
fb22 = M22/S22
fv2 = V2/Av2
fv3 = V3/Av3

If the section is slender with slender stiffened elements, such as a slender
web in I, Channel, and Box sections or slender flanges in Box sections, the
program uses effective section moduli based on reduced web and reduced
flange dimensions in calculating stresses, as follows:

fa = P/A (ASD A-B5.2d)
fb33 = M33/Seff,33 (ASD A-B5.2d)
fb22 = M22/Seff,22 (ASD A-B5.2d)
fv2 = V2/Av2 (ASD A-B5.2d)
fv3 = V3/Av3 (ASD A-B5.2d)

The flexural stresses are calculated based on the properties about the princi-
pal axes. For I, Box, Channel, T, Double-angle, Pipe, Circular and Rectangular
sections, the principal axes coincide with the geometric axes. For Single-angle
sections, the design considers the principal properties. For general sections, it
is assumed that all section properties are given in terms of the principal di-
rections.

For Single-angle sections, the shear stresses are calculated for directions
along the geometric axes. For all other sections, the program calculates the
shear stresses along the geometric and principle axes.
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STEEL FRAME DESIGN AISC-ASD89

Technical Note 39
Calculation of Allowable Stresses

This Technical Note explains how the program calculates the allowable
stresses in compression, tension, bending, and shear for Compact, Noncom-
pact, and Slender sections. The allowable flexural stresses for all shapes of
sections are calculated based on their principal axes of bending. For the I,
Box, Channel, Circular, Pipe, T, Double-angle and Rectangular sections, the
principal axes coincide with their geometric axes. For the Angle sections, the
principal axes are determined and all computations related to flexural stresses
are based on that.

If the user specifies nonzero allowable stresses for one or more elements in
the Steel Frame Design Overwrites form (display using the Design menu >
Steel Frame Design > Review/Revise Overwrites command), the
nonzero values will be used rather than the calculated values for those
elements. The specified allowable stresses should be based on the principal
axes of bending.

Allowable Stress in Tension
The allowable axial tensile stress value Fa is assumed to be 0.60 Fy.

 Fa = 0.6 Fy (ASD D1, ASD SAM 2)

It should be noted that net section checks are not made. For members
in tension, if l/r is greater than 300, a message to that effect is printed (ASD
B7, ASD SAM 2). For single angles, the minimum radius of gyration, rz is used
instead of r22 and r33 in computing l/r.

Allowable Stress in Compression
The allowable axial compressive stress is the minimum value obtained from
flexural buckling and flexural-torsional buckling. The allowable compressive
stresses are determined according to the following subsections.
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For members in compression, if Kl/r is greater than 200, a warning message
is printed (ASD B7, ASD SAM 4). For single angles, the minimum radius of
gyration, rz,  is used instead of r22 and r33 in computing Kl/r.

Flexural Buckling
The allowable axial compressive stress value, Fa, depends on the slenderness
ratio Kl/r based on gross section properties and a corresponding critical value,
Cc,  where


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For single angles, the minimum radius of gyration, rz, is used instead of r22

and r33 in computing Kl/r.

For Compact or Noncompact sections, Fa is evaluated as follows:
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If Kl/r is greater than 200, the calculated value of Fa is taken not to exceed
the value of Fa, calculated by using the equation ASD E2-2 for Compact and
Noncompact sections (ASD E1, B7).

For Slender sections, except slender Pipe sections, Fa is evaluated as follows:
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'> . (ASD A-B5-12, SAM 4-2)

where,

 
y

c QF
E

C
22

'
π= . (ASD A-B5.2c, ASD SAM 4)

For slender sections, if Kl/r is greater than 200, the calculated value of  Fa is
taken not to exceed its value calculated by using the equation ASD A-B5-12
(ASD  B7, E1).

For slender Pipe sections, Fa is evaluated as follows:

ya F
tD

F 40.0
/

662 += (ASD A-B5-9)

The reduction factor, Q, for all compact and noncompact sections is taken as
1. For slender sections, Q is computed as follows:

 Q = QsQa, where (ASD A-B5.2.c, SAM 4)

Qs = reduction factor for unstiffened slender elements, and(ASD A-B5.2.a)

 Qa = reduction factor for stiffened slender elements. (ASD A-B5.2.c)

The Qs factors for slender sections are calculated as described in Table 1
(ASD A-B5.2a, ASD SAM 4). The Qa factors for slender sections are calculated
as the ratio of effective cross-sectional area and the gross cross-sectional
area.

g

e
a A

A
Q = (ASD A-B5-10)

The effective cross-sectional area is computed based on effective width as
follows:

 ∑ −−= tbbAA ege )(

where
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be for unstiffened elements is taken equal to b, and be for stiffened elements
is taken equal to or less than b, as given in Table 2 (ASD A-B5.2b). For webs
in I, box, and Channel sections, he is used as be and h is used as b in the
above equation.

Flexural-Torsional Buckling
The allowable axial compressive stress value, Fa, determined by the limit
states of torsional and flexural-torsional buckling, is determined as follows
(ASD E3, C-E3):
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Table 1 Reduction Factor for Unstiffened Slender Elements, Qs

Section
Type

Reduction Factor for Unstiffened Slender Elements
(Qs)

Equation
Reference

I-SHAPE

1.0 if bf/2tf ≤  95 /
cy kF ,

Qs = 1,293 - 0.00309[bf/2tf] cy kF if 95 /
cy kF < bf/2tf <195 /

cy kF ,

26,200kc  / {[bf/2tf]2Fy} if bf/2tf ≥ 195 /
cy kF .

ASD A-B5-3,
ASD A-B5-4

BOX Qs = 1 ASD A-B5.2c

CHANNEL As for I-shapes with bf / 2tf replaced by bf / tf
ASD A-B5-3,
ASD A-B5-4

T-SHAPE

For flanges, as for flanges in I-shapes. For web, see below.
1.0 if b/tw ≤ 127 /

yF ,

Qs = 1.908-0.00715 [d/tw]
yF if 127/

yF <d/tw < 176/
yF ,

20,000 / {[d/tw]2Fy} if d/tw ≥ 176/
yF .

ASD A-B5-3,
ASD A-B5-4,
ASD A-B5-5,
ASD A-B5-6

DOUBLE-
ANGLE

1.0 if b/t ≤ 76 /
yF ,

Qs = 1.340-0.00447 [b/t]
yF if 76/

yF <d/t < 155/
yF ,

15,500 / {[b/t]2Fy} if d/t ≥ 155/
yF .

ASD A-B5-1,
ASD A-B5-2,

SAM 4-3

ANGLE

1.0 if b/t ≤ 76 /
yF ,

Qs = 1.340-0.00447 [d/t]
yF if 76/

yF  < b/t < 155/
yF ,

15,500 / {[d/t]2Fy} if b/t ≥ 155/
yF .

ASD A-B5-1,
ASD A-B5-2,

SAM 4-3

PIPE Qs = 1 ASD A-B5.2c

ROUND
BAR

Qs = 1 ASD A-B5.2c

RECTAN-
GULAR

Qs = 1 ASD A-B5.2c

GENERAL Qs = 1 ASD A-B5.2c
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Table 2 Effective Width for Stiffened Sections

Section
Type

Effective Width for Stiffened Sections
Equation
Reference

I-SHAPE

,h if 
ft

h

w

74.195≤ ,

tw 3.44253 , if h 74.195> .      (compression only ) ASD A-B5-8

BOX

CHANNEL

T-SHAPE

DOUBLE-
ANGLE

ANGLE

PIPE

ROUND
BAR

RECTAN-
GULAR

GENERAL

Note: A reduc
includes any w

P
f =
=h
e 39 - 6 Calcula
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ASD Commentary (ASD C-E3) refers to the 1986 version of the AISC-LRFD
code for the calculation of Fe. The 1993 version of the AISC-LRFD code is the
same as the 1986 version in this respect. Fe is calculated in the program as
follows:

 For Rectangular, I, Box, and Pipe sections:
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 For T-sections and Double-angles:
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 For Channels:
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 For Single-angle sections with equal legs:
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 For Single-angle sections with unequal legs, Fe is calculated as the mini-
mum real root of the following cubic equation (ASD SAM C-C4-2, LRFD A-
E3-7):

(Fe-Fe33)(F3-Fe22)(Fe-Fez)-Fe
2(Fe-Fe22), 2

2

o

o

r

x
-Fe

2(Fe-Fe33) 2

2

o

o

r

y
=0,

where,

 xo, yo are the coordinates of the shear center with respect to the cen-
troid, xo = 0 for double-angle and T-shaped members (y-axis of
symmetry),
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K22, K33 are effective length factors in minor and major directions,

Kz is the effective length factor for torsional buckling, and it is taken equal
to K22 in the program,

l22, l33 are effective lengths in the minor and major directions,

lz is the effective length for torsional buckling, and it is taken equal to l22.

For angle sections, the principal moment of inertia and radii of gyration are
used for computing Fe (ASD SAM 4). Also, the maximum value of Kl, i.e,
max(K22l22, K33l33) , is used in place of K22l22 or K33l33 in calculating Fe22 and
Fe33  in this case.

Allowable Stress in Bending
The allowable bending stress depends on the following criteria: the geometric
shape of the cross-section; the axis of bending; the compactness of the sec-
tion; and a length parameter.

I-Sections
For I-sections the length parameter is taken as the laterally unbraced length,
l22, which is compared to a critical length, lc. The critical length is defined as
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   Af is the area of compression flange.

Major Axis of Bending
If l22 is less than lc, the major allowable bending stress  for Compact and Non-
compact sections is taken depending on whether the section is welded or
rolled and whether fy is less than or equal to 65 ksi or greater than 65 ksi.

For Compact sections:

Fb33 = 0.66 Fy if fy ≤ 65 ksi, (ASD F1-1)

Fb33 = 0.60 Fy if fy > 65 ksi. (ASD F1-5)

For Noncompact sections:

Fb33 = yy
f

f FF
t
b
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−

2
002.079.0 if rolled and fy ≤ 65 ksi, (ASD F1-3)

Fb33 = y
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−

2
002.079.0 if welded and fy ≤ 65 ksi, (ASDF1-4)

Fb33 = 0.60 Fy if  fy > 65 ksi (ASD F1-5)

If the unbraced length l22 is greater than lc, then for both Compact and Non-
compact I-sections the allowable bending stress depends on the l22 /rT ratio.

For 
y
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T F
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r
l 000,10222 ≤  ,

Fb33 = 0.60 Fy, (ASD F1-6)
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and Fb33 is taken not to be less than that given by the following formula:

 Fb33 = ( )f

b

Adl
C

/
000,12

22
 ≤ 0.60 Fy (ASD F1-8)

where,

rT is the radius of gyration of a section comprising the compression flange
and 1/3 the compression web taken about an axis in the plane of the web,

Cb = 1.75 + 1.05 
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 + 0.3 
2
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



b

a

M
M

≤ 2.3 ,  where (ASD F1.3)

Ma and Mb are the end moments of any unbraced segment of the member and
Ma is numerically less than Mb; Ma / Mb being positive for double curvature
bending and negative for single curvature bending. Also, if any moment
within the segment is greater than Mb, Cb is taken as 1.0. Also, Cb is taken as
1.0 for cantilevers and frames braced against joint translation (ASD F1.3).
The program defaults Cb to 1.0 if the unbraced length, l22, of the member is
redefined by the user  (i.e., it is not equal to the length of the member). The
user can overwrite the value of Cb for any member by specifying it.

The allowable bending stress for Slender sections bent about their major axis
is determined in the same way as for a Noncompact section. Then the follow-
ing additional considerations are taken into account.

If the web is slender, the previously computed allowable bending stress is re-
duced as follows:

F'b33 = RPGReFb33, where (ASD G2-1)
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RPG = 1.0 - 0.0005 
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 ≤ 1.0, (hybrid girders) (ASD G2)

Re = 1.0, (non-hybrid girders) (ASD G2)

Aw = Area of web, in2,

Af = Area of compression flange, in2,

33

6.0

b

y

F

F
=α  ≤ 1.0 (ASD G2)

Fb33=Allowable bending stress assuming the section is non-compact,  and

F'b33=Allowable bending stress after considering web slenderness.

In the above expressions, Re is taken as 1, because currently the program
deals with only non-hybrid girders.

If the flange is slender, the previously computed allowable bending stress is
taken to be limited, as follows.

 F'b33 ≤ Qs (0.6 Fy), where (ASD A-B5.2a, A-B5.2d)

 Qs is defined earlier.

Minor Axis of Bending
The minor direction allowable bending stress Fb22 is taken as follows:

For Compact sections:

Fb22 = 0.75 Fy if fy ≤ 65 ksi, (ASD F2-1)

Fb22 = 0.60 Fy if fy > 65 ksi. (ASD F2-2)

For Noncompact and Slender sections:
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Fb22 = 





− y
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f F
t
b
2

005.0075.1  Fy,    if  fy ≤ 65 ksi, (ASD F2-3)

Fb22 = 0.60 Fy if  fy > 65 ksi. (ASD F2-2)

Channel Sections
For Channel sections, the length parameter is taken as the laterally unbraced
length, l22, which is compared to a critical length, lc. The critical length is de-
fined as

lc = min












y

f

y

f

dF
A

F

b 000,20
,

76
, where (ASD F1-2)

Af is the area of compression flange.

Major Axis of Bending
If l22 is less than lc, the major allowable bending stress for Compact and Non-
compact sections is taken depending on whether the section is welded or
rolled and whether fy is greater than 65 ksi or not.

For Compact sections:

Fb33 = 0.66 Fy if fy ≤ 65 ksi, (ASD F1-1)

Fb33 = 0.60 Fy if fy > 65 ksi. (ASD F1-5)

For Noncompact sections:

Fb33 = 


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002.079.0  Fy, if rolled and fy ≤ 65 ksi, (ASD F1-3)

Fb33 = 
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002.079.0  Fy, if welded and fy ≤ 65 ksi, (ASD F1-4)

     Fb33 =  0.60 Fy if  fy > 65 ksi. (ASD F1-5)

If the unbraced length l22 is greater than lc, then for both Compact and Non-
compact Channel sections the allowable bending stress is taken as follows:
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 Fb33 = 
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000,12
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b
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C

 ≤ 0.60 Fy (ASD F1-8)

The allowable bending stress for Slender sections bent about their major axis
is determined in the same way as for a Noncompact section. Then the follow-
ing additional considerations are taken into account.

If the web is slender, the previously computed allowable bending stress is re-
duced as follows:

 F'b33 = ReRPGFb33 (ASD G2-1)

If the flange is slender, the  previously computed allowable bending stress is
taken to be limited as follows:

F'b33 = Qs (0.60 Fy) (ASD A-B5.2a, A-B5.2d)

The definitions for  rT, Cb, Af, Aw, Re, RPG, Qs, Fb33, and F'b33 are given earlier.

Minor Axis of Bending
The minor direction allowable bending stress Fb22 is taken as follows:

Fb22 = 0.60 Fy (ASD F2-2)

T Sections and Double Angles
For T sections and Double angles, the allowable bending stress for both major
and minor axes bending is taken as,

Fb = 0.60 Fy

Box Sections and Rectangular Tubes
For all Box sections and Rectangular tubes, the length parameter is taken as
the laterally unbraced length, l22, measured compared to a critical length, lc.
The critical length is defined as

lc = max 










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+
yy

ba F
b

F
b

MM
200,1

,)/200,1950,1( (ASD F3-2)

where Ma and Mb have the same definition as noted earlier in the formula for

Cb.  If l22 is specified by the user, lc is taken as 
yF

b200,1
 in the program.
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Major Axis of Bending
If  l22 is less than lc, the allowable bending stress in the major direction of
bending is taken as:

Fb33 =  0.66 Fy (for Compact sections) (ASD F3-1)

Fb33 =  0.60 Fy (for Noncompact sections) (ASD F3-3)

If  l22 exceeds lc, the allowable bending stress in the major direction of bend-
ing for both Compact and Noncompact sections is taken as:

Fb33 =  0.60 Fy (ASD F3-3)

The major direction allowable bending stress for Slender sections is deter-
mined in the same way as for a Noncompact section. Then the following addi-
tional consideration is taken into account. If the web is slender, the previously
computed allowable bending stress is reduced as follows:

 F'b33 = ReRPGFb33 (ASD G2-1)

The definitions for  Re, RPG, Fb33 and F'b33 are given earlier.

If the flange is slender, no additional consideration is needed in computing
allowable bending stress. However, effective section dimensions are calcu-
lated and the section modulus is modified according to its slenderness.

Minor Axis of Bending
If l22 is less than lc, the allowable bending stress in the minor direction of
bending is taken as:

Fb22 =  0.66 Fy (for Compact sections) (ASD F3-1)

Fb22 =  0.60 Fy (for Noncompact and Slender sections) (ASD F3-3)

If  l22 exceeds lc, the allowable bending stress in the minor direction of bend-
ing is taken, irrespective of compactness, as:

Fb22 =  0.60 Fy (ASD F3-3)

Pipe Sections
For Pipe sections, the allowable bending stress for both major and minor axes
of bending is taken as
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Fb =  0.66 Fy (for Compact sections), and (ASD F3-1)

Fb =  0.60 Fy (for Noncompact and Slender sections). (ASD F3-3)

Round Bars
The allowable stress for both the major and minor axis of bending of round
bars is taken as,

Fb=  0.75 Fy. (ASD F2-1)

Rectangular and Square Bars
The allowable stress for both the major and minor axis of bending of solid
square bars is taken as,

Fb=  0.75 Fy. (ASD F2-1)

For solid rectangular bars bent about their major axes, the allowable stress is
given by

Fb=  0.60 Fy,  and

the allowable stress for minor axis bending of rectangular bars is taken as

Fb=  0.75 Fy. (ASD F2-1)

Single-Angle  Sections
The allowable flexural stresses for Single-angles are calculated based on their
principal axes of bending (ASD SAM 5.3).

Major Axis of Bending
The allowable stress for major axis bending is the minimum considering the
limit state of lateral-torsional buckling and local buckling (ASD SAM 5.1).

The allowable major bending stress for Single-angles for the limit state of lat-
eral-torsional buckling is given as follows (ASD SAM 5.1.3):

Fb,major = 











−

y
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F
F

10.055.0 Fob, if  Fob ≤ Fy (ASD SAM 5-3a)

Fb,major = 











−

obF

F
50.095.0 Fy,≤ 0.66 Fy if   Fob > Fy  (ASD SAM 5-3b)
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where,  Fob is the elastic lateral-torsional buckling stress as calculated below.

The elastic lateral-torsional buckling stress,  Fob, for equal-leg angles is taken
as

  Fob = Cb 
tl /

250,28
(ASD SAM 5-5)

and for unequal-leg angles,  Fob is calculated as

Fob = 143,100Cb 



 β++β ww

major

rlt
lS

I 2
min

2
2

min )/(052.0 , (ASD SAM 5-6)

where,

 t = min(tw, tf),

 l = max(l22,l33),

Imin = minor principal moment of inertia,

Imax = major principal moment of inertia,

Smajor = major section modulus for compression at the tip of one leg,

rmin  = radius of gyration for minor principal axis,

βw = oA zdAzwz
I

2)(
1 22

max
−








+∫ , (ASD SAM 5.3.2)

z = coordinate along the major principal axis,

w = coordinate along the minor principal axis, and

zo = coordinate of the shear center along the major principal axis with
respect to the centroid.

βw is a special section property for angles. It is positive for short leg in com-
pression, negative for long leg in compression, and zero for equal-leg angles
(ASD SAM 5.3.2). However, for conservative design in the program, it is al-
ways taken as negative for unequal-leg angles.
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In the previous expressions, Cb is calculated in the same way as is done for I
sections, with the exception that the upper limit of Cb is taken here as 1.5 in-
stead of 2.3.

Cb = 1.75 + 1.05 






b

a

M
M

+ 0.3 
2
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



b

a

M
M

 ≤ 1.5 (ASD F1.3, SAM 5.2.2)

The allowable major bending stress for Single-angles for the limit state of lo-
cal buckling is given as follows (ASD SAM 5.1.1):

Fb,major = 0.66 Fy if 
yFt

b 65≤ , (ASD SAM 5-1a)

Fb,major = 0.60 Fy if
yy Ft

b

F

7665 ≤< (ASD SAM 5-1b)

Fb,major = Q(0.60 Fy) if 
yFt

b 76> (ASD SAM 5-1c)

where,

 t = thickness of the leg under consideration,

b = length of the leg under consideration, and

Q = slenderness reduction factor for local buckling.(ASD A-B5-2, SAM 4)

In calculating the allowable bending stress for Single-angles for the limit state
of local buckling, the allowable stresses are calculated considering the fact
that either of the two tips can be under compression. The minimum allowable
stress is considered.

Minor Axis of Bending
The allowable minor bending stress for Single-angles is given as follows (ASD
SAM 5.1.1, 5.3.1b, 5.3.2b):

Fb,minor = 0.66 Fy if 
yFt

b 65≤ , (ASD SAM 5-1a)
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Fb,minor = 0.60 Fy if
yy Ft

b

F

7665 ≤< (ASD SAM 5-1b)

Fb,minor = Q(0.60 Fy) if 
yFt

b 76> (ASD SAM 5-1c)

In calculating the allowable bending stress for Single-angles, it is assumed
that the sign of the moment is such that both the tips are under compression.
The minimum allowable stress is considered.

General Sections
For General sections, the allowable bending stress for both major and minor
axes bending is taken as,

Fb = 0.60 Fy.

Allowable Stress in Shear
The allowable shear stress is calculated along the geometric axes for all sec-
tions. For I, Box, Channel, T, Double angle, Pipe, Circular and Rectangular
sections, the principal axes coincide with their geometric axes. For Single-
angle sections, principal axes do not coincide with the geometric axes.

Major Axis of Bending
The allowable shear stress for all sections except I, Box and Channel sections
is taken in the program as:

 Fv = 0.40 Fy (ASD F4-1, SAM 3-1)

The allowable shear stress for major direction shears in I-shapes, boxes and
channels is evaluated as follows:

 Fv = 0.40 Fy,                    if  
yw Ft

h 380≤  ,  and (ASD F4-1)

 Fv = yy
v FF

C
40.0

89.2
≤ , if  260

380 ≤<
wy t
h

F
. (ASD F4-2)

where,
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if 1≤
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5.34+
2)/(

00.4

ha if 1>
h
a

(ASD F4)

tw = Thickness of the web,

a = Clear distance between transverse stiffeners, in. Currently it is
taken conservatively as the length, l22, of the member in the pro-
gram,

h = Clear distance between flanges at the section, in.

Minor Axis of Bending
The allowable shear stress for minor direction shears is taken as:

Fv = 0.40 Fy (ASD F4-1, SAM 3-1) 
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Technical Note 40
Calculation of Stress Ratios

This Technical Note describes how the program calculates stress ratios. In the
calculation of the axial and bending stress ratios, first, for each station along
the length of the member, the actual stresses are calculated for each load
combination. Then the corresponding allowable stresses are calculated. Then,
the stress ratios are calculated at each station for each member under the
influence of each of the design load combinations. The controlling stress ratio
is then obtained, along with the associated station and load combination. A
stress ratio greater than 1.0 indicates an overstress.

During the design, the effect of the presence of bolts or welds is not
considered.

Axial and Bending Stresses
With the computed allowable axial and bending stress values and the factored
axial and bending member stresses at each station, an interaction stress ratio
is produced for each of the load combinations as follows (ASD H1, H2, SAM
6):

 If fa is compressive and  fa /  Fa, > 0.15, the combined stress ratio is given
by the larger of
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++  ,   where (ASD  H1-2, SAM 6.1)

fa = axial stress

fb33  = bending stress about the local 3-axis
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T

C

fb22 = bending stress about the local 2-axis

Fa = allowable axial stress

Fb33 = allowable bending stress about the local 3-axis

Fb22 =  allowable bending stress about the local 2-axis

Cm33 and Cm22 are coefficients representing distribution of moment along the
member length.

1.00 if length is overwritten,

1.00 if tension member,

0.85 if sway frame,

0.6-0.4 ,aM
if nonsway, no transverse loading (ASD H1)
m =
echnical Note 40 - 2 Calculation of Stress Ratios

bM

0.85 if nonsway, trans. load, end restrained,

1.00 if nonsway, trans. load, end unrestrained

For sway frame, Cm = 0.85; for nonsway frame without transverse load, Cm

= 0.6 - 0.4 Ma / Mb; for nonsway frame with transverse load and end re-
strained compression member, Cm = 0.85; and for nonsway frame with
transverse load and end unrestrained compression member,  Cm = 1.00
(ASD H1). In these cases,  Ma / Mb is the ratio of the smaller to the larger
moment at the ends of the member, Ma / Mb being positive for double cur-
vature bending and negative for single curvature bending. When Mb is zero,
Cm is taken as 1.0. The program defaults Cm to 1.0 if the unbraced length
factor, l, of the member is redefined by either the user or the program, i.e.,
if the unbraced length is not equal to the length of the member. The user
can overwrite the value of Cm for any member.  Cm assumes two values,
Cm22 and Cm33, associated with the major and minor directions.

F'e is given by

F'e = 
2

2

)/(23

12

rKl

Eπ
. (ASD H1)
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A factor of 4/3 is applied on F'e and 0.6Fy if the load combination includes
any wind load or seismic load (ASD H1, ASD A5.2).

 If fa is compressive and fa / Fa ≤ 0.15, a relatively simplified formula is used
for the combined stress ratio.
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++ (ASD  H1-3, SAM 6.1)

 If fa is tensile or zero, the combined stress ratio is given by the larger of
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+ ,  where

fa, fb33, fb22, Fa, Fb33, and Fb22 are as defined earlier in this Technical Note.
However, either Fb33 or Fb22 need not be less than 0.6Fy in the first equation
(ASD H2-1).  The second equation considers flexural buckling without any
beneficial effect from axial compression.

For circular and pipe sections, an SRSS combination is first made of the two
bending components before adding the axial load component, instead of the
simple addition implied by the above formulae.

For Single-angle sections, the combined stress ratio is calculated based on the
properties about the principal axis (ASD SAM 5.3, 6.1.5). For I, Box, Channel,
T, Double-angle, Pipe, Circular and Rectangular sections, the principal axes
coincide with their geometric axes. For Single-angle sections, principal axes
are determined in the program. For general sections, no effort is made to
determine the principal directions.

When designing for combinations involving earthquake and wind loads, allow-
able stresses are increased by a factor of 4/3 of the regular allowable value
(ASD A5.2).
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Shear Stresses
From the allowable shear stress values and the factored shear stress values
at each station, shear stress ratios for major and minor directions are com-
puted for each of the load combinations as follows:

v

v

F
f 2 ,      and      

v

v

F
f 3 .

For Single-angle sections, the shear stress ratio is calculated for directions
along the geometric axis. For all other sections, the shear stress is calculated
along the principle axes that coincide with the  geometric axes.

When designing for combinations involving earthquake and wind loads, allow-
able shear stresses are increased by a factor of 4/3 of the regular allowable
value (ASD A5.2).
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Technical Note 41
Input Data

This Technical Note describes the steel frame design input data for AISC-
ASD89. The input can be printed to a printer or to a text file when you click
the File menu > Print Tables > Steel Frame Design command. A printout
of the input data provides the user with the opportunity to carefully review
the parameters that have been input into the program and upon which pro-
gram design is based.  Further information about using the Print Design Ta-
bles Form is provided at the end of this Technical Note.

Input Data
The program provides the printout of the input data in a series of tables. The
column headings for input data and a description of what is included in the
columns of the tables are provided in Table 1 of this Technical Note.

Table 1  Steel Frame Design Input Data
COLUMN HEADING DESCRIPTION
Material Property Data
Material Name Steel, concrete or other.

Material Type Isotropic or orthotropic.

Design Type Concrete, steel or none. Postprocessor available if steel is
specified.

Material Dir/Plane "All" for isotropic materials; specify axis properties define for
orthotropic.

Modulus of Elasticity

Poisson's Ratio

Thermal Coeff

Shear Modulus

Material Property Mass and Weight
Material Name Steel, concrete or other.
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Table 1  Steel Frame Design Input Data
COLUMN HEADING DESCRIPTION

Mass Per Unit Vol Used to calculate self mass of the structure.

Weight Per Unit Vol Used to calculate the self weight of the structure.

Material Design Data for Steel Materials
Material Name Steel.

Steel FY Minimum yield stress of steel.

Steel FU Maximum tensile stress of steel.

Steel Cost ($) Cost per unit weight used in composite beam design if optimum
beam size specified to be determined by cost.

Material Design Data for Concrete Materials
Material Name Concrete.

Lightweight Concrete Check this box if this is a lightweight concrete material.

Concrete FC Concrete compressive strength.

Rebar FY Bending reinforcing yield stress.

Rebar FYS Shear reinforcing yield stress.

Lightwt Reduc Fact Define reduction factor if lightweight concrete box checked.
Usually between 0.75 ad 0.85.

Frame Section Property Data
Frame Section Name User specified or auto selected member name.

Material Name Steel, concrete or none.

Section Shape Name
or Name in Section
Database File

Name of section as defined in database files.

Section Depth Depth of the section.

Flange Width Top Width of top flange per AISC database.

Flange Thick Top Thickness of top flange per AISC database.

Web Thick Web thickness per AISC database.

Flange Width Bot Width of bottom flange per AISC database.

Flange Thick Bot Thickness of bottom flange per AISC database.

Section Area



Steel Frame Design AISC-ASD89  Input Data

Input Data Technical Note 41 - 3

Table 1  Steel Frame Design Input Data
COLUMN HEADING DESCRIPTION

Torsional Constant

Moments of Inertia I33, I22

Shear Areas A2, A3

Section Moduli S33, S22

Plastic Moduli Z33, Z22

Radius of Gyration R33, R22

Load Combination Multipliers
Combo Load combination name.

Type Additive, envelope, absolute, or SRSS as defined in Define >
Load Combination.

Case Name(s) of case(s) to be included in this load combination.

Case Type Static, response spectrum, time history, static nonlinear, se-
quential construction.

Factor Scale factor to be applied to each load case.

Beam Steel Stress Check Element Information
Story Level Name of the story level.

Beam Bay Beam bay identifier.

Section ID Name of member section assigned.

Framing Type Moment frame or braced frame.

RLLF Factor Live load reduction factor.

L_Ratio Major Ratio of unbraced length divided by the total member length.

L_Ratio Minor Ratio of unbraced length divided by the total member length.

K Major Effective length factor.

K Minor Effective length factor.

Beam Steel Moment Magnification Overwrites

Story Level Name of the story level.

Beam Bay Beam bay identifier.

CM Major As defined in AISC-ASD, page 5-55.
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Table 1  Steel Frame Design Input Data
COLUMN HEADING DESCRIPTION

CM Minor As defined in AISC-ASD, page 5-55.

Cb Factor As defined in AISC-ASD, page 5-47.

Beam Steel Allowables & Capacities Overwrites

Story Level Name of the story level.

Beam Bay Beam bay identifier.

Fa If zero, yield stress defined for material property data used and
AISC-ASD specification Chapter E.

Ft If zero, as defined for material property data used and AISC-
ASD Chapter D.

Fb Major If zero, as defined for material property data used and AISC-
ASD specification Chapter F.

Fb Minor If zero, as defined for material property data used and AISC-
ASD specification Chapter F.

Fv Major If zero, as defined for material property data used and AISC-
ASD specification Chapter F.

Fv Minor If zero, as defined for material property data used and AISC-
ASD specification Chapter F.

Beam Steel Moment Magnification Overwrites

Story Level Name of the story level.

Beam Bay Beam bay identifier.

CM Major As defined in AISC-ASD, page 5-55.

CM Minor As defined in AISC-ASD, page 5-55.

Cb Factor As defined in AISC-ASD, page 5-47.

Column Steel Stress Check Element Information

Story Level Name of the story level.

Column Line Column line identifier.

Section ID Name of member sections assigned.

Framing Type Moment Frame or Braced Frame

RLLF Factor Live load reduction factor.
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Table 1  Steel Frame Design Input Data
COLUMN HEADING DESCRIPTION

L_Ratio Major Ratio of unbraced length divided by the total member length.

L_Ratio Minor Ratio of unbraced length divided by the total member length.

K Major Effective length factor.

K Minor Effective length factor.

Column Steel Moment Magnification Overwrites

Story Level Name of the story level.

Column Line Column line identifier.

CM Major As defined in AISC-ASD, page 5-55.

CM Minor As defined in AISC-ASD, page 5-55.

Cb Factor As defined in AISC-ASD, page 5-47.

Column Steel Allowables & Capacities Overwrites

Story Level Name of the story level.

Column Line Column line identifier.

Fa If zero, yield stress defined for material property data used and
AISC-ASD specification Chapter E.

Ft If zero, as defined for material property data used and AISC-
ASD Chapter D.

Fb Major If zero, as defined for material property data used and AISC-
ASD specification Chapter F.

Fb Minor If zero, as defined for material property data used and AISC-
ASD specification Chapter F.

Fv Major If zero, as defined for material property data used and AISC-
ASD specification Chapter F.

Fv Minor If zero, as defined for material property data used and AISC-
ASD specification Chapter F.

Using the Print Design Tables Form
To print steel frame design input data directly to a printer, use the File menu
> Print Tables > Steel Frame Design command and click the Input Sum-
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mary check box on the Print Design Tables form. Click the OK button to send
the print to your printer. Click the Cancel button rather than the OK button
to cancel the print. Use the File menu > Print Setup command and the
Setup>> button to change printers, if necessary.

To print steel frame design input data to a file, click the Print to File check box
on the Print Design Tables form. Click the Filename button to change the
path or filename. Use the appropriate file extension for the desired format
(e.g., .txt, .xls, .doc). Click the Save buttons on the Open File for Printing
Tables form and the Print Design Tables form to complete the request.

Note:

The File menu > Display Input/Output Text Files command is useful for displaying out-
put that is printed to a text file.

The Append check box allows you to add data to an existing file. The path and
filename of the current file is displayed in the box near the bottom of the Print
Design Tables form. Data will be added to this file. Or use the Filename
button to locate another file, and when the Open File for Printing Tables cau-
tion box appears, click Yes to replace the existing file.

If you select a specific frame element(s) before using the File menu > Print
Tables > Steel Frame Design command, the Selection Only check box will
be checked. The print will be for the selected beam(s) only.
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Output Details

This Technical Note describes the steel frame design output for AISC-ASD89
that can be printed to a printer or to a text file. The design output is printed
when you click the File menu > Print Tables > Steel Frame Design com-
mand and select Output Summary on the Print Design Tables form. Further
information about using the Print Design Tables form is provided at the end of
this Technical Note.

The program provides the output data in a table. The column headings for
output data and a description of what is included in the columns of the table
are provided in Table 1 of this Technical Note.

Table 1 Steel Frame Design Output
COLUMN HEADING DESCRIPTION

Beam Steel Stress Check Output

Story Level Name of the story level.

Beam Bay Beam bay identifier.

Section ID Name of member sections assigned.

Moment Interaction Check

Combo Name of load combination that produces maximum stress ratio.

Ratio Ratio of acting stress to allowable stress.

Axl Ratio of acting axial stress to allowable axial stress.

B33 Ratio of acting bending stress to allowable bending stress
about the 33 axis.

B22 Ratio of acting bending stress to allowable bending stress
about the 22 axis.
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Table 1 Steel Frame Design Output
COLUMN HEADING DESCRIPTION

Shear22

Combo Load combination that produces the maximum shear parallel to
the 22 axis.

Ratio Ratio of acting shear stress divided by allowable shear stress.

Shear33

Combo Load combination that produces the maximum shear parallel to
the 33 axis.

Ratio Ratio of acting shear stress divided by allowable shear stress.

Column Steel Stress Check Output

Story Level Name of the story level.

Column Line Column line identifier.

Section ID Name of member sections assigned.

Moment Interaction Check

Combo Name of load combination that produces maximum stress ratio.

Ratio Ratio of acting stress to allowable stress.

AXL Ratio of acting axial stress to allowable axial stress.

B33 Ratio of acting bending stress to allowable bending stress
about the 33 axis.

B22 Ratio of acting bending stress to allowable bending stress
about the 22 axis.

Shear22

Combo Load combination that produces the maximum shear parallel to
the 22 axis.
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Table 1 Steel Frame Design Output
COLUMN HEADING DESCRIPTION

Ratio Ratio of acting shear stress divided by allowable shear stress.

Shear33

Combo Load combination that produces the maximum shear parallel to
the 33 axis.

Ratio Ratio of acting shear stress divided by allowable shear stress.

Using the Print Design Tables Form
To print steel frame design output data directly to a printer, use the File
menu > Print Tables > Steel Frame Design command and click the Out-
put Summary check box on the Print Design Tables form. Click the OK button
to send the print to your printer. Click the Cancel button rather than the OK
button to cancel the print. Use the File menu > Print Setup command and
the Setup>> button to change printers, if necessary.

To print steel frame design output data to a file, click the Print to File check
box on the Print Design Tables form. Click the Filename button to change the
path or filename. Use the appropriate file extension for the desired format
(e.g., .txt, .xls, .doc). Click the Save buttons on the Open File for Printing
Tables form and the Print Design Tables form to complete the request.

Note:

The File menu > Display Input/Output Text Files command is useful for displaying out-
put that is printed to a text file.

The Append check box allows you to add data to an existing file. The path and
filename of the current file is displayed in the box near the bottom of the Print
Design Tables form. Data will be added to this file. Or use the Filename>>
button to locate another file, and when the Open File for Printing Tables cau-
tion box appears, click Yes to replace the existing file.
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If you select a specific frame element(s) before using the File menu > Print
Tables > Steel Frame Design command, the Selection Only check box will
be checked. The print will be for the selected beam(s) only.
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General and Notation

Introduction to the AISC-LRFD93 Series of Technical
Notes
The AISC-LRFD93 Steel Frame Design series of Technical Notes describes the
details of the structural steel design and stress check algorithms used by this
program when the user selects the AISC-LRFD93 design code. The various
notations used in this series are described herein.

The design is based on user-specified loading combinations. To facilitate use,
the program provides a set of default load combinations that should satisfy
requirements for the  design of most building type structures. See AISC-
LRFD93 Steel Frame Design Technical Note 46 Design Load Combinations for
more information.

In the evaluation of the axial force/biaxial moment capacity ratios at a station
along the length of the member, first, the actual member force/moment com-
ponents and the corresponding capacities are calculated for each load combi-
nation. Then, the capacity ratios are evaluated at each station under the in-
fluence of all load combinations using the corresponding equations that are
defined in this Technical Note. The controlling capacity ratio is then obtained.
A capacity ratio greater than 1.0 indicates exceeding a limit state. Similarly, a
shear capacity ratio is also calculated separately. Algorithms for completing
these calculations are described in AISC-LRFD93 Steel Frame Design Techni-
cal Note 48 Calculation of Factored Forces and Moments, Technical Note 49
Calculation of Nominal Strengths, and Technical Note 50 Calculation of Ca-
pacity Ratios.

Further information is available from AISC-LRFD93 Steel Frame Design Tech-
nical Note 47 Classification of Sections.

The program uses preferences and overwrites, which are described in AISC-
LRFD93 Steel Frame Design Technical Note 44 Preferences and Technical Note
45 Overwrites. It also provides input and output data summaries, which are
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described in AISC-LRFD93 Steel Frame Design Technical Note 51 Input Data
and Technical Note 52 Output Details.

Notation
A Cross-sectional area, in2

Ae Effective cross-sectional area for slender sections, in2

Ag Gross cross-sectional area, in2

Av2,Av3 Major and minor shear areas, in2

Aw Shear area, equal dtw per web, in2

B1 Moment magnification factor for moments not causing side-
sway

B2 Moment magnification factor for moments causing sidesway

Cb Bending coefficient

Cm Moment coefficient

Cw Warping constant, in6

D Outside diameter of pipes, in

E Modulus of elasticity, ksi

Fcr Critical compressive stress, ksi

Fr Compressive residual stress in flange assumed 10.0 for rolled
sections and 16.5 for welded sections, ksi

Fy Yield stress of material, ksi

G Shear modulus, ksi

I22 Minor moment of inertia, in4

I33 Major moment of inertia, in4

J Torsional constant for the section, in4
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K Effective length factor

K33,K22 Effective length K-factors in the major and minor directions

Lb Laterally unbraced length of member, in

Lp Limiting laterally unbraced length for full plastic capacity, in

Lr Limiting laterally unbraced length for inelastic lateral-torsional
buckling, in

Mcr Elastic buckling moment, kip-in

Mlt Factored moments causing sidesway, kip-in

Mnt Factored moments not causing sidesway, kip-in

Mn33,Mn22 Nominal bending strength in major and minor directions, kip-
in

Mob Elastic lateral-torsional buckling moment for angle sections,
kip-in

Mr33, Mr22 Major and minor limiting buckling moments, kip-in

Mu Factored moment in member, kip-in

Mu33, Mu22 Factored major and minor moments in member, kip-in

Pe Euler buckling load, kips

Pn Nominal axial load strength, kip

Pu Factored axial force in member, kips

Py AgFy, kips

Q Reduction factor for slender section, = QaQs   

Qa Reduction factor for stiffened slender elements

Qs Reduction factor for unstiffened slender elements

S Section modulus, in3
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S33,S22 Major and minor section moduli, in3

Seff,33,Seff,22 Effective major and minor section moduli for slender sections,
in3

Sc Section modulus for compression in an angle section, in3

Vn2,Vn3 Nominal major and minor shear strengths, kips

Vu2,Vv3 Factored major and minor shear loads, kips

Z Plastic modulus, in3

Z33,Z22 Major and minor plastic moduli, in3

b Nominal dimension of plate in a section, in
longer leg of angle sections,
bf  ― 2tw for welded and bf  ― 3tw for rolled box sections, etc.

be Effective width of flange, in

bf Flange width, in

d Overall depth of member, in

de Effective depth of web, in

hc Clear distance between flanges less fillets, in
assumed d ― 2k for rolled sections, and d ― 2tf for welded
sections

k Distance from outer face of flange to web toe of fillet, in

kc Parameter used for section classification,

 wth4 , 0.35 ≤ kc ≤ 0.763

l33,l22 Major and minor directions unbraced member lengths, in

r Radius of gyration, in

r33,r22 Radii of gyration in the major and minor directions, in

t Thickness, in
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tf Flange thickness, in

tw Thickness of web, in

βw Special section property for angles, in

λ Slenderness parameter

λc,λe Column slenderness parameters

λp Limiting slenderness parameter for compact element

λr Limiting slenderness parameter for non-compact element

λs Limiting slenderness parameter for seismic element

λslender Limiting slenderness parameter for slender element

ϕb Resistance factor for bending, 0.9

ϕc Resistance factor for compression, 0.85

ϕt Resistance factor for tension, 0.9

ϕv Resistance factor for shear, 0.9
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Preferences

This Technical Note describes the items in the Preferences form.

General
The steel frame design preferences in this program are basic assignments
that apply to all steel frame elements. Use the Options menu > Prefer-
ences > Steel Frame Design command to access the Preferences form
where you can view and revise the steel frame design preferences.

Default values are provided for all steel frame design preference items. Thus,
it is not required that you specify or change any of the preferences. You
should, however, at least review the default values for the preference items
to make sure they are acceptable to you.

Using the Preferences Form
To view preferences, select the Options menu > Preferences > Steel
Frame Design. The Preferences form will display.  The preference options
are displayed in a two-column spreadsheet. The left column of the spread-
sheet displays the preference item name. The right column of the spreadsheet
displays the preference item value.

To change a preference item, left click the desired preference item in either
the left or right column of the spreadsheet. This activates a drop-down box or
highlights the current preference value. If the drop-down box appears, select
a new value. If the cell is highlighted, type in the desired value. The prefer-
ence value will update accordingly. You cannot overwrite values in the drop-
down boxes.

When you have finished making changes to the composite beam preferences,
click the OK button to close the form. You must click the OK button for the
changes to be accepted by the program. If you click the Cancel button to exit
the form, any changes made to the preferences are ignored and the form is
closed.
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Preferences
For purposes of explanation, the preference items are presented in Table 1.
The column headings in the table are described as follows:

 Item: The name of the preference item as it appears in the cells at the
left side of the Preferences form.

 Possible Values: The possible values that the associated preference item
can have.

 Default Value: The built-in default value that the program assumes for
the associated preference item.

 Description: A description of the associated preference item.

Table 1: Steel Frame Preferences

Item
Possible
Values

Default
Value Description

Design Code Any code in the
program

AISC-
ASD89

Design code used for design of
steel frame elements.

Time History
Design

Envelopes,
Step-by-Step

Envelopes Toggle for design load combinations
that include a time history designed for
the envelope of the time history, or de-
signed step-by-step for the entire time
history. If a single design load combi-
nation has more than one time history
case in it, that design load combination
is designed for the envelopes of the
time histories, regardless of what is
specified here.

Frame Type Moment Frame,
Braced Frame

Moment
Frame

Stress Ratio
Limit

>0 0.95 Program will select members from the
auto select list with stress ratios less
than or equal to this value.

Maximum Auto
Iteration

≥1 1 Sets the number of iterations of the
analysis-design cycle that the program
will complete automatically assuming
that the frame elements have been as-
signed as auto select sections.
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Overwrites

General
The steel frame design overwrites are basic assignments that apply only to
those elements to which they are assigned. This Technical Note describes
steel frame design overwrites for AISC-LRFD93. To access the overwrites,
select an element and click the Design menu > Steel Frame Design >
View/Revise Overwrites command.

Default values are provided for all overwrite items. Thus, you do not need to
specify or change any of the overwrites. However, at least review the default
values for the overwrite items to make sure they are acceptable. When
changes are made to overwrite items, the program applies the changes only
to the elements to which they are specifically assigned; that is, to the ele-
ments that are selected when the overwrites are changed.

Overwrites
For explanation purposes in this Technical Note, the overwrites are presented
in Table 1. The column headings in the table are described as follows.

 Item: The name of the overwrite item as it appears in the program. To
save space in the forms, these names are generally short.

 Possible Values: The possible values that the associated overwrite item
can have.

 Default Value: The default value that the program assumes for the associ-
ated overwrite item. If the default value is given in the table with an asso-
ciated note "Program Calculated," the value is shown by the program before
the design is performed. After design, the values are calculated by the pro-
gram and the default is modified by the program-calculated value.

 Description: A description of the associated overwrite item.
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An explanation of how to change an overwrite is provided at the end of this
Technical Note.

Table 1 Steel Frame Design Overwrites

Item
Possible
Values

Default
Value Description

Current Design
Section

Indicates selected member size used in
current design.

Element Type Moment
Frame,

Braced Frame

From
Preferences

Live Load
Reduction

Factor
≥0 1

Live load is multiplied by this factor.

Horizontal
Earthquake

Factor
≥0 1

Earthquake loads are multiplied by this
factor.

Unbraced
Length Ratio

(Major)
≥0 1

Ratio of unbraced length divided by
total length.

Unbraced
Length Ratio
(Minor, LTB)

≥0 1
Ratio of unbraced length divided by
total length.

Effective
Length Factor

(K Major)
≥0 1

As defined in AISC-LRFD Table C-
C2.1, page 6-184.

Effective
Length Factor

(K Minor)
≥0 1

As defined in AISC-LRFD Table C-
C2.1, page 6-184.

Moment
Coefficient
(Cm Major)

≥0 0.85
As defined in AISC-LRFD specification
Chapter C.

Moment
Coefficient
(Cm Minor)

≥0 0.85
As defined in AISC-LRFD specification
Chapter C.

Bending
Coefficient

(Cb)
≥0 1

As defined in AISC-LRFD specification
Chapter F.
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Table 1 Steel Frame Design Overwrites

Item
Possible
Values

Default
Value Description

NonSway
Moment
Factor

(B1 Major)

≥0 1 As defined in AISC-LRFD specification
Chapter C.

NonSway
Moment
Factor

(B1 Minor)

≥0 1 As defined in AISC-LRFD specification
Chapter C.

Sway Moment
Factor

(B2 Major)

≥0 1 As defined in AISC-LRFD specification
Chapter C.

Sway Moment
Factor

(B2 Minor)

≥0 1 As defined in AISC-LRFD specification
Chapter C.

Yield stress, Fy ≥0 0 If zero, yield stress defined for material
property data used.

Compressive
Capacity,
phi*Pnc

≥0 0 If zero, as defined for Material Property
Data used and per AISC-LRFD specifi-
cation Chapter E.

Tensile
Capacity,
phi*Pnt

≥0 0 If zero, as defined for Material Property
Data used and per AISC-LRFD specifi-
cation Chapter D.

Major Bending
Capacity,
phi*Mn3

≥0 0 If zero, as defined for Material Property
Data used and per AISC-LRFD specifi-
cation Chapter F and G.

Minor Bending
Capacity,
phi*Mn2

≥0 0 If zero, as defined for Material Property
Data used and per AISC-LRFD specifi-
cation Chapter F and G.

Major Shear
Capacity,
phi*Vn2

≥0 0 If zero, as defined for Material Property
Data used and per AISC-LRFD specifi-
cation Chapter F.

Minor Shear
Capacity,
phi*Vn3

≥0 0 If zero, as defined for Material Property
Data used and per AISC-LRFD specifi-
cation Chapter F.
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Making Changes in the Overwrites Form
To access the steel frame overwrites, select a frame element and click the
Design menu > Steel Frame Design > View/Revise Overwrites com-
mand.

The overwrites are displayed in the form with a column of check boxes and a
two-column spreadsheet. The left column of the spreadsheet contains the
name of the overwrite item. The right column of the spreadsheet contains the
overwrites values.

Initially, the check boxes in the Steel Frame Design Overwrites form are all
unchecked and all of the cells in the spreadsheet have a gray background to
indicate that they are inactive and the items in the cells cannot be changed.
The names of the overwrite items are displayed in the first column of the
spreadsheet. The values of the overwrite items are visible in the second col-
umn of the spreadsheet if only one frame element was selected before the
overwrites form was accessed. If multiple elements were selected, no values
show for the overwrite items in the second column of the spreadsheet.

After selecting one or multiple elements, check the box to the left of an over-
write item to change it. Then left click in either column of the spreadsheet to
activate a drop-down box or highlight the contents in the cell in the right col-
umn of the spreadsheet. If the drop-down box appears, select a value from
the box. If the cell contents is highlighted, type in the desired value. The
overwrite will reflect the change. You cannot change the values of the drop-
down boxes.

When changes to the overwrites have been completed, click the OK button to
close the form. The program then changes all of the overwrite items whose
associated check boxes are checked for the selected members. You must click
the OK button for the changes to be accepted by the program. If you click the
Cancel button to exit the form, any changes made to the overwrites are ig-
nored and the form is closed.

Resetting Steel Frame Overwrites to Default Values
Use the Design menu > Steel Frame Design > Reset All Overwrites
command to reset all of the steel frame overwrites. All current design results
will be deleted when this command is executed.
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Important note about resetting overwrites: The program defaults for the
overwrite items are built into the program. The steel frame overwrite values
that were in a .edb file that you used to initialize your model may be different
from the built-in program default values. When you reset overwrites, the pro-
gram resets the overwrite values to its built-in values, not to the values that
were in the .edb file used to initialize the model.
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Technical Note 46
Design Load Combinations

The design load combinations are the various combinations of the load cases
for which the structure needs to be checked. For the AISC-LRFD93 code, if a
structure is subjected to dead load (DL), live load (LL), wind load (WL), and
earthquake induced load (EL), and considering that wind and earthquake
forces are reversible, the following load combinations may need to be defined
(LRFDA4.1):

1.4DL (LRFD A4-1)
1.2DL + 1.6LL (LRFD A4-2)

0.9DL ± 1.3WL (LRFD A4-6)
1.2DL ±  1.3WL (LRFD A4-4)
1.2DL + 0.5LL ± 1.3WL (LRFD A4-4)

0.9DL ± 1.0 EL (LRFD A4-6)
1.2DL ± 1.0 EL (LRFD A4-4)
1.2DL + 0.5LL ± EL (LRFD A4-4)

These are also the default design load combinations in the program whenever
the AISC-LRFD93 code is used. The user should use other appropriate loading
combinations if roof live load is separately treated, if other types of loads are
present, or if pattern live loads are to be considered.

Live load reduction factors can be applied to the member forces of the live
load case on an element-by-element basis to reduce the contribution of the
live load to the factored loading. See AISC-LRFD93 Steel Frame Design Tech-
nical Note 45 Overwrites for more information.

When using the AISC-LRFD93 code, the program design assumes that a P-
delta analysis has been performed so that moment magnification factors for
moments causing sidesway can be taken as unity. It is recommended that the
P-delta analysis be performed at the factored load level of 1.2DL plus 0.5LL
(White and Hajjar 1991).
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Reference
White, D.W. and J.F. Hajjar. 1991. Application of Second-Order Elastic Analy-

sis in LRFD:  Research to Practice. Engineering Journal. American In-
stitute of Steel Construction, Inc. Vol. 28. No. 4.
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Technical Note 47
Classification of Sections

This Technical Note explains the classification of sections when the user se-
lects the AISC-LRFD93 design code.

The nominal strengths for axial compression and flexure are dependent on
the classification of the section as Compact, Noncompact, Slender, or Too
Slender. The program classifies individual members according to the limiting
width/thickness ratios given in Table 1 and Table 2 (LRFD B5.1, A-G1, Table
A-F1.1). The definition of the section properties required in these tables is
given in Figure 1 and AISC-LRFD93 Steel Frame Design Technical Note 43
General and Notation. Moreover, special considerations are required regarding
the limits of width-thickness ratios for Compact sections in Seismic zones and
Noncompact sections with compressive force as given in Table 2. If the limits
for Slender sections are not met, the section is classified as Too Slender.
Stress check of Too Slender sections is beyond the scope of this pro-
gram.

In classifying web slenderness of I-shapes, Box, and Channel sections, it is
assumed that there are no intermediate stiffeners. Double angles are conser-
vatively assumed to be separated.
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Table 1 Limiting Width-Thickness Ratios for Classification of Sections in
Flexure Based on AISC-LRFD

Description
of Section

Check
λ

COMPACT
(λp)

NONCOMPACT
λr

SLENDER
(λslender)

bf / 2tf
(rolled)

≤ 65 / yF ≤ 141 / 0.10−yF No limit

bf / 2tf
(welded)

≤ 65 / yF ≤ 162 / 
c

y

k

F 5.16−
No limit

I-SHAPE

hc / tw

For Pu / ϕbPy ≤  0.125,

≤ 











ϕ
−

yb

u

y
P
P

F

75.2
1

640

For Pu / ϕbPy >  0.125,












ϕ
−

yb

u

y
P
P

F
33.2

191

 












ϕ
−

yb

u

P
P

F
74.01

970

260

)5.16(

000,14

≤

+yy FF

BOX b / tf
hc / tw

CHANNEL bf / tf
hc / tw

T-SHAPE bf / 2tf
d / tw

ANGLE b / t

DOUBLE-
ANGLE

(Separated)
b / t

PIPE D / t

ROUND
BAR 

RECTAN-
GULAR 

GENERAL 
≤

≥ 

yF

253

≤ 190 / 
yF

As for I-shapes

As for I-shapes
As for I-shapes

As for I-shapes
Not applicable

Not applicable

Not applicable

≤ 2,070 / Fy
  ≤
≤ 238 / 
yF

As for I-shapes

As for I-shapes
As for I-shapes

As for I-shapes
≤ 127 / 

yF

≤ 76 / 
yF

≤ 76 / 
yF

≤ 8,970 / 
yF

Assumed Compact

Assumed Compact

Assumed Compact
≤

Classification of Sections

No limit
≤ 970 / 

yF

No limit
As for I-shapes

No limit
No limit

No limit

No limit

≤ 13,000 / Fy

(Compression only)
No limit for flexure
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Table 2 Limiting Width-Thickness Ratios for Classification of Sections
(Special Cases) Based on AISC-LRFD

Description
of Section

Width-
Thickness

Ratio
λ

NONCOMPACT
(Uniform Compression)

(M22 ≈≈≈≈ M33 ≈≈≈≈ 0)
(λr)

bf / 2tf
(rolled)

≤ 95 / yF

bf / 2tf
(welded)

≤ 95 / yF
I-SHAPE

hc / tw ≤ 253 / yF

BOX b / tf
hc / tw

≤ 238 / yF

≤ 253 / yF

CHANNEL bf / tf
hc / tw

As for I-shapes
As for I-shapes

T-SHAPE bf / 2tf
d / tw

As for I-shapes

≤ 127 / yF

ANGLE b / t ≤ 76 / yF

DOUBLE-ANGLE
(Separated) b / t ≤ 76 / yF

PIPE D / t ≤ 3,300 / yF

ROUND BAR  Assumed Compact

RECTANGULAR  Assumed Noncompact

GENERAL  Assumed Noncompact
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AISC-LRFD93: Axes Conventions
2-2 is the cross section axis parallel to the webs,

the longer dimension of tubes,
the longer leg of single angles, or
the side by side legs of double angles.
This is the same as the y-y axis.

3-3 is orthogonal to 2-2. This is the same as the
x-x axis.

2, y

2, y

3, x3, x

Figure 1 AISC-LRFD Definition of Geometric Properties
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Technical Note 48
Calculation of Factored Forces and Moments

This Technical Note describes how the program calculates factored forces and
moments.

The factored member loads that are calculated for each load combination are
Pu, Mu33, Mu22, Vu2, and Vu3, corresponding to factored values of the axial load,
the major moment, the minor moment, the major direction shear force and
the minor direction force, respectively. These factored loads are calculated at
each of the previously defined stations.

For loading combinations that cause compression in the member, the factored
moment Mu (Mu33 and Mu22 in corresponding directions) is magnified to con-
sider second order effects. The magnified moment in a particular direction is
given by:

Mu = B1Mnt + B2Mlt, where (LRFD C1-1, SAM 6)

B1 = Moment magnification factor for non-sidesway moments,
B2 = Moment magnification factor for sidesway moments,
Mnt = Factored moments not causing sidesway, and
Mlt = Factored moments causing sidesway.

The moment magnification factors are associated with corresponding direc-
tions. The moment magnification factor B1 for moments not causing sidesway
is given by

B1 =
)/1( eu

m

PP
C

−
 ≥ 1.0, where (LRFD C1-2, SAM 6-2)

Pe is the Euler buckling load (Pe = 
2λ

ygFA
, with )

E

F

r
Kl y

π
=λ , and

Cm33 and Cm22 are coefficients representing distribution of moment along the
member length.
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Tec

1.00 if length is overwritten,

1.00 if tension member,

1.00 if end unrestrained,

0.6-0.4 aM
if no transverse loading

Th
les
is 

Th
B2

de
(L

Fo
th
ma
Eu

= )
Cm 
hnical Note 48 - 2 Calculation of Factored Fo

bM

0.85 if trans. load, end restrained

1.00 if trans. load, end unrestrained

Ma / Mb is the ratio of the smaller to the larger moment at th
member; Ma / Mb being positive for double curvature bendin
tive for single curvature bending. For tension members, Cm is
1.0. For compression members with transverse load on the m
assumed as 1.0 for members with any unrestrained end an
members with two unrestrained ends. When Mb is zero, Cm is 
The program defaults Cm to 1.0 if the unbraced length fac
member is redefined by either the user or the program, i.
braced length is not equal to the length of the member. T
overwrite the value of Cm for any member. Cm assumes two
and Cm33, associated with the major and minor directions.

e magnification factor B1 must be a positive number. Therefor
s than Pe. If Pu is found to be greater than or equal to Pe, a fai
declared.

e program design assumes the analysis includes P-delta effec
 is taken as unity for bending in both directions. It is suggeste
lta analysis be performed at the factored load level of 1.2 D
RFD C2.2). See also White an Hajjar (1991).

r single angles, where the principal axes of bending are not co
e geometric axes (2-2 and 3-3), the program conservativ
ximum of K22l22 and K33l33 for determining the major and m
ler buckling capacity.
(LRFD C1-3
rces and Moments

e ends of the
g and nega-
 assumed as
ember, Cm is

d as 0.85 for
taken as 1.0.
tor, l, of the
e., if the un-
he user can
 values, Cm22

e Pu must be
lure condition

ts; therefore,
d that the P-
L plus 0.5 LL

incident with
ely uses the
inor direction
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If the program assumptions are not satisfactory for a particular structural
model or member, the user has a choice of explicitly specifying the values of
B1 and B2 for any member.

Reference
White, D.W. and J. F. Hajjar. 1991. Application of Second-Order Elastic Analy-

sis in LRFD:  Research to Practice. Engineering Journal. American In-
stitute of Steel Construction, Inc. Vol. 28, No. 4.
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STEEL FRAME DESIGN AISC-LRFD93

Technical Note 49
Calculation of Nominal Strengths

This Technical Note describes how the program calculates nominal strengths
in compression, tension, bending, and shear for Compact, Noncompact, and
Slender sections.

Overview
The nominal strengths in compression, tension, bending, and shear are com-
puted for Compact, Noncompact, and Slender sections according to the fol-
lowing subsections. The nominal flexural strengths for all shapes of sections
are calculated based on their principal axes of bending. For the Rectangular,
I, Box, Channel, Circular, Pipe, T, and Double-angle sections, the principal
axes coincide with their geometric axes. For the Angle Sections, the principal
axes are determined and all computations except shear are based on that.

For Single-angle sections, the nominal shear strengths are calculated for di-
rections along the geometric axes. For all other sections, the shear stresses
are calculated along their geometric and principal axes.

The strength reduction factor, ϕ, is taken as follows (LRFD A5.3):

 ϕt = Resistance factor for tension, 0.9 (LRFD D1, H1, SAM 2, 6)
 ϕc = Resistance factor for compression, 0.85 (LRFD E2, E3, H1)
 ϕc = Resistance factor for compression in angles, 0.90 (LRFD SAM 4,6)
 ϕb = Resistance factor for bending, 0.9 (LRFD F1, H1, A-F1, A-G2, SAM 5)
 ϕv = Resistance factor for shear, 09 (LRFD F2, A-F2, A-G3, SAM 3)

If the user specifies nonzero factored strengths for one or more of the
elements on the Steel Frame Overwrites form, these values will over-
ride the calculated values for those elements. The specified factored
strengths should be based on the principal axes of bending.
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Compression Capacity
The nominal compression strength is the minimum value obtained from flex-
ural buckling, torsional buckling and flexural-torsional buckling. The strengths
are determined according to the following subsections.

For members in compression, if Kl/r is greater than 200, a message to that
effect is printed (LRFD B7, SAM 4). For single angles, the minimum radius of
gyration, rz, is used instead of r22 and r33 in computing Kl/r.

Flexural Buckling
The nominal axial compression strength, Pn, depends on the slenderness ra-
tio, Kl/r, and its critical value, λc, where

r
Kl

 = max 








22

2222

33

3333 ,
r

lK
r

lK
, and

λc = 
E

F

r
Kl y

π
. (LRFD E2-4, SAM 4)

For single angles, the minimum radius of gyration, rz, is used instead of r22

and r33 in computing Kl/r.

Pn for Compact or Noncompact sections is evaluated for flexural buckling as
follows:

Pn = AgFcr, where (LRFD E2-1)

Fcr = (0.658
2
cλ )Fy, for λc ≤ 1.5, and (LRFD E2-2)

Fcr = y
c

F












λ2

877.0
, for λc > 1.5 (LRFD E2-3)

Pn for Slender sections is evaluated for flexural buckling as follows:

Pn = AgFcr, where (LRFD A-B3d, SAM 4)

Fcr = Q(0.658
2
cQλ )Fy, for λc Q  ≤ 1.5, and (LRFD A-B5-15, SAM 4-1)



Steel Frame Design AISC-LRFD93  Calculation of Nominal Strengths

Calculation of Nominal Strengths Technical Note 49 - 3

Fcr = y
c

F












λ2

877.0
, for λc  Q  > 1.5 (LRFD E2-3)

The reduction factor, Q, for all compact and noncompact sections is taken as
1. For slender sections, Q is computed as follows:

Q = Qs Qa, where (LRFD A-B5-17, SAM 4)

Qs = reduction factor for unstiffened slender elements, and(LRFD A-B5.3a)

Qa = reduction factor for stiffened slender elements. (LRFD A-B5.3c)

The Qs factors for slender sections are calculated as described in Table 1
(LRFD A-B5.3a). The Qa factors for slender sections are calculated as the ratio
of effective cross-sectional area and the gross cross-sectional area (LRFD A-
B5.3c).

Qa =
s

e

A
A

(LRFD A-B5-14)

The effective cross-sectional area is computed based on effective width as
follows:

Ae = Ag - ∑(b-be)t

be for unstiffened elements is taken equal to b, and be for stiffened elements
is taken equal to or less than b as given in Table 2 (LRFD A-B5.3b). For webs
in I, Box, and Channel sections, he is used as be and h is used as b in the
above equation.

Flexural-Torsonal Buckling
Pn for flexural-torsional buckling of Double-angle and T-shaped compression
members whose elements have width-thickness ratios less than λr is given by

Pn = AgFcrft, where (LRFD E3-1)

Fcrft =












+
−−




 +
2

2

22

)(

4
11

2 crzcr

crzcrcrzcr

FF

HFF
H

FF
, where (LRFD E3-1)
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Table 1 Reduction Factor for Unstiffened Slender Elements, Qs

Section
Type

Reduction Factor for Unstiffened Slender Elements
(Qs)

Equation
Reference

1.0 if bf/2tf ≤  95 /
yF ,

Qs = 1.415 - 0.00437[bf/2tf] yF if 95 /
yF < bf/2tf <176 /

yF ,

20,000  / {[bf/2tf]2Fy} if bf/2tf ≥ 176 /
yF .

LRFD A-B5-5,
LRFD A-B5-6

I-SHAPE
1.0 if bf/2tf ≤ 109 /

cy kF

Qs = 1.415 - 0.00381[bf/2tf]
cy kF if 109 /

cy kF < bf/2tf <200 /
cy kF

26,200kc  / {[bf/2tf]2Fy} if bf/2tf ≥ 200 /
cy kF .

LRFD A-B5-7,
LRFD A-B5-8

BOX Qs = 1 LRFD A-B5.3d

CHANNEL As for I-shapes with bf  / 2tf replaced by bf / tf

LRFD A-B5-5,
LRFD A-B5-6,
LRFD A-B5-7,
LRFD A-B5-8

T-SHAPE

For flanges, as for flanges in I-shapes. For web, see below.
1.0 if d/tw ≤ 127 /

yF ,

Qs = 1.908 - 0.00715[d/tw] yF if 127 /
yF < d/tw <176 /

yF ,

20,000  / {[d/tw]2Fy} if d/tw  ≥ 176 /
yF .

LRFD A-B5-5,
LRFD A-B5-6,
LRFD A-B5-7,
LRFD A-B5-8,
LRFD A-B5-9,
LRFD A-B5-10

DOUBLE-
ANGLE

(Separated)

1.0 if b/t ≤ 76 /
yF ,

Qs = 1.340 - 0.00447[b/t]
yF if 76 /

yF < b/t <155 /
yF ,

15,500  / {[b/t]2Fy} if b/t  ≥ 155 /
yF .

LRFD A-B5-3
LRFD A-B5-4

ANGLE

1.0 if b/t ≤ 0.446 / EFy / ,

Qs = 1.34 - 0.761[b/t] EFy / if 0.446 EFy / < b/t <0.910 / EFy / ,

0.534  / {[b/t]2[Fy /E]} if b/t  ≥ 0.910 / EFy / .
LRFD SAM4-3

PIPE Qs = 1 LRFD A-B5.3d

ROUND
BAR Qs = 1 LRFD A-B5.3d

RECTAN-
GULAR Qs = 1 LRFD A-B5.3d

GENERAL Qs = 1 LRFD A-B5.3d
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Table 2 Effective Width for Stiffened Sections

Section
Type Effective Width for Stiffened Sections Equation

Reference

I-SHAPE

     h if
ft

h

w

253≤ ,

LRFD A-B5-12

BOX

CHANNEL

T-SHAPE

DOUBLE-
ANGLE

(Separated)

ANGLE

PIPE

ROUND
BAR

RECTAN-
GULAR

GENERAL

(compression only,  f = )
gA

P

he =











−

fthf

t

w

w

)(

2.57
1

326 if
ft

h

w

253>

     h if
ft

h

w

253≤ ,

t 2.57326 h 253 (compression only,  f = )
gA

P

he =







−
fthf w

w

)(
1 if

ftw
>

     b, if
ft

h

w

238≤ ,












−

ftbf

t

f

f

)(

9.64
1

326 if
ft

b

f

238>

LRFD A-B5-12

LRFD A-B5-11

     h if
ft

h

w

253≤ ,

LRFD A-B5-12(compression only,  f = )
P
he =
f Nominal Strengths












−

fthf

t

w

w

)(

2.57
1

326 if
ft

h

w

253>

be - b

be - b

be - b

     1, if
Ft

D 3,3≤

  
3
2

)(
100,1 +

yFtD
if

Ft
D 3,3>

Not applicable

be - b

Not applicable

=

(compr. or flexure,  f = Fy)

be =
LRFD A-B5.3B

LRFD A-B5.3B

LRFD A-B5.3B

y

00

y

00 LRFD A-B5-13

gA
(compression only)
Qa 
Technical Note 49 - 5



LRFD A-B5.3b


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Fcrz =
2
oAr

GJ

H = 1- 








 +
2

22

o

oo

r

yx
,

ro = Polar radius of gyration about the shear center,

xo, yo are the coordinates of the shear center with respect to the
centroid, xo = 0 for double angle and T-shaped members (y-
axis of symmetry),

Fcr2 is determined according to the equation LRFD E2-1 for flexural

buckling about the minor axis of symmetry for λc = 
E

F

r
Kl y

22π
.

Torsional and Flexural-Torsional Buckling
The strength of a compression member, Pn, determined by the limit states of
torsional and flexural-torsional buckling, is determined as follows:

Pn = AgFcr, where (LRFD A-E3-1)

Fcr = Q(0.658
2
eQλ )Fy, for λe Q ≤ 1.5, and (LRFD A-E3-2)

Fcr =












λ2

877.0

e

 Fy, for λe Q > 1.5. (LRFD A-E3-3)

In the above equations, the slenderness parameter λe is calculated as

λe =

e

y

F

F
, (LRFD A-E3-4)

where Fe is calculated as follows:

 For Rectangular, I, Box and Pipe sections:

Fe =
3322

2

2 1

)( II
GJ

lK

EC

zz

w

+










+

π
(LRFD A-E3-5)
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 For T-sections and Double-angles:

Fe =












+
−−




 +
2

22

2222

)(

4
11

2 eze

ezeeze

FF

HFF
H

FF
(LRFD A-E3-6)

 For Channels:

Fe =












+
−−




 +
2

33

3333

)(

4
11

2 eze

ezeeze

FF

HFF
H

FF
(LRFD A-E3-6)

 For Single-angle sections with equal legs:

Fe =












+
−−




 +
2

33

3333

)(

4
11

2 eze

ezeeze

FF

HFF
H

FF
(LRFD A-E3-6)

 For Single-angle sections with unequal legs, Fe is calculated as the mini-
mum real root of the following cubic equation (LRFD A-E3-7):

(Fe - Fe33)(Fe - Fe22)(Fe - Fez) - F
2
e (Fe-Fe22) 2

2

o

o

r

x
-F 2

e (Fe - Fe33) 2

2

o

o

r

y
= 0

where

xo,yo are the coordinates of the shear center with respect to the center-
oid, xo = 0 for double-angle and T-shaped members (y-axis sym-
metry),

ro =
g

oo A
II

yx 332222 +
++ = polar radius of gyration about the shear

center,

H = 1- 








 +
2

22

o

oo

r

yx
, (LRFD A-E3-9)

Fe33= 2
333333

2

)/( rlK

Eπ
(LRFD A-E3-10)
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Fe22= 2
222222

2

)/( rlK

Eπ
(LRFD A-E3-11)

Fez =
2
0

2

2 1

)( Ar
GJ

lK

EC

zz

w












+

π
(LRFD A-E3-12)

K22, K33 are effective length factors in minor and major directions,

Kz is the effective length factor for torsional buckling, and it is taken equal
to K22 in this program,

l22, l33 are effective lengths in the minor and major directions,

lz is the effective length for torsional buckling and it is taken equal to l22.

For angle sections, the principal moment of inertia and radii of gyration are
used for computing Fe. Also, the maximum value of Kl, i.e., max (K22,l22,
K33,l33), is used in place of K22l22 or K33l33 in calculating Fe22 and Fe33 in this
case.

Tension Capacity
The nominal axial tensile strength value Pn is based on the gross cross-
sectional area and the yield stress.

Pn = AgFy (LRFD D1-1)

It should be noted that no net section checks are made. For members
in tension, if l/r is greater than 300, a message to that effect is printed (LRFD
B7, SAM 2). For single angles, the minimum radius gyration, rz, is used in-
stead of r22 and r33 in computing Kl/r.

Nominal Strength in Bending
The nominal bending strength depends on the following criteria: the geomet-
ric shape of the cross-section; the axis of bending; the compactness of the
section; and a slenderness parameter for lateral-torsional buckling. The
nominal strengths for all shapes of sections are calculated based on their
principal axes of bending. For the Rectangular, I, Box, Channel, Circular, Pipe,
T, and Double-angle sections, the principal axes coincide with their geometric
axes. For the Single-angle sections, the principal axes are determined, and all
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computations related to flexural strengths are based on that. The nominal
bending strength is the minimum value obtained according to the limit states
of yielding, lateral-torsional buckling, flange local buckling, and web local
buckling, as follows:

Yielding
The flexural design strength of beams, determined by the limit state of yield-
ing, is:

Mp = ZFy ≤ 1.5 S Fy (LRFD F1-1)

Lateral-Torsional Buckling
Doubly Symmetric Shapes and Channels
For I, Channel, Box, and Rectangular shaped members bent around the major
axis, the moment capacity is given by the following equation (LRFD F1):

Mp33 if Lb ≤ Lp

Mn33 = Cb 






















−
−

−−
pr

pb
rpp LL

LL
MMM )( 333333  ≤ Mp33 if Lp < Lb ≤ Lr

Mcr33 ≤ Mp33 if Lb > Lr.

(LRFD F1-1, F1-2, F1-12)

where,

Mn33 = Nominal major bending strength

Mp33 = Major plastic moment, Z33Fy ≤ 1.5 S33Fy, (LRFD F1.1)

Mr33 = Major limiting buckling moment
(Fy - Fr)S33 for I-shapes and channels, (LRFD F1-7)
and FySeff,33 for rectangular bars and boxes (LRFD F1-11)

Mcr33 = Critical elastic moment,

w
bb

b CI
L
E

GJEI
L

C
22

2

22 




 π+
π

for I-shapes and

channels and (LRFD F1-13)
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22

000,57
rL

JAC

b

b  for boxes and rectangular bars (LRFD F1-14)

Lb = Laterally unbraced length, l22

Lp = Limiting laterally unbraced length for full plastic capacity,

yF

r22300
for I-shapes and channels, and (LRFD F1-4)

JA
M

r

p33

22750,3
for boxes and rectangular bars, (LRFD F1-5)

Lr = Limiting laterally unbraced length for
inelastic lateral-torsional buckling,

( )[ ] 2
1

2
1

2
2

122 11








−++
− ry

ry
FFX

FF
Xr

 for I-shapes and

channels, and (LRFD F1-6)

33

22000,57

rM
JAr

 for boxes and rectangular bars, (LRFD F1-10)

X1 =
233

EGJA
S
π

(LRFD F1-8)

X2 = 4
2

33

22






GJ
S

I
Cw (LRFD F1-9)

Cb =
cBA MMMM

M
3435.2

5.12

max

max

+++
 and (LRFD F1-3)

Mmax, MA, MB, and Mc are absolute values of maximum moment, 1/4 point,
center of span and 3/4 point major moments respectively, in the member. Cb

should be taken as 1.0 for cantilevers. However, the program is unable to
detect whether the member is a cantilever. The user should overwrite Cb
for cantilevers. The program also defaults Cb to 1.0 if the minor unbraced
length, l22, of the member is redefined by the user (i.e., it is not equal to the
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length of the member). The user can overwrite the value of Cb for any mem-
ber.

For I, Channel, Box, and Rectangular shaped members bent about the minor
axis, the moment capacity is given by the following equation:

Mn22 = Mp22 = Z22Fy ≤ 1.5S22Fy (LRFD F1)

For pipes and circular bars bent about any axis,

Mn = Mp = ZFy ≤ 1.5SFy. (LRFD F1)

T-Sections and Double-Angles
For T-shapes and Double-angles, the nominal major bending strength is given
as,

Mn33 = 



 ++

π 222 1 BB
L

GJEI

b
, where (LRFD F1-15)

Mn33 ≤ 1.5FyS33, for positive moment, stem in tension (LRFD F1.2c)

Mn33 ≤ FyS33, for negative positive moment, stem in
tension (LRFD F1.2c)

B = ± 2.3 
J

I
L
d

b

22 (LRFD F1-16)

The positive sign for B applies for tension in the stem of T-sections or the out-
standing legs of double angles (positive moments) and the negative sign ap-
plies for compression in stem or legs (negative moments).

For T-shapes and double-angles the nominal minor bending strength is as-
sumed as:

Mn22 = S22Fy.

Single Angles
The nominal strengths for Single-angles are calculated based on their princi-
pal axes of bending. The nominal major bending strength for Single-angles for
the limit state of lateral-torsional buckling is given as follows (LRFD SAM
5.1.3):
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Mn,major =











−

majory

ob

M
M

,
17.092.0 Mob ≤ 1.25 My,major, if Mob ≤ My,major

Mn,major =











−

ob

majory

M

M ,83.058.1 My,major ≤ 1.25 My,major, if Mob ≤ My,major

where,

My,major = yield moment about the major principal axis of bending, con-
sidering the possibility of yielding at the heel and both of the
leg tips,

Mob = elastic lateral-torsional buckling moment as calculated below.

The elastic lateral-torsional buckling moment, Mob, for equal-leg angles is
taken as

Mob = Cb
l

tEb 2246.0
(LRFD SAM 5-5)

and for unequal-leg angles, the Mob is calculated as

Mob = 4.9ECb 



 β++β ww rlt

l

I 2
min

2
2

min )/(052.0 (LRFD SAM 5-6)

where,

t = min (tw, tf)

l = max (l22, l33)

Imin = minor principal axis moment of inertia

Imax = major principal axis moment of inertia,

rmin = radius of gyration for minor principal axis,

βw = 







+∫ dAzwz

I A )(
1 22

max
 -2z0, (LRFD SAM 5.3.2)

z = coordinate along the major principal axis
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w = coordinate along the minor principal axis, and

z0 = coordinate of the shear center along the major principal axis
with respect to the centroid.

βw is a special section property for angles. It is positive for short leg in com-
pression, negative for long leg in compression, and zero for equal-leg angles
(LRFD SAM 5.3.2). However, for conservative design in this program, it is al-
ways taken as negative for unequal-leg angles.

General Sections
For General Sections the nominal major and minor direction bending
strengths are assumed as

Mn = S Fy.

Flange Local Buckling
The flexual design strength, Mn, of Noncompact and Slender beams for the
limit state of Flange Local Buckling is calculated as follows (LRFD A-F1):

For major direction bending,

Mp33 if λ ≤ λp,

Mn33 = Mp33 - (Mp33 - Mr33) 










λ−λ
λ−λ

pr

p if λp < λ ≤ λr, (A-F1-3)

Mcr33 ≤ Mp33 if λ > λr

and for minor direction bending,

Mp22 if λ ≤ λp,

Mn22 = Mp22 - (Mp22 - Mr22) 










λ−λ
λ−λ

pr

p if λp < λ ≤ λr, (A-F1-3)

Mcr22 ≤ Mp22 if λ > λr.

where,
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Mn33 = Nominal major bending strength,

Mn22 = Nominal minor bending strength,

Mp33 = Major plastic moment, Z33,Fy ≤ 1.5S33Fy,

Mp22 = Major plastic moment, Z22,Fy ≤ 1.5S22Fy,

Mr33 = Major limiting buckling moment,

Mr22 = Minor limiting buckling moment,

Mcr33 = Major buckling moment,

Mcr22 = Minor buckling moment,

λ = Controlling slenderness parameter,

λp = Largest value of λ for which Mn = Mp and

λr = Largest value of λ for which buckling is inelastic.

The parameters λ, λp, λr, Mr33,Mr22, Mcr33, and Mcr22 for flange local buckling for
different types of shapes are given below:

I Shapes, Channels

λ = 
f

f

t
b
2

, (for I sections) (LRFD B5.1, Table A-F1.1)

λ = 
f

f

t
b

, (for Channel sections) (LRFD B5.1, Table A-F1.1)

λp = 
yF

65
, (LRFD B5.1, Table A-F1.1)

ry FF −
141

, For rolled shape,

162

λr        =
cal Note 49 - 14 Calc

cry kFF /)( −
, For welded shape,
(LRFD Table A-F1.1)
ulation of Nominal Strengths
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Mr33 = (Fy - Fr) S33 (LRFD Table A-F1.1)

Mr22 = Fy S22 (LRFD Table A-F1.1)

2

000,20

λ
S33 For rolled shape

2

200,26

λ
ck

S33 For welded shape

2

000,20

λ
S22 For rolled shape

2

200,26

λ
ck

S22 For welded shape

10     ksi For rolled shape

16.5 ksi For welded shape

Boxes

f

wf

t
tb 3−

, For rolled shape,

f

wf

t
tb 2−

, For welded shape,

λp = 
yF

190
, (LRFD

λr = 
yF

238
, (LRFD

Mr33 = (Fy - Fr) Seff,33

Mr22 = (Fy - Fr) Seff,22

Mcr33 = Fy Seff,33 (Seff,33/S33)

Mcr22 = Fy Seff,22

= )

=

=

(LRFD Table A-F1.1
)
(LRFD Table A-F1.1
Mcr33  
Mcr22  
Fr       
 B5

 B5

(LR

(LR

(LR

(LR
(LRFD Table A-F1)
λ         =

(LRFD B5.1, Table A-F1.1)
Technical Note 49 - 15

.1, Table A-F1.1)

.1, Table A-F1.1)

FD Table A-F1.1)

FD Table A-F1.1)

FD Table A-F1.1)

FD Table A-F1.1)
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10     ksi For rolled shape

16.5 ksi For welded shape

T-Sec
No lo
gram
separ

Single
The n
pal ax
gle-an
(LRFD

where

=
Fr       
al Note 49 - 16 Calcula

Seff,33 = effective major section modulus considering sl

Seff,22 = effective minor section modulus considering sl

tions and Double Angles
cal buckling is considered for T-sections and Double-a
. If special consideration is required, the user is expect
ately.

s Angles
ominal strengths for Single-angles are calculated base
es of bending. The nominal major and minor bending 
gles for the limit state of flange local buckling are
 SAM 5.1.1):

1.25FySc if

FySc 









































−− 1

382.0

/
49.125.1

yF
E

tb if 0.382 
yF
E

QFySc if

,

Sc = section modulus for compression at the tip of on

t = thickness of the leg under consideration,

b = length of the leg under consideration, and
(LRFD Table A-F1)
enderness and

enderness.

ngles in this pro-
ed to analyze this

d on their princi-
strengths for Sin-
 given as follows

yF
E

t
b

382.0≤ ,

<
t
b ≤ 0.446 

yF
E

Mn  =
tion of Nominal Strengths

yF
E

t
b

446.0>

e leg,
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Q = strength reduction factor due to local buckling.

In calculating the bending strengths for single-angles for the limit state of
flange local buckling, the capacities are calculated for both the principal axes
considering the fact that either of the two tips can be under compression. The
minimum capacities are considered.

Pipe Sections

λ = 
t
D

(LRFD B Table A-F1.1)

λp = 
yF

070,2
, (LRFD Table A-F1.1)

λr = 
yF

970,8
, (LRFD Table A-F1.1)

Mr33 = Mr22 = 




 + yF

tD /
600

S (LRFD Table A-F1.1)

Mcr33 = Mcr22 = 






tD /
570,9

S (LRFD Table A-F1.1)

Circular, Rectangular, and General Sections
No consideration of local buckling is required for solid circular shapes or rec-
tangular plates (LRFD Table A-F1.1). No local buckling is considered in the
program for circular, rectangular, and general shapes. If special consideration
is required, the user is expected to analyze this separately.

Web Local Buckling
The flexural design strengths are considered in the program for only the ma-
jor axis bending (LRFD Table A-F1.1).

I Shapes, Channels, and Boxes
The flexural design strength for the major axis bending, Mn, of Noncompact
and Slender beams for the limit state of Web Local Buckling is calculated as
follows (LRFD A-F1-1, A-F1-3, A-G2-2):
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Mp33 if λ ≤ λp

Mp33 -(Mp33 - Mr33) 










λ−λ
λ−λ

pr

p if λp < λ ≤ λr, (A-F1, A-G1)

where

The w
Pu is 
Mn33  =
S33RPGReRcr if λ > λr

,

Mn33 = Nominal major bending strength,

Mp33 = Major plastic moment, Z33Fy≤1.5S33Fy (LRFD F1.1)

Mr33 = Major limiting buckling moment, ReS33Fy (LRFD Table A-F1.1)

λ = Web slenderness parameter,

λp = Largest value of λ for which Mn = Mp

λr = Largest value of λ for which buckling in inelastic

RPG = Plate girder bending strength reduction factor

Re = Hybrid girder factor, and

Fcr = Critical compression flange stress, ksi

eb slenderness parameters are computed as follows, where the value of
taken as positive for compression and zero for tension:

λ =
w

c

t
h












ϕ
−

yb

u

y
P

P

F
75.21

640
for 

yb

u

P
P

ϕ
≤ 0.125,



λp       =
al Note 49 - 18 Calculation of Nominal Strengths

yyb

u

y FP
P

F

253
33.2

191 ≥




 ϕ

for 
yb

u

P
P

ϕ
> 0.125, and
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λr 










ϕ
−

yb

u

y P
P

F
74.01

970
.

The parameters RPG, Re, and Fcr for slender web sections are calculated in the
program as follows:

RPG = 1- 











−

+ crw

c

r

r

Ft
h

a
a 970

300200,1
≤ 1.0 (LRFD A-G2-3)

Re =
r

r

a
mma

1212
)2(12 3

+
−+

 ≤ 1.0 (for hybrid sections) (LRFD A-G2)

Re = 1.0 (for non-hybrid section), where (LRFD A-G2)

ar = ≤ 1.0 , and (LRFD A-G2)

m =
min( cr

y

F

F

In the above ex
gram deals with 

The critical compressi
lated for limit states o
the corresponding slen

Fy

CpFy 





1

2η
PGC

The parameters η, ηp, 
I, Channel and Box se

η =
T

b

r
L

,

a

web area

ession fla
compr nge are
), yF
, taken as 1.0 (LRFD A-G2)

pression, Re is taken as 1, because currently the pro-
only non-hybrid girders.

on flange stress, Fcr, for slender web sections is calcu-
f lateral-torsional buckling and flange local buckling for
derness parameter η in the program as follows:

if η ≤ ηp







η−η
η−η

−
pr

p

2
1 ≤ Fy if ηp < η ≤ ηr, (LRFD A-G2-4, 5, 6)
Fcr  =
s Technical Note 49 - 19

if η > ηr

ηr, and CPG for lateral-torsional buckling for slender web
ctions are given as follows:

(LRFD A-G2-7)
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ηp =
yF

300
, (LRFD A-G2-8)

ηr =
yF

756
, (LRFD A-G2-9)

CPG = 286,000 Cb, and (LRFD A-G2-10)

rT = radius of gyration of the compression flange plus one-third of

the compression portion of the web, and it is taken as bf/ 12
in this program.

Cb = a factor that depends on span moment. It is calculated as fol-
lows:

cBA MMMM
M

3435.2
5.12

max

max

+++
(LRFD F1-3)

The parameters  η, ηp, ηr, and CPG for flange local buckling for slender web I,
Channel and Box sections are given as follows:

η =
t
b

, (LRFD A-G2-11)

ηp =
yF

65
, (LRFD A-G2-12)

ηr =
cy kF

230
, (LRFD A-G2-13)

CPG = 26,200 kc, and (LRFD A-G2-14)

Cb = 1. (LRFD A-G2-15)

T-Sections and Double-Angles
No local buckling is considered for T-sections and Double-angles in this pro-
gram. If special consideration is required, the user is expected to analyze this
separately.
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Single Angles
The nominal major and minor bending strengths for Single angles for the limit
state of web local buckling are the same as those given for flange local buck-
ling (LRFD SAM 5.1.1). No additional check is considered in this program.

Pipe Sections
The nominal major and minor bending strengths for Pipe sections for the limit
state of web local buckling are the same as those given for flange local buck-
ling (LRFD Table A-F1.1). No additional check is considered in this program.

Circular, Rectangular, and General Sections
No web local buckling is required for solid circular shapes and rectangular
plates (LRFD Table A-F1.1). No web local buckling is considered in the pro-
gram for circular, rectangular, and general shapes. If special consideration is
required, the user is expected to analyze them separately.

Shear Capacities
The nominal shear strengths are calculated for shears along the geometric
axes for all sections. For I, Box, Channel, T, Double angle, Pipe, Circular and
Rectangular sections, the principal axes coincide with their geometric axes.
For Single-angle sections, principal axes do not coincide with their geometric
axes.

Major Axis of Bending
The nominal shear strength, Vn2, for major direction shears in I-shapes, boxes
and channels is evaluated as follows:

For 
yw Ft

h 418≤ ,

Vn2 = 0.6 FyAw, (LRFD F2-1)

for 
ywy Ft

h

F

523418 ≤< ,

Vn2 = 0.6 Fy Aw 
wy t
h

F
/

418
, and (LRFD F2-2)
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for ,260
523 ≤<

wy t
h

F
,

Vn2 = 132,000 
[ ]2/ w

w

th

A
(LRFD F2-3 and A-F2-3)

The nominal shear strength for all other sections is taken as:

Vn2 = 0.6 FyAv2.

Minor Axis of Bending
The nominal shear strength for minor direction shears is assumed as:

Vn3 = 0.6 FyAv3.
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Technical Note 50
Calculation of Capacity Ratios

This Technical Note describes the calculation of capacity ratios when the user
selects the AISC-LRFD93 code, including axial and bending stresses and shear
stresses.

Overview
In the calculation of the axial force/biaxial moment capacity ratios, first, for
each station along the length of the member, the actual member
force/moment components are calculated for each load combination. Then the
corresponding capacities are calculated. Then, the capacity ratios are calcu-
lated at each station for each member under the influence of each of the de-
sign load combinations. The controlling capacity ratio is then obtained, along
with the associated station and load combination. A capacity ratio greater
than 1.0 indicates exceeding a limit state.

During the design, the effect of the presence of bolts or welds is not
considered. Also, the joints are not designed.

Axial and Bending Stresses
The interaction ratio is determined based on the ratio Pu/(ϕPn). If Pu is tensile,
Pn is the nominal axial tensile strength and ϕ = ϕt = 0.9; and if Pu is compres-
sive, Pn is the nominal axial compressive strength and  ϕ = ϕc = 0.85, except
for angle sections  ϕ = ϕc = 0.90 (LRFD SAM 6). In addition, the resistance
factor for bending, ϕb = 0.9.

For 
n

u

P
P

ϕ
≥ 0.2, the capacity ration if given as







ϕ

+
ϕ

+
ϕ 22

22

33

33

9
8

nb

u

nb

u

n

u

M
M

M
M

P
P

(LRFD H1-1a, SAM 6-1a)
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For 
n

u

P
P

ϕ
< 0.2, the capacity ration if given as







ϕ

+
ϕ

+
ϕ 22

22

33

33

2 nb

u

nb

u

n

u

M
M

M
M

P
P

(LRFD H1-1b, SAM 6-1a)

For circular sections, an SRSS (Square Root of Sum of Squares) combination
is first made of the two bending components before adding the axial load
component instead of the simple algebraic addition implied by the above for-
mulas.

For single-angle sections, the combined stress ratio is calculated based on the
properties about the principal axis (LRFD SAM 5.3, 6). For I, Box, Channel, T,
Double angle, Pipe, Circular, and Rectangular sections, the principal axes co-
incide with their geometric axes. For Single-angle sections, principal axes are
determined in the program. For general sections, it is assumed that the sec-
tion properties are given in terms of principal directions.

Shear Stresses
Similar to the normal stresses, from the factored shear force values and the
nominal shear strength values at each station for each of the load combina-
tions, shear capacity ratios for major and minor directions are calculated as
follows:

2

2

nv

u

V
V

ϕ
, and

3

3

nv

u

V
V

ϕ
,

where ϕv = 0.9.

For Single-angle sections, the shear stress ratio is calculated for directions
along the geometric axis. For all other sections, the shear stress is calculated
along the principal axes that coincides with the geometric axes.
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Technical Note 51
Input Data

This Technical Note describes the steel frame design input data for AISC-
LRFD93. The input can be printed to a printer or to a text file when you click
the File menu > Print Tables > Steel Frame Design command. A printout
of the input data provides the user with the opportunity to carefully review
the parameters that have been input into the program and upon which pro-
gram design is based.  Further information about using the Print Design Ta-
bles Form is provided at the end of this Technical Note.

Input Data
The program provides the printout of the input data in a series of tables. The
column headings for input data and a description of what is included in the
columns of the tables are provided in Table 1 of this Technical Note.

Table 1  Steel Frame Design Input Data
COLUMN HEADING DESCRIPTION
Material Property Data
Material Name Steel, concrete or other.

Material Type Isotropic or orthotropic.

Design Type Concrete, steel or none. Postprocessor available if steel is
specified.

Material Dir/Plane "All" for isotropic materials; specify axis properties define for
orthotropic.

Modulus of Elasticity

Poisson's Ratio

Thermal Coeff

Shear Modulus

Material Property Mass and Weight
Material Name Steel, concrete or other.
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Table 1  Steel Frame Design Input Data
COLUMN HEADING DESCRIPTION

Mass Per Unit Vol Used to calculate self mass of the structure.

Weight Per Unit Vol Used to calculate the self weight of the structure.

Material Design Data for Steel Materials
Material Name Steel.

Steel FY Minimum yield stress of steel.

Steel FU Maximum tensile stress of steel.

Steel Cost ($) Cost per unit weight used in composite beam design if optimum
beam size specified to be determined by cost.

Material Design Data for Concrete Materials
Material Name Concrete.

Lightweight Concrete Check this box if this is a lightweight concrete material.

Concrete FC Concrete compressive strength.

Rebar FY Bending reinforcing yield stress.

Rebar FYS Shear reinforcing yield stress.

Lightwt Reduc Fact Define reduction factor if lightweight concrete box checked.
Usually between 0.75 ad 0.85.

Frame Section Property Data
Frame Section Name User specified or auto selected member name.

Material Name Steel, concrete or none.

Section Shape Name
or Name in Section
Database File

Name of section as defined in database files.

Section Depth Depth of the section.

Flange Width Top Width of top flange per AISC database.

Flange Thick Top Thickness of top flange per AISC database.

Web Thick Web thickness per AISC database.

Flange Width Bot Width of bottom flange per AISC database.

Flange Thick Bot Thickness of bottom flange per AISC database.

Section Area
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Table 1  Steel Frame Design Input Data
COLUMN HEADING DESCRIPTION

Torsional Constant

Moments of Inertia I33, I22

Shear Areas A2, A3

Section Moduli S33, S22

Plastic Moduli Z33, Z22

Radius of Gyration R33, R22

Load Combination Multipliers
Combo Load combination name.

Type Additive, envelope, absolute, or SRSS as defined in Define >
Load Combination.

Case Name(s) of case(s) to be included in this load combination.

Case Type Static, response spectrum, time history, static nonlinear, se-
quential construction.

Factor Scale factor to be applied to each load case.

Code Preferences
Phi_bending Resistance factor for bending.

Phi_tension Resistance factor for tension.

Phi_compression Resistance factor for compression.

Phi_shear Resistance factor for shear.

Beam Steel Stress Check Element Information
Story Level Name of the story level.

Beam Bay Beam bay identifier.

Section ID Name of member section assigned.

Framing Type Moment frame or braced frame.

RLLF Factor Live load reduction factor.

L_Ratio Major Ratio of unbraced length divided by the total member length.

L_Ratio Minor Ratio of unbraced length divided by the total member length.

K Major Effective length factor.
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Table 1  Steel Frame Design Input Data
COLUMN HEADING DESCRIPTION

K Minor Effective length factor.

Beam Steel Moment Magnification Overwrites

Story Level Name of the story level.

Beam Bay Beam bay identifier.

CM Major As defined in AISC-LRFD specification Chapter C.

CM Minor As defined in AISC-LRFD specification Chapter C.

Cb Factor As defined in AISC-LRFD specification Chapter F.

B1 Major As defined in AISC-LRFD specification Chapter C.

B1 Minor As defined in AISC-LRFD specification Chapter C.

B2 Major As defined in AISC-LRFD specification Chapter C.

B2 Minor As defined in AISC-LRFD specification Chapter C.

Beam Steel Allowables & Capacities Overwrites

Story Level Name of the story level.

Beam Bay Beam bay identifier

phi*Pnc If zero, as defined for Material Property Data used and per
AISC-LRFD specification Chapter E.

phi*Pnt If zero, as defined for Material Property Data used and per
AISC-LRFD specification Chapter D.

phi*Mn Major If zero, as defined for Material Property Data used and per
AISC-LRFD specification Chapter F and G.

phi*Mn Minor If zero, as defined for Material Property Data used and per
AISC-LRFD specification Chapter F and G.

phi*Vn Major If zero, as defined for Material Property Data used and per
AISC-LRFD specification Chapter F.

phi*Vn Minor If zero, as defined for Material Property Data used and per
AISC-LRFD specification Chapter F.

Column Steel Stress Check Element Information

Story Level Name of the story level.

Column Line Column line identifier.
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Table 1  Steel Frame Design Input Data
COLUMN HEADING DESCRIPTION

Section ID Name of member section assigned.

Framing Type Moment frame or braced frame.

RLLF Factor Live load reduction factor.

L_Ratio Major Ratio of unbraced length divided by the total member length.

L_Ration Minor Ratio of unbraced length divided by the total member length.

K Major Effective length factor.

K Minor Effective length factor.

Column Steel Moment Magnification Overwrites

Story Level Name of the story level.

Column Line Column line identifier.

CM Major As defined in AISC-LRFD specification Chapter C.

CM Minor As defined in AISC-LRFD specification Chapter C.

Cb Factor As defined in AISC-LRFD specification Chapter F.

B1 Major As defined in AISC-LRFD specification Chapter C.

B1 Minor As defined in AISC-LRFD specification Chapter C.

B2 Major As defined in AISC-LRFD specification Chapter C.

B2 Minor As defined in AISC-LRFD specification Chapter C.

Column Steel Allowables & Capacities Overwrites

Story Level Name of the story level.

Column Line Column line identifier.

phi*Pnc If zero, as defined for Material Property Data used and per
AISC-LRFD specification Chapter E.

phi*Pnt If zero, as defined for Material Property Data used and per
AISC-LRFD specification Chapter D.

phi*Mn Major If zero, as defined for Material Property Data used and per
AISC-LRFD specification Chapter F and G.

phi*Mn Minor If zero, as defined for Material Property Data used and per
AISC-LRFD specification Chapter F and G.
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Table 1  Steel Frame Design Input Data
COLUMN HEADING DESCRIPTION

phi*Vn Major If zero, as defined for Material Property Data used and per
AISC-LRFD specification Chapter F.

phi*Vn Minor If zero, as defined for Material Property Data used and per
AISC-LRFD specification Chapter F.

Using the Print Design Tables Form
To print steel frame design input data directly to a printer, use the File menu
> Print Tables > Steel Frame Design command and click the Input Sum-
mary check box on the Print Design Tables form. Click the OK button to send
the print to your printer. Click the Cancel button rather than the OK button
to cancel the print. Use the File menu > Print Setup command and the
Setup>> button to change printers, if necessary.

To print steel frame design input data to a file, click the Print to File check box
on the Print Design Tables form. Click the Filename button to change the
path or filename. Use the appropriate file extension for the desired format
(e.g., .txt, .xls, .doc). Click the Save buttons on the Open File for Printing
Tables form and the Print Design Tables form to complete the request.

Note:

The File menu > Display Input/Output Text Files command is useful for displaying out-
put that is printed to a text file.

The Append check box allows you to add data to an existing file. The path and
filename of the current file is displayed in the box near the bottom of the Print
Design Tables form. Data will be added to this file. Or use the Filename
button to locate another file, and when the Open File for Printing Tables cau-
tion box appears, click Yes to replace the existing file.

If you select a specific frame element(s) before using the File menu > Print
Tables > Steel Frame Design command, the Selection Only check box will
be checked. The print will be for the selected beam(s) only.



Output Details Technical Note 52 - 1

©COMPUTERS AND STRUCTURES, INC., BERKELEY, CALIFORNIA DECEMBER 2001

STEEL FRAME DESIGN AISC-LRFD93

Technical Note 52
Output Details

This Technical Note describes the steel frame design output for AISC-LRFD93
that can be printed to a printer or to a text file. The design output is printed
when you click the File menu > Print Tables > Steel Frame Design com-
mand and select Output Summary on the Print Design Tables form. Further
information about using the Print Design Tables form is provided at the end of
this Technical Note.

The program provides the output data in a table. The column headings for
output data and a description of what is included in the columns of the table
are provided in Table 1 of this Technical Note.

Table 1 Steel Frame Design Output
COLUMN HEADING DESCRIPTION

Beam Steel Stress Check Output

Story Level Name of the story level.

Beam Bay Beam bay identifier.

Section ID Name of member sections assigned.

Moment Interaction Check

Combo Name of load combination that produces the maximum
load/resistance ratio.

Ratio Ratio of acting load to available resistance.

Axl Ratio of acting axial load to available axial resistance.

B33 Ratio of acting bending moment to available bending resistance
about the 33 axis.
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Table 1 Steel Frame Design Output
COLUMN HEADING DESCRIPTION

B22 Ratio of acting bending moment to available bending resistance
about the 22 axis.

Shear22

Combo Name of load combination that produces maximum stress ratio.

Ratio Ratio of acting shear divided by available shear resistance.

Shear33

Combo Load combination that produces the maximum shear parallel to
the 33 axis.

Ratio Ratio of acting shear divided by available shear resistance.

Column Steel Stress Check Output

Story Level Name of the story level.

Column Line Column line identifier.

Section ID Name of member sections assigned.

Moment Interaction Check

Combo Name of load combination that produces maximum stress ratio.

Ratio Ratio of acting stress to allowable stress.

AXL Ratio of acting axial stress to allowable axial stress.

B33 Ratio of acting bending stress to allowable bending stress
about the 33 axis.

B22 Ratio of acting bending stress to allowable bending stress
about the 22 axis.
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Table 1 Steel Frame Design Output
COLUMN HEADING DESCRIPTION

Shear22

Combo Load combination that produces the maximum shear parallel to
the 22 axis.

Ratio Ratio of acting shear stress divided by allowable shear stress.

Shear33

Combo Load combination that produces the maximum shear parallel to
the 33 axis.

Ratio Ratio of acting shear stress divided by allowable shear stress.

Using the Print Design Tables Form
To print steel frame design output data directly to a printer, use the File
menu > Print Tables > Steel Frame Design command and click the Out-
put Summary check box on the Print Design Tables form. Click the OK button
to send the print to your printer. Click the Cancel button rather than the OK
button to cancel the print. Use the File menu > Print Setup command and
the Setup>> button to change printers, if necessary.

To print steel frame design output data to a file, click the Print to File check
box on the Print Design Tables form. Click the Filename button to change the
path or filename. Use the appropriate file extension for the desired format
(e.g., .txt, .xls, .doc). Click the Save buttons on the Open File for Printing
Tables form and the Print Design Tables form to complete the request.

Note:

The File menu > Display Input/Output Text Files command is useful for displaying out-
put that is printed to a text file.

The Append check box allows you to add data to an existing file. The path and
filename of the current file is displayed in the box near the bottom of the Print
Design Tables form. Data will be added to this file. Or use the Filename but-
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ton to locate another file, and when the Open File for Printing Tables caution
box appears, click Yes to replace the existing file.

If you select a specific frame element(s) before using the File menu > Print
Tables > Steel Frame Design command, the Selection Only check box will
be checked. The print will be for the selected beam(s) only.
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